Results 1 to 8 of 8

Thread: NVidia drivers in repo for 11.1 2.6.27.25 kernel?

  1. #1
    Steve Barrell NNTP User

    Default NVidia drivers in repo for 11.1 2.6.27.25 kernel?

    I have been waiting very patiently to update my 11.1 x64 kernel from
    2.6.27.23-0.1-default to 2.6.27.25-0.1.1. I have been holding off for so
    long because I prefer to update my nvidia drivers (currently
    185.18.14_2.6.27.23_0.1-2.2) using the
    http://download.nvidia.com/opensuse/11.1 repository at the same time as the
    kernel update rather than the manual method - it's so much easier and less
    prone to cockpit error :-)

    Does anyone know if I should expect to see nvidia drivers in the repository
    for the newer 2.6.27.25 kernel sometime soon (next few weeks perhaps?) or
    how do I go about contacting Novell to see what's happening?

    Maybe it's vacation time for the nvidia driver kit builders and I just have
    to wait it out.

    Thanks,
    Steve.

  2. #2
    Join Date
    Jun 2008
    Location
    Charmoille, Switzerland
    Posts
    31

    Default Re: NVidia drivers in repo for 11.1 2.6.27.25 kernel?

    Hi Steve, I'm working also with the repo nvidia.

    And I've updated the kernel with the 2.6.27.25-0.1-pae long time ago now (yes in 32bits but it's like the same)

    modinfo about nvidia.ko say
    2.6.27.23-0.1-pae SMP mod_unload modversions 586

    It doesn't matter in this case to have a minor diff in fact the kernel is always a 2.6.27 version and the nvidia module should work out of the box.

    If there a 2.6.28 that's another story ...

  3. #3
    Join Date
    Apr 2009
    Location
    Washington (the state)
    Posts
    53

    Default Re: NVidia drivers in repo for 11.1 2.6.27.25 kernel?

    Using openSUSE 64 here, currently using kernel 2.6.27.25-0.1.1-x86_64 default with NVIDIA driver 185.18.14-2.2-x86_64. Have been since my last kernel update. Update applet says there's a new kernel out now. Haven't upgraded yet, but haven't ever had any problems in the past with previous kernel updates. Only time I have had to compile a custom nvidia kernel module is when I had a custom compiled kernel.

  4. #4
    Steve Barrell NNTP User

    Default Re: NVidia drivers in repo for 11.1 2.6.27.25 kernel?

    bruno friedmann wrote:

    >
    > Hi Steve, I'm working also with the repo nvidia.
    >
    > And I've updated the kernel with the 2.6.27.25-0.1-pae long time ago
    > now (yes in 32bits but it's like the same)
    >
    > modinfo about nvidia.ko say
    > 2.6.27.23-0.1-pae SMP mod_unload modversions 586
    >
    > It doesn't matter in this case to have a minor diff in fact the kernel
    > is always a 2.6.27 version and the nvidia module should work out of the
    > box.
    >
    > If there a 2.6.28 that's another story ...
    >
    >


    Many thanks Bruno. I just noticed this morning that there was a newer
    kernel: 2.6.27.29-0.1 and nvidia driver: 185.18.31_2.6.27.25_0.1-11.1

    I just updated them both along with alsa, gspca and other drivers and all is
    good!



  5. #5
    Steve Barrell NNTP User

    Default Re: NVidia drivers in repo for 11.1 2.6.27.25 kernel?

    herderofyaks wrote:

    >
    > Using openSUSE 64 here, currently using kernel 2.6.27.25-0.1.1-x86_64
    > default with NVIDIA driver 185.18.14-2.2-x86_64. Have been since my
    > last kernel update. Update applet says there's a new kernel out now.
    > Haven't upgraded yet, but haven't ever had any problems in the past with
    > previous kernel updates. Only time I have had to compile a custom
    > nvidia kernel module is when I had a custom compiled kernel.
    >
    >


    Hi herderofyaks,

    I had the nvidia 185.18.31 driver downloaded from the nvidia web site prior
    to my kernel update 30 minutes ago - just as a precaution - but I did not
    need it. Yast and the packages did their job correctly. It usually does, but
    I've had troubles in the past - more with suse 10.* with kernel and nvidia
    updates.



  6. #6
    -G- NNTP User

    Default Re: NVidia drivers in repo for 11.1 2.6.27.25 kernel?

    Steve Barrell wrote:

    > Many thanks Bruno. I just noticed this morning that there was a newer
    > kernel: 2.6.27.29-0.1 and nvidia driver: 185.18.31_2.6.27.25_0.1-11.1
    >
    > I just updated them both along with alsa, gspca and other drivers and all
    > is good!


    I did update last night on a laptop and the update produces a kernel panic
    error. (used to work fine before the update!).

    I checked the nvidia site and they have a v.185.18.36 which: "Fixed a bug
    that caused kernel panics when starting X on some mobile GPUs."
    (I have one and X locks with a black screen).

    I am waiting for the opensuse repo to have this update to reinstall the
    driver. There was no way to make the yast repo driver work on that machine.

    -G-


  7. #7
    Steve Barrell NNTP User

    Default Re: NVidia drivers in repo for 11.1 2.6.27.25 kernel?

    -G- wrote:

    > Steve Barrell wrote:
    >
    >> Many thanks Bruno. I just noticed this morning that there was a newer
    >> kernel: 2.6.27.29-0.1 and nvidia driver: 185.18.31_2.6.27.25_0.1-11.1
    >>
    >> I just updated them both along with alsa, gspca and other drivers and all
    >> is good!

    >
    > I did update last night on a laptop and the update produces a kernel panic
    > error. (used to work fine before the update!).
    >
    > I checked the nvidia site and they have a v.185.18.36 which: "Fixed a bug
    > that caused kernel panics when starting X on some mobile GPUs."
    > (I have one and X locks with a black screen).
    >
    > I am waiting for the opensuse repo to have this update to reinstall the
    > driver. There was no way to make the yast repo driver work on that
    > machine.
    >
    > -G-


    I just updated to 185.18.36 via the nvidia repo and all is well. I don't
    have a laptop - this is my home-built pc - a somewhat ageing Athlon 64 3500
    cpu (2.2Ghz, single core), 2GB ram, Western Digital Raptors, Nvidia 6600GT
    graphics.

  8. #8
    -G- NNTP User

    Default Re: NVidia drivers in repo for 11.1 2.6.27.25 kernel?

    Steve Barrell wrote:
    > I just updated to 185.18.36 via the nvidia repo and all is well. I don't
    > have a laptop - this is my home-built pc - a somewhat ageing Athlon 64
    > 3500 cpu (2.2Ghz, single core), 2GB ram, Western Digital Raptors, Nvidia
    > 6600GT graphics.


    I updated to v. *.36 and all is well here too.
    The *.31 was buggy on some chips.
    Cheers

    -G-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •