Results 1 to 5 of 5

Thread: How to install gcc-3.4?

  1. #1
    mhenno NNTP User

    Default How to install gcc-3.4?

    Hello,

    For specific needs, I need to use gcc-3.4.
    I get the last one (gcc-4.3.1) and I didn't find a way to install an older version. Implementing binary for direct install looks like complicated.
    Does anyone know an ftp address for rpm package that I can add to yast for installation? Or a better way to do?

    Thanks for your help

  2. #2

    Default Re: How to install gcc-3.4?

    Quote Originally Posted by mhenno View Post
    Hello,

    For specific needs, I need to use gcc-3.4.
    I get the last one (gcc-4.3.1) and I didn't find a way to install an older version. Implementing binary for direct install looks like complicated.
    Does anyone know an ftp address for rpm package that I can add to yast for installation? Or a better way to do?

    Thanks for your help
    If you go to yast package management, you will see gcc-3.3. You may have to add packman repository. Is there a special reason for 3.4 and not 3.3?

  3. #3
    mhenno NNTP User

    Default Re: How to install gcc-3.4?

    hi, under my Yast Package Manager I only see gcc-4.3.1.

    Where did you find the gcc-3.3?

    "Is there a special reason for 3.4 and not 3.3?"
    3.3 is fine, actually I just need gcc-3.X

    I also had a look to: Software.openSUSE.org, and I didn't find a rpm for gcc-3.X
    I'm using a x86_64 architecture, is that restrictive for this?

    Thanks again.

  4. #4
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    301

    Default Re: How to install gcc-3.4?

    Hi,

    you can find the repository here:
    Index of /repositories/devel:/gcc/openSUSE_11.1

    Hope that helps

  5. #5

    Default Re: How to install gcc-3.4?

    Quote Originally Posted by mhenno View Post
    hi, under my Yast Package Manager I only see gcc-4.3.1.

    Where did you find the gcc-3.3?

    "Is there a special reason for 3.4 and not 3.3?"
    3.3 is fine, actually I just need gcc-3.X

    I also had a look to: Software.openSUSE.org, and I didn't find a rpm for gcc-3.X
    I'm using a x86_64 architecture, is that restrictive for this?

    Thanks again.
    All I did was type in gcc in the search box. gcc-3.3 is in the standard oss repository, independent of architecture. Make sure you have this repository enabled in Yast. Downloading individual rpms and installing manually does not take care of dependencies. Yast takes care of it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •