Results 1 to 3 of 3

Thread: atheros wireless not working

  1. #1
    ycherfas NNTP User

    Default atheros wireless not working

    Hi you all.
    I just installed the opensuse 11.1 with gnome and I can't make the wireless getting work.I am new with linux and tryied to look in the forum for solution but could't find any.
    I have AR242x 802.11abg Wriless PCI Express Adapter
    this is huge problem for me...
    thx.
    Last edited by ycherfas; 11-Aug-2009 at 00:30. Reason: more info

  2. #2
    ycherfas NNTP User

    Default Re: atheros wireless not working

    this are my results...

    ycherfas@linux-pprs:~> /sbin/lspci
    00:00.0 Host bridge: ATI Technologies Inc Device 5a31 (rev 01)
    00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
    00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
    00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
    00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
    00:07.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
    00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
    00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
    00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
    00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
    00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
    00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
    00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
    00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 13)
    00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
    00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
    00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
    00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
    01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
    02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
    08:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
    08:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
    08:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 08)
    08:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

    00:00.0 0600: 1002:5a31 (rev 01)
    00:01.0 0604: 1002:5a3f
    00:04.0 0604: 1002:5a36
    00:05.0 0604: 1002:5a37
    00:06.0 0604: 1002:5a38
    00:07.0 0604: 1002:5a39
    00:12.0 0106: 1002:4380
    00:13.0 0c03: 1002:4387
    00:13.1 0c03: 1002:4388
    00:13.2 0c03: 1002:4389
    00:13.3 0c03: 1002:438a
    00:13.4 0c03: 1002:438b
    00:13.5 0c03: 1002:4386
    00:14.0 0c05: 1002:4385 (rev 13)
    00:14.1 0101: 1002:438c
    00:14.2 0403: 1002:4383
    00:14.3 0601: 1002:438d
    00:14.4 0604: 1002:4384
    01:05.0 0300: 1002:5a62
    02:00.0 0200: 168c:001c (rev 01)
    08:01.0 0607: 1180:0476 (rev b3)
    08:01.1 0805: 1180:0822 (rev 17)
    08:01.2 0880: 1180:0592 (rev 08)
    08:07.0 0200: 10ec:8139 (rev 10)


    Yenta: Raising subordinate bus# of parent bus (#08) from #09 to #0c
    pcmcia: parent PCI bridge I/O window: 0xa000 - 0xbfff
    cs: IO port probe 0xa000-0xbfff: clean.
    pcmcia: parent PCI bridge Memory window: 0xfca00000 - 0xfeafffff
    pcmcia: parent PCI bridge Memory window: 0xcff00000 - 0xdfefffff
    vendor=1002 device=5a36
    ath5k_pci 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    ath5k_pci 0000:02:00.0: setting latency timer to 64
    ath5k_pci 0000:02:00.0: registered as 'phy0'
    phy0: Selected rate control algorithm 'pid'
    ath5k phy0: Atheros AR2424 chip found (MAC: 0xa0, PHY: 0x61)
    HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    cs: IO port probe 0x100-0x3af: clean.
    cs: IO port probe 0x3e0-0x4ff: clean.
    cs: IO port probe 0x820-0x8ff: clean.
    cs: IO port probe 0xc00-0xcf7: clean.
    cs: IO port probe 0xa00-0xaff: clean.


    ycherfas@linux-pprs:~/Desktop> /usr/sbin/iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11bg ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    ycherfas@linux-pprs:~/Desktop> sudo /usr/sbin/iwlist scan
    root's password:
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wmaster0 Interface doesn't support scanning.

    wlan0 No scan results

    pan0 Interface doesn't support scanning.

  3. #3
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: atheros wireless not working

    wlan0 IEEE 802.11bg ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Looks to me you haven't associated with any wireless points.click on network manager - new connection - select wireless device follow the instructions. At the end, click on save NOT connect & save. then, click on network manager, select the access point from the list & you should be able to connect

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •