Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Cannot Install KDE4 Patches

  1. #1

    Default Cannot Install KDE4 Patches

    I have been trying for months now to install the following patches:
    kde4-akonadi kde4-dolphin

    But everytime I try I get the error:
    ================
    Code:
    Removing kdebase4-nsplugin-4.1.3-3.7 [error]
    Removal of (56980)kdebase4-nsplugin-4.1.3-3.7.i586(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package kdebase4-nsplugin-4.1.3-3.7.i586 is not installed
    
    
    Removing kdepim4-wizards-4.1.3-3.13 [error]
    Removal of (56995)kdepim4-wizards-4.1.3-3.13.i586(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package kdepim4-wizards-4.1.3-3.13.i586 is not installed
    ================

    I have tried removing all of KDE and reinstalling it and downgrading the packages above to those specific versions so that they can be "removed" by the patch upgrade. Nothing works.

    Please tell me how I can fix this.

    Thanks,
    Jeff

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot Install KDE4 Patches

    Post the result of these from a terminal:

    Code:
    zypper lr -d
    Now become su and do

    Code:
    zypper lu
    Paste results of both here:
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Cannot Install KDE4 Patches

    Here are the results:
    Code:
    scorcher:/home/jeff # zypper lr -d
    #  | Alias                 | Name                      | Enabled | Refresh | Priority | Type   | URI                                                     | Service
    ---+-----------------------+---------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------+--------
    1  | Libdvdcss repository  | Libdvdcss repository      | Yes     | Yes     |   99     | rpm-md | http://suse.linuxin.dk/repo/11.1/                                         |
    2  | home:HessiJames       | home:HessiJames           | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/HessiJames/openSUSE_11.1/ |
    3  | openSUSE-11.1-Updates | openSUSE-11.1-Updates     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1                                  |
    4  | repo                  | Main Repository (NON-OSS) | No      | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/              |
    5  | repo-debug            | openSUSE-11.1-Debug       | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/debug/distribution/11.1/repo/oss/            |
    6  | repo-source           | openSUSE-11.1-Source      | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/           |
    7  | repo_1                | Main Repository (OSS)     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                  |
    8  | repo_2                | Main Update Repository    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/                                 |
    9  | repo_3                | Packman Repository        | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/                               |
    10 | repo_4                | ATI Repository            | Yes     | Yes     |   99     | rpm-md | http://www2.ati.com/suse/11.1                                             |
    scorcher:/home/jeff # zypper lu
    Download (curl) error for 'http://download.opensuse.org/source/distribution/11.1/repo/oss/content':
    
    Loading repository data...
    Reading installed packages...
    No updates found.
    Jeff

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot Install KDE4 Patches

    Please change as shown in red

    Quote Originally Posted by jlmarkus View Post
    Here are the results:
    Code:
    scorcher:/home/jeff # zypper lr -d
    #  | Alias                 | Name                      | Enabled | Refresh | Priority | Type   | URI                                                     | Service
    ---+-----------------------+---------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------+--------
    1  | Libdvdcss repository  | Libdvdcss repository      | No     | No     |   99     | rpm-md | http://suse.linuxin.dk/repo/11.1/                                         |
    2  | home:HessiJames       | home:HessiJames           | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/HessiJames/openSUSE_11.1/ |
    3  | openSUSE-11.1-Updates | openSUSE-11.1-Updates     | Yes     | Yes     |   20     | rpm-md | http://download.opensuse.org/update/11.1                                  |
    4  | repo                  | Main Repository (NON-OSS) | Yes      | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/              |
    5  | repo-debug            | openSUSE-11.1-Debug       | No     | Yes     |  100     | yast2  | http://download.opensuse.org/debug/distribution/11.1/repo/oss/            |
    6  | repo-source           | openSUSE-11.1-Source      | No     | Yes     |  100     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/           |
    7  | repo_1                | Main Repository (OSS)     | Yes     | Yes     |   120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                        |
    9  | repo_3                | Packman Repository        | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/                               |
    10 | repo_4                | ATI Repository            | Yes     | Yes     |   99     | rpm-md | http://www2.ati.com/suse/11.1                                             |
    scorcher:/home/jeff # zypper lu
    Download (curl) error for 'http://download.opensuse.org/source/distribution/11.1/repo/oss/content':
    
    Loading repository data...
    Reading installed packages...
    No updates found.
    Jeff
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Cannot Install KDE4 Patches

    I updated the repository as you indicated, but I still get the same errors when I run online update (or zypper patch).

    What else can I do?

    Thanks,
    Jeff

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot Install KDE4 Patches

    Post your repos again

    Code:
    zypper lr -d
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Cannot Install KDE4 Patches

    Code:
    scorcher:/home/jeff # zypper lr -d
    #  | Alias                 | Name                      | Enabled | Refresh | Priority | Type   | URI                                                     | Service
    ---+-----------------------+---------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------+--------
    1  | Libdvdcss repository  | Libdvdcss repository      | No      | No      |   99     | rpm-md | http://suse.linuxin.dk/repo/11.1/                                         |
    2  | home:HessiJames       | home:HessiJames           | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/HessiJames/openSUSE_11.1/ |
    3  | openSUSE-11.1-Updates | openSUSE-11.1-Updates     | Yes     | Yes     |   20     | rpm-md | http://download.opensuse.org/update/11.1                                  |
    4  | repo                  | Main Repository (NON-OSS) | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/              |
    5  | repo-debug            | openSUSE-11.1-Debug       | No      | Yes     |  100     | yast2  | http://download.opensuse.org/debug/distribution/11.1/repo/oss/            |
    6  | repo-source           | openSUSE-11.1-Source      | No      | Yes     |  100     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/           |
    7  | repo_1                | Main Repository (OSS)     | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                  |
    8  | repo_2                | Main Update Repository    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/                                 |
    9  | repo_3                | Packman Repository        | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/                               |
    10 | repo_4                | ATI Repository            | Yes     | Yes     |   99     | rpm-md | http://www2.ati.com/suse/11.1                                             |
    scorcher:/home/jeff #

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot Install KDE4 Patches

    Quote Originally Posted by jlmarkus View Post
    Code:
    scorcher:/home/jeff # zypper lr -d
    #  | Alias                 | Name                      | Enabled | Refresh | Priority | Type   | URI                                                     | Service
    ---+-----------------------+---------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------+--------
    1  | Libdvdcss repository  | Libdvdcss repository      | No      | No      |   99     | rpm-md | http://suse.linuxin.dk/repo/11.1/                                         |
    2  | home:HessiJames       | home:HessiJames           | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/HessiJames/openSUSE_11.1/ |
    3  | openSUSE-11.1-Updates | openSUSE-11.1-Updates     | Yes     | Yes     |   20     | rpm-md | http://download.opensuse.org/update/11.1                                  |
    4  | repo                  | Main Repository (NON-OSS) | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/              |
    5  | repo-debug            | openSUSE-11.1-Debug       | No      | Yes     |  100     | yast2  | http://download.opensuse.org/debug/distribution/11.1/repo/oss/            |
    6  | repo-source           | openSUSE-11.1-Source      | No      | Yes     |  100     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/           |
    7  | repo_1                | Main Repository (OSS)     | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                  |
    8  | repo_2                | Main Update Repository    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/                                 |
    9  | repo_3                | Packman Repository        | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/                               |
    10 | repo_4                | ATI Repository            | Yes     | Yes     |   99     | rpm-md | http://www2.ati.com/suse/11.1                                             |
    scorcher:/home/jeff #
    Please delete this duplicate.

    See what happens, but tell me where are you seeing these update/patches? Is it in Yast - Online Update
    or the Auto Updater in the sys tray?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Cannot Install KDE4 Patches

    I deleted the duplicate. Same thing happens. The patch shows up in "Online Update" and the Updater in the tray and "zypper patch" as shown below.

    Code:
    scorcher:/home/jeff # zypper lr -d
    # | Alias                 | Name                      | Enabled | Refresh | Priority | Type   | URI                                                                       | Service                                                         
    --+-----------------------+---------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------+--------                                                         
    1 | Libdvdcss repository  | Libdvdcss repository      | No      | No      |   99     | rpm-md | http://suse.linuxin.dk/repo/11.1/                                         |                                                                 
    2 | home:HessiJames       | home:HessiJames           | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/HessiJames/openSUSE_11.1/ |                                                                 
    3 | openSUSE-11.1-Updates | openSUSE-11.1-Updates     | Yes     | Yes     |   20     | rpm-md | http://download.opensuse.org/update/11.1                                  |
    4 | repo                  | Main Repository (NON-OSS) | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/              |
    5 | repo-debug            | openSUSE-11.1-Debug       | No      | Yes     |  100     | yast2  | http://download.opensuse.org/debug/distribution/11.1/repo/oss/            |
    6 | repo-source           | openSUSE-11.1-Source      | No      | Yes     |  100     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/           |
    7 | repo_1                | Main Repository (OSS)     | Yes     | Yes     |  120     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                  |
    8 | repo_3                | Packman Repository        | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/                               |
    9 | repo_4                | ATI Repository            | Yes     | Yes     |   99     | rpm-md | http://www2.ati.com/suse/11.1                                             |
    scorcher:/home/jeff # zypper patch
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW patches are going to be installed:
      kde4-akonadi kde4-dolphin
    
    
    The following packages are going to be REMOVED:
      kdebase4-nsplugin kdepim4-wizards
    
    
    After the operation, 1007.0 K will be freed.
    Continue? [YES/no]:
    Removing kdebase4-nsplugin-4.1.3-3.7 [error]
    Removal of (36123)kdebase4-nsplugin-4.1.3-3.7.i586(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package kdebase4-nsplugin-4.1.3-3.7.i586 is not installed
    
    
    Abort, retry, ignore? [A/r/i]: i
    Removing kdepim4-wizards-4.1.3-3.13 [error]
    Removal of (36138)kdepim4-wizards-4.1.3-3.13.i586(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package kdepim4-wizards-4.1.3-3.13.i586 is not installed
    
    
    Abort, retry, ignore? [A/r/i]: i
    scorcher:/home/jeff #

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot Install KDE4 Patches

    Open a su terminal and do:

    Code:
    zypper ref
    then

    Code:
    zypper up
    For eg this:
    kdebase4-nsplugin and the version you are reporting are old and are showing updates are avail according to my list. So do the above ans report back.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •