Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Login Problems

  1. #1

    Default Login Problems

    Hello,

    I've got a weird problem with my Open Suse 11.1 (Kernel 2.6.27) installation. Everything used to work perfectly, but for some time now I've had the following problem which I've been unable to solve yet:

    When a user tries to login, the system accepts the password and displays 'Have a lot of fun...'. So far, so good. However the users don't get to the shell, but immediately find themselves in some yast basic menu without any options to choose from. Hitting the enter button (which is the only option) logs the user out again. The only thing that works is logging in as 'root', which I generally tend to avoid.

    I already checked /etc/passwd but couldnt find anything there, the users are set to /bin/bash, just as root.

    Since I've got no idea how to fix the problem, I do hope that you can help me.

    Cheers,
    ajoram

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Login Problems

    A silly question - how much hard disk memory do you have free?

    My wife ran into something similiar a while back when she simply never emptied the trash on her Linux, and eventually her user account filed the hard drive.

  3. #3

    Default Re: Login Problems

    There're are still 16GB available. so I don't think this is the cause of the problem.

    I uploaded a screenshot of the (empty) menu I get to after login in as 'schof' to our website:

    http://schof-gmbh.de/opensuse.jpg

    Don't get confused that it's in German - as you can see it's some kind of basic menu with no options to choose from. And yeah, I'm running OpenSuse 11.1 in VmWare Server 1.05 on a Windows 2003 Server system.

    I've just created a new user account and when I logged in I had the SAME problem. I'm confused.

    Cheers,
    ajoram

  4. #4
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Login Problems

    ajoram adjusted his/her AFDB on Monday 10 Aug 2009 16:46 to write:

    >
    > There're are still 16GB available. so I don't think this is the cause of
    > the problem.
    >
    > I uploaded a screenshot of the (empty) menu I get to after login in as
    > 'schof' to our website:
    >
    > http://schof-gmbh.de/opensuse.jpg
    >
    > Don't get confused that it's in German - as you can see it's some kind
    > of basic menu with no options to choose from. And yeah, I'm running
    > OpenSuse 11.1 in VmWare Server 1.05 on a Windows 2003 Server system.
    >
    > Cheers,
    > ajoram
    >
    >


    And for us ignorant people, what does it say?

    :-)

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  5. #5

    Default Re: Login Problems

    Oh, it just says 'Basic Menu' in the headline and 'User:Schof'.

    In the bottom line it says 'Pick one of the key numbers from above or press <ENTER> to exit'. Without any key numbers available, all I can do is exit.

  6. #6
    goldie NNTP User

    Default Re: Login Problems

    > http://schof-gmbh.de/opensuse.jpg

    first: you didn't mention that the openSUSE is running in a VM under
    Windows...i know that is possible, but why would anyone do that, ever?

    second: in your first posting you call what i see in the jpg "some
    yast basic menu"...but, i have to say in all my years i've never ever
    seen a menu offered by YaST (or Linux) which looked like this one..

    SO, i have to ask you have YOU ever seen a menu like this that HAD
    numbers available to pick from?? I ask because whatever (probably
    added) program that is throwing up this menu has some sort of fault..

    maybe the answer to my first question (WHY run Linux inside of M$?) is
    this is a course in Linux command line/shell..

    AND, maybe the course *has* a menu driven navigation and the student
    may pick from a range of topics..

    what i'm getting at is: i think your problem is neither an openSUSE or
    a Linux problem, but a faulty menu program..

    --
    goldie
    Note: Accuracy, completeness, legality, or usefulness of this posting
    may be illusive.

  7. #7
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Login Problems

    ajoram adjusted his/her AFDB on Tuesday 11 Aug 2009 01:06 to write:

    >
    > Oh, it just says 'Basic Menu' in the headline and 'User:Schof'.
    >
    > In the bottom line it says 'Pick one of the key numbers from above or
    > press <ENTER> to exit'. Without any key numbers available, all I can do
    > is exit.
    >
    >


    As goldie said that is not a SuSE or any linux menu I have ever seen.

    If it was some well hidden YaST stuff it would more than likely be in blue
    and white which is the colour of the ncurses interface unless this has been
    modified by user.

    I take the user is logging in by terminal and not a GUI?

    What happens if you create a new user?

    If the new user is getting the same menu then something system wide has been
    changed to the login section.

    I cannot even guess what/where this might be coming from.

    Can you supply some more info on what exactly this machine is being used for
    and the login details please?
    (obviously you will mung any sensitive stuff we do not want that )

    HTH

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  8. #8
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Login Problems

    * ajoram,

    like Mark, I never saw that one before. Almost looks like a Windows bootloader.

    You say root works, so I'd bluntly rename the user's /home dir and try again. If that works, move his stuff over to the new home.

    Uwe

  9. #9

    Default Re: Login Problems

    The reason for running OpenSuse in a VMWare Server is that we are a small company and use an application which requires a MS SQL Server and another application that requires a Linux system. Since our server isn't really busy there's just no point in spending money for a second server to run Linux on.

    Since the software running on the Linux system is maintained and updated by the developer, a smbserver is running and I set up a VPN Gateway.

    As for the menu - No, I've never seen it before and have no idea what it is for. Calling it a Yast menu was just a guess.

    Creating a new user doesn't help. I've tried that before and when logging in I only get to this weird menu again. The only thing that works is logging in as root.

    When logging in by GUI the username and password are visibly accepted, but nothing further happens and eventually I'm returned to the GUI login screen - yet without seeing that strange menu.

    As I'm not a Linux Guru myself allow me to ask if there is some configuration file for the login section or which logs I should probably check.

    Thanks for your help.

    Cheers,
    ajoram

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Login Problems

    Like the others told you, this is not some openSUSE menu. So the answer to the question about disk space makes no sense either. The free space on the physical disk can be 16 GB, this does not mean the virtual disk that openSUSE runs from is not full....

    Try running the VM in runlevel 3 ( on options line in GRUB menu, simply type 'init 3'. At the login prompt, login as the normal tuser and do a 'df -h' to see if the VM is running out of space, and therefor throws you back to some basic VM boot menu. Since it's only option is not available due to errors it would leave the menu empty. But that's merely a guess.

    This is the best I can do for you, my choice too would have been the other way around ( run Windoos in a VM on a linux host )
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •