Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Kmix and regular headphones

  1. #1

    Default Kmix and regular headphones

    My sounds works perfectly well....except for when I plug in my headphones....these are the regular kind...not the usb ones....the ones used like in ipods and mp3 players...

    As soon as I plug in my headphones any noiuse coming out just stops....is tehre anything I have to do to cpnfigure Kmix to get my headphones to work?

    Snaps of my channels:




  2. #2
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Kmix and regular headphones

    Have you checked to see if the headphone channel is unmuted in the KMix mixer?

  3. #3

    Default Re: Kmix and regular headphones

    the thing is i am not sure which on the headphone channel is...
    I have two tabs...

    HDA ATI SB
    HDA ATI HDMI

    and i always made sure i unmute everything......when itried the headphones......and made sure everything was on the highest volume

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,492
    Blog Entries
    37

    Default Re: Kmix and regular headphones

    When you plug your head phones in, sound is supposed to stop in your speakers, and come out of your headphones.

    Am I correct that when you plug your headphones in, you get no sound any where?

    Your mixer should be pretty clear as to what the headphone volume control is.

    What openSUSE version are you using (it makes a difference in the support ! ) ? What desktop? KDE3? KDE4? Gnome?

  5. #5

    Default Re: Kmix and regular headphones

    yeah i get no sound waht so ever.......but if i unplug it it gives me the sound throught my laptop's spearkers again.....

    I am running KDE 4......openSUSE 11.1........it is not clear to me at all on how to control the headphones.....coz i mean i see this channel under one of my tabs which looks like the plugging in end of a headphone.......but adjusting it doing anything doesnt make a difference to me.....

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,492
    Blog Entries
    37

    Default Re: Kmix and regular headphones

    Quote Originally Posted by celeb View Post
    yeah i get no sound waht so ever.......but if i unplug it it gives me the sound throught my laptop's spearkers again.....
    Ok, I've seen this happen with some laptop makes, where the developers were told of the problem, and they created some updated alsa rpms to address the problem (where alsa is the sound driver for Linux).

    Note with KDE4's kmix you can add via a kmix menu item extra channels for more control over your mixer/audio.

    Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. Select the < UPLOAD/SHARE> option such that it uploads the information to the web. When it is complete, it will give you the URL of the web site. Please post that URL here. JUST the URL.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation.

  7. #7

    Default Re: Kmix and regular headphones

    thnx for the reply......

    Heres teh url......
    http://www.alsa-project.org/db/?f=4e70df45c277c9dcd62f2c1be0f16b5db8c91c00


    Information form terminal:

    # 5Dex.uqQijx37meA:SBx00 Azalia (Intel HDA)
    alias snd-card-0 snd-hda-intel
    # dP62.3eubOLksOn3:Radeon X1200 Series Audio Controller
    alias snd-card-1 snd-hda-intel

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,492
    Blog Entries
    37

    Default Re: Kmix and regular headphones

    Quote Originally Posted by celeb;2024288Heres teh url......[URL="http://www.alsa-project.org/db/?f=4e70df45c277c9dcd62f2c1be0f16b5db8c91c00"
    http://www.alsa-project.org/db/?f=4e70df45c277c9dcd62f2c1be0f16b5db8c91c00[/URL]
    OK, I note opensuse-11.1 with the original 2.6.27.7-9-default kernel (ie you have not kept up with the security updates). Your PC's hardware audio codec is reported as a STAC9205, and your alsa version as 1.0.17/1.0.18 (where alsa is the audio driver for Linux).

    When I do a search for the stac9205 on the alsa web site, I note there was an update in 1.0.20 of alsa, but I can not tell if that is relevant: Search results stac9205 - AlsaProject

    When I do a search for the stac92xx on the alsa web site, I also note there was an update in 1.0.20 of alsa, but I can not tell if that is relevant: Search results stac92xx - AlsaProject

    What you could do, is work on an assumption that the headset should work with 1.0.17/1.0.18 of alsa, but that the configuration after booting was not applied correctly, and thus try to force a model configuration upon boot.

    I note the list for various models, from the 1.0.18a of alsa is:
    Code:
    	STAC9205/9254
    	  ref		Reference board
    	  dell-m42	Dell (unknown)
    	  dell-m43	Dell Precision
    	  dell-m44	Dell Inspiron
    and from the 1.0.20 version of alsa is:
    Code:
    STAC9205/9254
    =============
      ref		Reference board
      dell-m42	Dell (unknown)
      dell-m43	Dell Precision
      dell-m44	Dell Inspiron
      eapd		Keep EAPD on (e.g. Gateway T1616)
      auto		BIOS setup (default)
    So since your PC has 1.0.17/1.0.18, you could try forcing one of the 1.0.18a alsa models.

    Lets say you start by trying to force the dell-m42 model option. You can do that by opening /etc/modprobe.d/sound file with an editor, and adding a line at the start, so that the file now looks like:
    Code:
    options snd-hda-intel model=dell-m42
    # 5Dex.uqQijx37meA:SBx00 Azalia (Intel HDA)
    alias snd-card-0 snd-hda-intel
    # dP62.3eubOLksOn3:Radeon X1200 Series Audio Controller
    alias snd-card-1 snd-hda-intel
    save the change and then restart your alsa sound driver with su -c 'rcalsasound restart' and enter root password when prompted, restart your mixer (kmix on kde and alsamixer on gnome) and test your speaker headset functionality.

    Note to change the file you need root permissions and you can open the file editor with root permissions by typing
    • in gnome: gnomesu 'gedit /etc/modprobe.d/sound'
    • in KDE: kdesu 'kwrite /etc/modprobe.d/sound'
    and enter root password when prompted and save the change.

    Note things may be worse when that model option is applied. No worries. You can always remove the change.

    If dell-m42 does not work, then replace it with the next item in the list "dell-m43" and save the change, restart alsa (per above), restart your mixer and test.

    Do that for each item in the list.

    If that does not work, then advise, and we can look at updating your alsa version.

  9. #9

    Default Re: Kmix and regular headphones

    I tried editing the sound file and restarting alsa......none of it worked,,,,,

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,492
    Blog Entries
    37

    Default Re: Kmix and regular headphones

    Quote Originally Posted by celeb View Post
    I tried editing the sound file and restarting alsa......none of it worked,,,,,
    Ok, I can give you some rpm commands to update your alsa. The problem with this approach (although it has a reasonable chance of success) is if you subsequently update your kernel version, it may break your sound, forcing you to update the alsa driver again.

    As before, I note opensuse-11.1 with the original 2.6.27.7-9-default kernel . Please confirm that is still the case wrt the kernel. ie type:
    uname -a
    if your kernel is still the 2.6.27.7-9, then do the following (if it is NOT then stop now and advise):

    1st remove that custom line from your /etc/modprobe.d/sound file.

    Then with your pc connected to the internet, open a konsole/terminal and type 'su' (no quotes - enter root password when prompted) and copy and paste the following six commands, in sequence, one at a time, into that konsole/terminal and execute them:
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa alsa-docs libasound2
    Code:
    zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa-driver-kmp-default
    Code:
    zypper rr multimedia
    then restart your PC, and test your sound/headphone. Be careful to check your mixer settings.

    If that does not work, you could try again the model options for 1.0.20 of alsa in your /etc/modprobe.d/sound file, restarting alsa and restarting your mixer after each attempt.

    If that does not work, then go on to the daily snapshots of alsa. You can do that with your pc connected to the internet, open a konsole/terminal and type 'su' (no quotes - enter root password when prompted) and copy and paste the following six commands, in sequence, one at a time, into that konsole/terminal and execute them:
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/snapshot/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse libasound2
    Code:
    zypper rr multimedia
    Code:
     zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1/ multimedia
    Code:
    zypper install alsa-driver-kmp-default
    Code:
    zypper rr multimedia
    You may be told some are already installed. Proceed anyway, sending all commands. Then restart your PC, and test your sound/headphone. Be careful to check your mixer settings.

    If that does not work, you could try again the model options for 1.0.20 of alsa in your /etc/modprobe.d/sound file, restarting alsa and restarting your mixer after each attempt.

    Again, note those are for the original 2.6.27.7-9-default kernel and if you have changed your kernel version (which can easily happen with an openSUSE update) then the commands MUST be different.

    Good luck.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •