Results 1 to 9 of 9

Thread: HDA ATI SB fallback to HDA ATI HDMI

  1. #1

    Default HDA ATI SB fallback to HDA ATI HDMI

    I can't get my sound system to work properly. Sometimes I get it to work, but next time I reboot I get a message that tells me that the system fallback to HDA ATI HDMI (exact message I don't have. I goes to fast).

    After that sound isn't working anymore. Who can help me out?

    Here I my system specs:

    Processor: AMD2
    Motherboard: ASUS M4A78-EM
    Cipset: AMD 780G/SB700
    Memory: 4GB (4 x 1GB) DDR2 1066
    Video Card: Integrated ATI Radeon HD3200
    sound Card: ALC887 High Definition Audio 8 -Channel CODEC

    What did I do?
    I have a plain installed OpenSuse 11.1 and updated everything (even went to KDE4.3 and the newest ALSA drivers).

    I already tried: no sound on new Suse 11.1 ? - openSUSE Forums but this doesn't work. I get the sound running with it. But after rebooting the message pops up again and the sound is dead.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: HDA ATI SB fallback to HDA ATI HDMI

    Quote Originally Posted by extra302 View Post
    I can't get my sound system to work properly. Sometimes I get it to work, but next time I reboot I get a message that tells me that the system fallback to HDA ATI HDMI (exact message I don't have. I goes to fast).
    Many users see this and their sound still works afterward. Hence I believe this is a known bug and that a number of users have reported this. There are a more than a few threads here, where users have posted solutions that worked for them: I think I've seen other "solutions" as well, but a quick search did not reveal it (I probably had the wrong search parameters).

    Quote Originally Posted by extra302 View Post
    After that sound isn't working anymore. Who can help me out?
    What is your criteria for saying your sound did not work any more after that? Please do NOT use the start up sound, as that is not a good indication. Please instead use the speaker tests in the URL you quoted ... and also here: SDB:AudioTroubleshooting - openSUSE Try each of the 2 speaker-tests and also the alsa sound test. If ANY ONE of those 3 tests work, then your basic sound works and this is a desktop glitch or an application glitch.

    Quote Originally Posted by extra302 View Post
    I have a plain installed OpenSuse 11.1 and updated everything (even went to KDE4.3 and the newest ALSA drivers).
    Ahh ... KDE-4.3. Sorry, I can't help. I don't provide support for desktop updated versions that are not provided as official Novell-SuSE updates. Too much can go wrong, and the testing is far less than with basic KDE. I use KDE-3.5.10 myself and I do NOT have these sort of sound problems.

  3. #3
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: HDA ATI SB fallback to HDA ATI HDMI

    extra302 adjusted his/her AFDB on Sunday 09 Aug 2009 19:56 to write:

    >
    > I can't get my sound system to work properly. Sometimes I get it to
    > work, but next time I reboot I get a message that tells me that the
    > system fallback to HDA ATI HDMI (exact message I don't have. I goes to
    > fast).
    >
    > After that sound isn't working anymore. Who can help me out?
    >
    > Here I my system specs:
    >
    > Processor: AMD2
    > Motherboard: ASUS M4A78-EM
    > Cipset: AMD 780G/SB700
    > Memory: 4GB (4 x 1GB) DDR2 1066
    > Video Card: Integrated ATI Radeon HD3200
    > sound Card: ALC887 High Definition Audio 8 -Channel CODEC
    >
    > What did I do?
    > I have a plain installed OpenSuse 11.1 and updated everything (even
    > went to KDE4.3 and the newest ALSA drivers).
    >
    > I already tried: 'no sound on new Suse 11.1 ? - openSUSE Forums'
    > (http://tinyurl.com/99zg75) but this doesn't work. I get the sound
    > running with it. But after rebooting the message pops up again and the
    > sound is dead.
    >
    >


    Use Yast>hardware>Sound and make sure that the HDMI card is not configured,
    just highlight and Delete, click your other card and make it the default.

    You might get messages asking if you want to forget about this card, answer
    yes, then you will have to logoff and login again.

    If all is well then that is great, if not then go to personal
    settings/desktop setting and then media and make sure that the card is there
    and make it the top choice for everything in the list.

    If you still get the messages then you might have to un-install some
    applications, but we will get to that after you have tried the disable bit.

    post back if ypu need more help or it is working.

    HTH
    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  4. #4

    Default Re: HDA ATI SB fallback to HDA ATI HDMI

    Many thanks for the response.

    - I upgraded to KDE 4.3 because of the sound problems. After the upgrade, I've the same issues. So I don't think it got anything to do with this "instable" version i believe.

    - I tried YAST > sound configuration. It has to options:
    Code:
    1. SBx00 Azalia (Intel HDA)
    
         - Configured as sound card number 0
         - Driver snd-hda-intel
    
    2. RS780 Azalia controller
    
        - Configured as sound card number 1
        - Driver snd-hda-intel
    Can you tell which one I need to delete (which one is HDMI)?

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: HDA ATI SB fallback to HDA ATI HDMI

    The script /usr/sbin/alsa-info.sh provides more information on one's PC's audio configuration. If it asks to update, then run it once with root permissions to install the update. Then run a second time as a regular user to obtain more information.

  6. #6

    Default Re: HDA ATI SB fallback to HDA ATI HDMI

    Here you find /usr/sbin/alsa-info.sh

    Code:
    http://www.alsa-project.org/db/?f=03f99e1c918c8335e2bcc864093294759e46bdc8
    I don't see that it need an update?

    What I do see is that my message in my windows manager is from phonon. Sinds I deleted SBx00 Azalia (Intel HDA) in Yast the message on my screen telss me:

    Code:
    Notification from phononL kde's multimedia library
    switching to the audio playback device HDA ATI SB (ALC883 Analog)
    Which just became available and has higher preference.
    
    button with label: revert back to device 'ALSA default output'

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: HDA ATI SB fallback to HDA ATI HDMI

    Quote Originally Posted by extra302 View Post
    Can you tell which .... which one is HDMI ?
    I believe the diagnostic script gave you the answer to that question.
    Quote Originally Posted by extra302 View Post
    Here you find /usr/sbin/alsa-info.sh
    Code:
    http://www.alsa-project.org/db/?f=03f99e1c918c8335e2bcc864093294759e46bdc8
    !!Soundcards recognised by ALSA
    !!-----------------------------

    0 [SB ]: HDA-Intel - HDA ATI SB
    HDA ATI SB at 0xfbcf0000 irq 16
    1 [HDMI ]: HDA-Intel - HDA ATI HDMI
    HDA ATI HDMI at 0xfbee8000 irq 1
    I don't recommend any card deletion.

    Quote Originally Posted by extra302 View Post
    Sinds I deleted SBx00 Azalia (Intel HDA) in Yast the message on my screen telss me ...
    You are into unknown territory for me ..... with a custom KDE-4.3 and deleting things I would not recommend deleting. .... Good luck.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: HDA ATI SB fallback to HDA ATI HDMI

    Quote Originally Posted by extra302 View Post
    Here you find /usr/sbin/alsa-info.sh

    Code:
    http://www.alsa-project.org/db/?f=03f99e1c918c8335e2bcc864093294759e46bdc8
    Out of curiosity, why do you have your master volume control muted ?? That GUARANTEES no sound

    Simple mixer control 'Master',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback 0 - 31
    Mono: Playback 19 [61%] [-18.00dB] [off]

  9. #9

    Default Re: HDA ATI SB fallback to HDA ATI HDMI

    Hey everybody! It's working. Thanks for the support.

    What I did:

    - In Yast > sound system I configured 1 drive and not the intel HDA drive. Then I have prioritized all sound drivers in the select box hardware differently. I gave HDMI the lowest prio. Know everything works well.

    - Perhaps interesting for the developers on KDE 4.3: Every time my sound systems crashed the KMIX went of my screen and automatically switched the mute function on next time it came on. Perhaps It helps to find a solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •