Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: No 3D (enable desktop effects) on Radeon HD3200

  1. #1

    Default No 3D (enable desktop effects) on Radeon HD3200

    When I enable desktop effects my system slows down. Who can help me out?

    Here I my system specs:

    Processor: AMD2
    Motherboard: ASUS M4A78-EM
    Cipset: AMD 780G/SB700
    Memory: 4GB (4 x 1GB) DDR2 1066
    Video Card: Integrated ATI Radeon HD3200
    sound Card: ALC887 High Definition Audio 8 -Channel CODEC

    What did I do?
    I have a plain installed OpenSuse 11.1 and updated everything (even went to KDE4.3).

    After installing the ATI driver conform ATI - openSUSE (the easy way) I can select 3D functionality in YAST (hadrware/video). After I enable desktop effects the system slows down. I need to <ctrl><alt><F1> and as root edit the xorg.conf file to bring the system up again.

    Option Composite ="off"

  2. #2
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    extra302 adjusted his/her AFDB on Sunday 09 Aug 2009 19:46 to write:


    > What did I do?
    > I have a plain installed OpenSuse 11.1 and updated everything (even
    > went to KDE4.3).
    >
    > After installing the ATI driver conform 'ATI - openSUSE'
    > (http://en.opensuse.org/ATI) (the easy way) I can select 3D
    > functionality in YAST (hadrware/video). After I enable desktop effects
    > the system slows down. I need to <ctrl><alt><F1> and as root edit the
    > xorg.conf file to bring the system up again.
    >
    > Option Composite ="off"
    >
    >


    Can you confirm that the fglrx driver is loaded and being used?

    When in KDE open a terminal and type:

    lsmod


    Have a look and see if it is in the list.

    Also can you cut and paste your xorg.conf from /etc/X11/ so that we can see
    if it is in fact being used.

    HTH
    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  3. #3

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    I only see that I use atiixp (4476 0) when I type lsmod.


    Here is my xorg.conf

    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-08-09T15:33:28+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AIGLX" "on"
      Option       "AllowMouseOpenFail" "on"
      Option       "IgnoreABI" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Disable      "dri"
      Load         "dbe"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
    EndSection
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Pixart Imaging USB OPTICAL MOUSE"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  408 306
      HorizSync    30-81
      Identifier   "Monitor[0]"
      ModelName    "SAMSUNG SYNCMASTER"
      Option       "DPMS"
      Option       "PreferredMode" "1600x1200"
      VendorName   "SAM"
      VertRefresh  43-75
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
      Modeline 	"1600x1200" 162 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "ATI Radeon HD 3200 Graphics (RS780 9610)"
      Driver       "fglrx"
      Identifier   "Device[0]"
      Option       "XAANoOffscreenPixmaps" "true"
      Option       "Capabilities" "0x00000000"
      Option       "OpenGLOverlay" "off"
      Option       "FSAAScale" "0"
      Option       "FSAAEnable" "off"
      Option       "VideoOverlay" "on"
      VendorName   "ATI"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
      Option       "Composite" "off"
    EndSection
    If you need more, please let me know!

  4. #4

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    By the way I did the following:

    YaST -> Software -> Software Repositories -> Add

    Protocol: http
    Server Name: : www2.ati.com
    Directory on Server: suse/11.1

    to add the ATI http server as additional installation source.
    Now use

    YaST -> Software -> Software Management

    to install the ATI/fglrx driver. Select the following packages:

    x11-video-fglrxG01


    In YaST the module ati-fglrxG01-kmp-default is loaded as wel (debug, kmp-pae and kmp-trace aren't).

    After that I used:

    - SAX2 -R -M 0=FGLRX > see: ATI - openSUSE

    I didn't use below command that was mentioned on ATI Installer HOWTO for SUSE/Novell users
    Use "sax2 -r" for X.Org configuration.

    Is there a difference?

  5. #5
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    extra302 adjusted his/her AFDB on Monday 10 Aug 2009 22:36 to write:

    >
    > By the way I did the following:
    >
    > YaST -> Software -> Software Repositories -> Add
    >
    > Protocol: http
    > Server Name: : www2.ati.com
    > Directory on Server: suse/11.1
    >
    > to add the ATI http server as additional installation source.
    > Now use
    >
    > YaST -> Software -> Software Management
    >
    > to install the ATI/fglrx driver. Select the following packages:
    >
    > x11-video-fglrxG01
    >
    >
    > In YaST the module ati-fglrxG01-kmp-default is loaded as wel (debug,
    > kmp-pae and kmp-trace aren't).
    >
    > After that I used:
    >
    > - SAX2 -R -M 0=FGLRX > see: 'ATI - openSUSE'
    > (http://en.opensuse.org/ATI)
    >
    > I didn't use below command that was mentioned on 'ATI Installer HOWTO
    > for SUSE/Novell users'
    > (http://www.suse.de/~sndirsch/ati-installer-HOWTO.html)
    > Use "sax2 -r" for X.Org configuration.
    >
    > Is there a difference?
    >
    >

    No you should be fine, the problems arise if you do the "Hard Way" of
    installing the drivers executing sax2 can/will/might b0rrk the xorg.conf
    file so that you do not get a satisfactory config.

    Now I noticed in your other post the at the bottom of the xorg.conf you have
    composite set to::

    Section "Extensions"
    Option "Composite" "off"
    EndSection


    Change that to::
    Section "Extensions"
    Option "Composite" "enable"
    EndSection



    And restart the X server either by just logging out of the GUI and then for
    good luck press and hold down Ctrl+Alt and press BackSpace twice you will
    here a beep and the login screen will come up again.

    Now go and see if the effects work.

    Let us know how you get on.
    HTH
    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  6. #6

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    As mentioned before I had to set

    Composite = "off"

    this is the only way that I can use my system again on normal speed.

    By the way: standard Composite = "on" not "enable".

    Any other ideas?

    By the way, can I just try again like below?

    - init 3
    - SAX2 -R -M 0=FGLRX
    - edit xorg Composite = "on"
    - init 5

  7. #7

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    I still can't get it to work. I got some new info that perhaps is interesting solving this issue:

    I see that below driver is installed (strange I have a radeon HD3200):
    - xorg-x11-driver-video-radeonhd - Driver for AMD GPG (ATI) r5xx/r6xx Chipsets

    When trying to run SAX2 (it doesn't matter what extensions I use) I get below message:
    - your current configuration will not be read in
    After that, it SAX2 stops (CTRL Z to go back to the prompt).

    I deinstalled compiz, beryl and fusion. Then I get the message in

    Configure desktop > desktop >

    - Compositing is not supported on your system.
    Required X extensions (XComposite and XDamage) are not available.

    Here below is my xorg.conf
    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-08-22T19:23:23+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AIGLX" "on"
      Option       "AllowMouseOpenFail" "on"
      Option       "IgnoreABI" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Load         "glx"
      Load         "extmod"
      Load         "freetype"
      Load         "dbe"
      Load         "dri"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Pixart Imaging USB OPTICAL MOUSE"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  408 306
      HorizSync    30-81
      Identifier   "Monitor[0]"
      ModelName    "SAMSUNG SYNCMASTER"
      Option       "DPMS"
      Option       "PreferredMode" "1600x1200"
      VendorName   "SAM"
      VertRefresh  43-75
      UseModes     "Modes[0]"
    EndSection
    
    Section "Modes"
      Identifier   "Modes[0]"
      Modeline 	"1600x1200" 162.00 1600 1664 1856 2160 1200 1201 1204 1250
    EndSection
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    Section "Device"
      BoardName    "ATI Radeon HD 3200 Graphics (RS780 9610)"
      Driver       "fglrx"
      Identifier   "Device[0]"
      Option       "XAANoOffscreenPixmaps" "0x116c010"
      Option       "Capabilities" "0x116bf90"
      Option       "OpenGLOverlay" "0x116bfd0"
      Option       "FSAAScale" "0xfd3e60"
      Option       "FSAAEnable" "0x116bef0"
      Option       "VideoOverlay" "0x116beb0"
      Screen       0
      VendorName   "ATI"
    EndSection
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
    EndSection
    Two questions:
    1.) Who can tell me how to get enabled desktop effects correct to work (so that it won't slow down my system)?
    2.) Who can tell me how to get SAX2 to work properly again?

  8. #8
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    extra302 adjusted his/her AFDB on Saturday 22 Aug 2009 19:36 to write:


    > Section "DRI"
    > Group "video"
    > Mode 0660
    > EndSection
    >
    > SECTION \"EXTENSIONS\"
    > ENDSECTION
    >
    > --------------------



    I do not know if it is just the way my reader is rendering your post but
    that last section should be:

    Section "Extensions"
    Option "Composite" "on"
    EndSection

    Note that it is case sensitive, and one big gotcha that a lot of people do
    not realise is that you have to put a cr ( carriage return ) at the end of
    the xorg.conf, just press enter so there is a blank line at the end this can
    halt sax2 but is usually will print an error about it as it tries to read
    after the file is ended, the cr is used as an EOF message.

    HTH

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  9. #9
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    extra302 adjusted his/her AFDB on Saturday 22 Aug 2009 19:36 to write:

    >
    > I still can't get it to work. I got some new info that perhaps is
    > interesting solving this issue:
    >
    > I see that below driver is installed (strange I have a radeon HD3200):
    > - xorg-x11-driver-video-radeonhd - Driver for AMD GPG (ATI) r5xx/r6xx
    > Chipsets
    >
    > When trying to run SAX2 (it doesn't matter what extensions I use) I get
    > below message:
    > - your current configuration will not be read in
    > After that, it SAX2 stops (CTRL Z to go back to the prompt).
    >
    > I deinstalled compiz, beryl and fusion. Then I get the message in
    >
    > Configure desktop > desktop >
    >
    > - Compositing is not supported on your system.
    > Required X extensions (XComposite and XDamage) are not available.
    >
    > Here below is my xorg.conf



    After reading your post again I realise you are saying you installed the
    radeonhd driver but your xorg is trying to load a non existent fglrx driver.

    You must choose which one you want you can either do it the hard way and
    install the ATI drivers from ATI and then use the fglrx, and DO NOT use sax2
    follow the instruction from the ATI site to get it up and running especially
    the one about using aticonfig --initial to configure your xorg.conf

    Or you can use the open source radeonhd driver which is fine for normal use
    but is still not capable of giving full OpenGL functionality.

    If you go the ATI way you will need a default xorg.conf you can get one by
    running ( as root in runlevel 3 ):

    sax2 -r -m 0=vesa

    Note that 0 is a zero not an "oh".

    this will recreate a default xorg which you will be able to use to get a
    desktop but will have no fancy stuff.

    Then proceed to d/load the ATI`s for your card, nake a note of where you
    saved them ( not on the desktop ) then logout when at the login screen
    press:

    Ctrl+Alt+f1

    login as root
    enter root password

    Then in this order:

    init 3
    cd ( to wherever you put the drivers )
    sh ./<version-of-ati-drivers>.sh

    Then just follow the OK`s, do not let it go to the web to d/load anything as
    there is nothing to d/load, let it compile a new kernel interface and if
    needed let it install the 32bit compat libs, when all done and you are back
    at the prompt as long as it has all gone with no errors you just type:

    aticonfig --initial.

    this will automagically edit your xorg.conf for you to use the fglrx
    drivers, when that is finished just type:

    init 5

    and you should get to your login screen.

    Now if all that has gone OK you will need to edit your xorg.conf to add the
    section with the composite "on"* to the end of the xorg.conf and do not
    forget the extra cr at the end.

    * if you wish to put enable you may do instead of on but both work fine
    there is no difference at all, as always in Unix/linux the idea is that less
    is more so the fewer keystrokes the more productive you are.

    That is why there is auto complete on the commandline, for instance when you
    have cd`d to the directory that has the d/loaded ATI`s if you just type:

    sh ./ati

    and then pressed the Tab key it will autocomplete the rest of the command.

    HTH
    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  10. #10

    Default Re: No 3D (enable desktop effects) on Radeon HD3200

    KDE Community Forums &bull; [SOLVED] Composite effects xdamage xcomposite

    Section "Extensions"
    Option "Damage" "true"
    Option "Composite" "true"
    EndSection

    did it. Funny.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •