Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

  1. #1

    Default OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    Hi.

    Sorry for the vague thread title, but I've encountered a series of problems that I can't seem to get solved - which is weird since most of them should be quite common or not existent at all.
    (BTW: I just installed OpenSUSE for the first time, so please bear with me...
    not new to linux though)


    1.: Shutdown from Xfce
    I know that shutting down linux is a administrative task, but it should be well possibly to do this from within Xfce (using "Menu"->"Quit"->"Shut down").
    But this only gets me back to the log in screen.
    I tried the standard sudo-approach documented at faq [Xfce wiki].
    OpenSUSE seems to place the shutdown-helper in /usr/lib/ but adding:
    Code:
    my_username   ALL=NOPASSWD:/usr/lib/xfsm-shutdown-helper
    via visudo didn't help.

    I tried the workaround proposed in this thread but polkit-auth --show-obtainable won't do produce any useful content. It either displays the man-Page or nothing at all. (neither as root nor as user)


    2.: Xfce transparency
    Setting windows transparent doesn't do anything. They're always 100% opaque.
    I tried setting the following to my /etc/X11/xorg.conf:
    Code:
    Section "Extensions"
       Option   "Composite" "Enable"
    EndSection
    (Found that tweak in some HowTo)
    But I still can't get any of the Xfce-Components transparent. (Windows, Panels, etc...)
    Did I oversee any "master switch"? The How-To's always make it seem like a "auto-on" feature.

    3.: Hostname
    The hostname displayed in the console is always >linux-l0v7<.
    I tried to change it, but got weird results:
    The /etc/hosts states the following hostnames:
    Code:
    127.0.0.1   nil
    127.0.0.2   linux-l0v7.site linux-l0v7
    192.168.0.123 MY_HOSTNAME MY_HOSTNAME
    (The last line being my actual IP-Address and my actual preferred hostname)
    Now I don't know what the 127.0.0.2 device is used for or why it does display that hostname before all others, but if I try to change it, Xfce tells me that the host linux-l0v7 could not be found and Xfce won't operate correctly at the next log in.
    It does start though...



    Having more problems with this, but those are the ones I want to address first. Can anyone give me a hint?

  2. #2

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    1. Shutdown
    Does when it gets you back in the login screen and click menu and click shutdown, the system power off?

    In yast2-local security-boot settings-shutdown behavior of login manager should be set to 'all users'

    See also the option in yast /etc/sysconfig editor-system-boot-halt_disks and might need to set it to 'yes'

    2. transparency
    Could be depending on what type of video card you are using and the driver is properly installed and configured.

    Using nvidia if memory serves, the option you set in the /etc/x11/xorg.conf should work or you don't even need to manually set it if nvidia is working properly.. Looking at this machine I am presently using with an intel video the option is set to:
    Code:
           Section "Extensions"
       Option   "Composite" "On"
    EndSection
    Noticed the difference, yours is "enable" and mine is "on" and work flawlessly with xfwm4 and kwin.

    3. Hostname
    Try the yast2-Network devices-Network Settings and look under hostname see if you can change it.

    Hope this help
    People who do not break things first will never learn to create anything

  3. #3

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    Thanks for the reply!

    Quote Originally Posted by conram View Post
    1. Shutdown
    Does when it gets you back in the login screen and click menu and click shutdown, the system power off?
    I don't have a menu at the log-in screen - it's just a plain grey screen with a log-in prompt (and a small console window at the bottom left corner).
    I can kill it with [CTRL]+C though and get to the regular text based log-in.

    Quote Originally Posted by conram View Post
    In yast2-local security-boot settings-shutdown behavior of login manager should be set to 'all users'
    Thank's for the hint - I tried it, but it didn't help.
    I still have to be root to shut down, too.
    halt_disks was already set to 'yes'.


    Quote Originally Posted by conram View Post
    2. transparency
    Could be depending on what type of video card you are using and the driver is properly installed and configured.
    Thanks for the hint with the driver. I built and installed the lastest NVidia-Driver.
    It's a Geforce 6600 GT
    Sadly, that didn't fix the problem - still no transparencies. I wonder what could be "misconfigured" about them. Any hints?

    I changed the "Composite" option in xorg.conf, but it still won't work.


    @Hostname:
    Found it and worked. Thanks!
    Now I wonder why I didn't see it the first time...
    Last edited by Makx; 09-Aug-2009 at 14:17. Reason: Forgot to mention my video card...

  4. #4

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    So you are using xdm for the displaymanager. Maybe you need to install gdm or kdm to complete those missing items. You can choose between the two I've mentioned and make it as your default displaymanager in yast2/etc/sysconfig editor. When you able to install the display manager mentioned it will be easy for you to power off using your user.

    With the nvidia card I will try to see if I have some save config file here and check what worked for me. I can't guaranty That I will be able to find one, hope someone will be able to help you with that.
    People who do not break things first will never learn to create anything

  5. #5

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    Here is a link on trouble shooting your nvidia graphics.
    nvidia-xconfig(1) - Linux man page
    Please read the advance options.
    People who do not break things first will never learn to create anything

  6. #6

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    Switching to gdm and back changed nothing - gdm can shut down/reboot properly, Xfce can't.

  7. #7

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    I'm trying around with the nvidia-xconfig tool, but I can't seem to find the correct settings...

    About the shutdown problem:
    When starting Xorg/Xfce from console I can read the error when it tries to shut down:

    Code:
    ** Message: xfsm-shutdown-helper.c:229: Using HAL to shutdown/reboot the computer.
    Terminal: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
    
    ** (xfce4-session:3705): WARNING **: Failed to perform shutdown action!
    Agent pid 3697 killed
    
    waiting for X server to shut down xfce-mcs-manager: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
    alsa: Mixer attach default error: Permission denied
    I can't believe noone has had these problems before. It's not like I'm trying to do anything fancy - or on any fancy kind of hardware...

    Thanks for your help anyway.

  8. #8

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    With xdm you have to be super user to shutdown.
    In the terminal su to become root and command shutdown or poweroff.
    If you google search there are documentations of adding shutdown menu with xdm. There are also some documentations of ways on how to change permissions to let user to shutdown your system but not advisable in some circumstances. I am not familiar with it for I haven't try playing with it. I always use kdm for my login screen as the design looks pretty for my taste and not to squeeze my mind just to let user to shutdown my machine.

    With nvidia not to sure about the needed commands but maybe try this at your own risk as su in the terminal try these options even you have already manually changed your xorg.conf.
    nvidia-xconfig --composite
    nvidia-xconfig --allow-glx-with-composite

    I apologize if it still will not work, look at my signature and it will give hint on what I do with my machine.
    People who do not break things first will never learn to create anything

  9. #9

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    Quote Originally Posted by conram View Post
    With xdm you have to be super user to shutdown.
    In the terminal su to become root and command shutdown or poweroff.
    If you google search there are documentations of adding shutdown menu with xdm. There are also some documentations of ways on how to change permissions to let user to shutdown your system but not advisable in some circumstances. I am not familiar with it for I haven't try playing with it. I always use kdm for my login screen as the design looks pretty for my taste and not to squeeze my mind just to let user to shutdown my machine.
    Well that's exacly what I meant.
    There IS a shutdown menu in Xfce; it's supposed to shut down the computer; it uses xfsm-shutdown-helper; you need to grant it the appropriate privileges; there are tutorials to do that; none worked...

    Quote Originally Posted by conram View Post
    With nvidia not to sure about the needed commands but maybe try this at your own risk as su in the terminal try these options even you have already manually changed your xorg.conf.
    nvidia-xconfig --composite
    nvidia-xconfig --allow-glx-with-composite
    Yeah, those where the ones that caught my eye too, but they didn't work.
    Tried out some more with the same result.
    I don't know what else to try.

    Can someone actually confirm that what I am trying to do is really possible?
    Not "yeah, I heard of that somewhere from another distro"-possible, but "yes, I am using that on OpenSUSE/Xfce and it's working"-possible.

    I just want to know if I'm wasting my time. If it's not supported then please just let me know.

  10. #10

    Default Re: OpenSUSE11.1, Xfce 4.4.3 and a lot of problems...

    Quote Originally Posted by Makx View Post
    le.

    I just want to know if I'm wasting my time. If it's not supported then please just let me know.
    Maybe.
    You're problem looks like not just xfce specific.
    The way it looks, only one dare to try helping you, maybe it's about time to find a way to look for solution somewhere, while waiting for some additional post in this thread. Hopefully someone will chime in.
    Say try this link from the xfce forums:
    Set Search Parameters
    When you are inside that link type in search this word xdm*shutdown

    Just in case you found a solution, please do post it here might help folks here with the same issues

    Or try upgrading your 4.3 version to 4.6
    People who do not break things first will never learn to create anything

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •