Results 1 to 5 of 5

Thread: About kde, kmix and pulseaudio

  1. #1
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Exclamation About kde, kmix and pulseaudio

    I just enabled pulseaudio in kde-settings multimedia, and at first there was no sound at all anymore: I considured to install pavucontrol from xfce... but I remembered to have kicked master channel from kmix as it did nothing (choosed pcm as master). With right clicking kmix and choosing channels, enabling master, I saw : MUTED
    Enabling "Master" as master again did enable pulseaudio sound for me, but sliding the volume does nothing now

    Pulseaudio has some extra features, is used in most distributions, is getting matured now, but:
    Kmix having a "Master" which can mute but not change volume is a bug.

  2. #2
    Join Date
    Feb 2009
    Location
    Baton Rouge, LA, US
    Posts
    152

    Default Re: About kde, kmix and pulseaudio

    Quote Originally Posted by ulenrich View Post
    I just enabled pulseaudio in kde-settings multimedia, and at first there was no sound at all anymore: I considured to install pavucontrol from xfce... but I remembered to have kicked master channel from kmix as it did nothing (choosed pcm as master). With right clicking kmix and choosing channels, enabling master, I saw : MUTED
    Enabling "Master" as master again did enable pulseaudio sound for me, but sliding the volume does nothing now

    Pulseaudio has some extra features, is used in most distributions, is getting matured now, but:
    Kmix having a "Master" which can mute but not change volume is a bug.
    Have you tried enabling it in Yast>Sound>Other>Pulse Audio Configuration?
    Thanks,
    Dwight Paige

  3. #3
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Re: About kde, kmix and pulseaudio

    You did not fully read my report ?
    Pulseaudio runs out of the box, but I had the muted "Master" channel hidden due to his (the channels) disfunctionality.

    [edit] Uups: There is a YAST->Sound->Other which has not Pulseaudio activated - But Pulseaudio runs ..... ???

    ... Really that button "Other" is little/hidden - everybody overlooks as kind of [Cancel|Ok]

  4. #4
    Join Date
    Feb 2009
    Location
    Baton Rouge, LA, US
    Posts
    152

    Default Re: About kde, kmix and pulseaudio

    Did I read your post. Yes. Did I understand it. Probably not. I've always struggled to understand sound in Linux. All I know is PulseAudio sound does not work for me as regular user AND when enabled it seems to cause graphic problems on login. That seems bizarre. How can a sound app cause graphic problems?
    My system sound:

    Model: nVidia MCP51 High Definition Audio
    Kernel Driver: snd_hda_intel

    Curiously as mentioned as regular user in KDE System Settings PulseAudio does not play a sound. However if I run 'kdesu systemsettings' it DOES play a sound as root... Wonder what that means? Permissions problem?
    Thanks,
    Dwight Paige

  5. #5
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: About kde, kmix and pulseaudio

    See this bug for some newer alsa and pulseaudio rpms that fix the muting problem.

    https://bugzilla.novell.com/show_bug.cgi?id=499445

    The link to the packages is in comment #25 and the instructions are in comment #27.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •