When running M4 I had phpbb and phpMyAdmin running on my machine, after upgrading I was getting error messages about how a mysql server was not configured or that it couldn't connect the the mysql.sock file. In order to fix the problem I had to softlink /var/run/mysql/mysql.sock and /var/lib/mysql/mysql.sock now everything is working.