Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Sound issue -- Intel Hda

  1. #1
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Sound issue -- Intel Hda

    I have sound problem with openSUSE 11.1 32bit. No sound from the box.
    I have Intel audio card. Did kernel upgrade, but with no luck.
    Any work around.
    Thanks.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Sound issue -- Intel Hda

    Quote Originally Posted by mmarif4u View Post
    I have sound problem with openSUSE 11.1 32bit. No sound from the box.
    I have Intel audio card. Did kernel upgrade, but with no luck.
    Any work around.
    Thanks.
    @oldcpu is your man for sound.
    Check in Desktop Config you have Intel as prefered and using alsa


    Check kmix channel is set to master
    Check the audio trouble shooter

    (Did you solve the memory issue?)
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Sound issue -- Intel Hda

    Thanks caf for the fast reply.
    I am working on the memory problem, As i am using wifi in university. Its slow...takes time to download the things.
    In the place,(the image you posted), there is no Alsa for me. let me try to install it from yast.
    Will be back in a while.
    I am also thinking of compiling new kernel(2.6.30.4), just in this hope that it will solve most of the issues for me. As i used 11.2 M3 on this laptop, there was no sound issue that time. Because of some other issues, i switch back to 11.1 from 11.2.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound issue -- Intel Hda

    Quote Originally Posted by mmarif4u View Post
    I am also thinking of compiling new kernel(2.6.30.4), just in this hope that it will solve most of the issues for me. As i used 11.2 M3 on this laptop, there was no sound issue that time. Because of some other issues, i switch back to 11.1 from 11.2.
    My experience is users who compile a new kernel themselves are more like to break sound than fix it.

    You could try working your way through the openSUSE audio troubleshooting guide:
    SDB:AudioTroubleshooting - openSUSE

    When testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Assuming after your trying to get sound working, after having gone through each applicable step in the troubleshooting guide, and if still no sound, can you provide more very detailed information so a good recommendation can be given? If using openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and typing "su" (no quotes - enter root password) and then and typing and executing twice :
    /usr/sbin/alsa-info.sh
    the first time it will ask to update. Select YES for the update. The second time that will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation (as opposed to a guess).

  5. #5
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Sound issue -- Intel Hda

    Thanks oldcpu the detailed reply.
    As you mentioned the 1st command throws errors like:
    speaker-test -Dplug:front -c2 -l5 -twav

    speaker-test 1.0.18

    Playback device is plug:front
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Playback open error: -16,Device or resource busy
    Playback open error: -16,Device or resource busy
    Playback open error: -16,Device or resource busy
    2nd one:
    linux-30vu:/home/anl # speaker-test -c2 -l5 -twav

    speaker-test 1.0.18

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    Rate set to 48000Hz (requested 48000Hz)
    Buffer size range from 96 to 1048576
    Period size range from 32 to 349526
    Using max buffer size 1048576
    Periods = 4
    was set period_size = 262144
    was set buffer_size = 1048576
    0 - Front Left
    1 - Front Right
    speaker-test: pcm_pulse.c:361: pulse_write: Assertion `pcm->stream' failed.
    Aborted
    Tried with headset and without headset, but no luck.

    This is URL for the conf file:
    http://www.alsa-project.org/db/?f=68...7c90d05575bae0

    linux-30vu:/home/anl # rpm -qa | grep alsa
    alsa-utils-1.0.18-6.4
    alsa-plugins-pulse-1.0.18-6.12
    alsa-firmware-1.0.17-1.42
    alsa-oss-1.0.17-1.37
    alsamixergui-0.9.0rc1-584.132
    alsa-1.0.18-8.7
    alsa-plugins-1.0.18-6.12
    linux-30vu:/home/anl # rpm -qa | grep pulse
    pulseaudio-module-zeroconf-0.9.12-9.6
    libpulsecore4-0.9.12-9.6
    pulseaudio-utils-0.9.12-9.6
    pulseaudio-module-jack-0.9.12-9.6
    libpulse0-0.9.12-9.6
    libpulse-mainloop-glib0-0.9.12-9.6
    alsa-plugins-pulse-1.0.18-6.12
    pulseaudio-module-lirc-0.9.12-9.6
    pulseaudio-0.9.12-9.6
    pulseaudio-module-bluetooth-0.9.12-9.6
    libpulse-browse0-0.9.12-9.6
    pulseaudio-esound-compat-0.9.12-9.6
    libxine1-pulse-1.1.15-20.8
    pulseaudio-module-x11-0.9.12-9.6
    linux-30vu:/home/anl # rpm -q libasound2
    libasound2-1.0.18-8.7
    linux-30vu:/home/anl # uname -a
    Linux linux-30vu 2.6.27.25-0.1-pae #1 SMP 2009-07-01 15:37:09 +0200 i686 i686 i386 GNU/Linux
    linux-30vu:/home/anl # cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.sgM5+Zagk53:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    linux-30vu:/home/anl # rpm -q alsa alsa-utils alsa-firmware
    alsa-1.0.18-8.7
    alsa-utils-1.0.18-6.4
    alsa-firmware-1.0.17-1.42
    Also followed the link, which you posted above. Did all the tests, but still no sound.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound issue -- Intel Hda

    Quote Originally Posted by mmarif4u View Post
    OK, openSUSE-11.1 with the 2.6.27.25 kernel and the Codec: IDT 92HD71B7X

    Quote Originally Posted by mmarif4u View Post
    Also followed the link, which you posted above. Did all the tests, but still no sound.
    Hmmm ... I believe you read it, but did not follow it. The link I provided provides guidance on updating alsa. But clearly, since you still have 1.0.17 and 1.0.18 of alsa, you did not do that.

    As above, I note your PC has the IDT 92HD71B7X hardware audio codec. That was broken by the 2.6.27.25 kernel and the alsa packager for openSUSE put out an alsa update that works with the updated kernel (and I reference those updates in the guide), and if you had updated per the guide, then I believe you may have been able to get your sound working again.

    I concede the guide is confusing here, and I will update the guide this weekend.

    Anyway, if you go here:
    SDB:AudioTroubleshooting - openSUSE

    for detailed instructions to update alsa it will send you here:
    Alsa-update - openSUSE

    Please update alsa per your kernel version ( 2.6.27.25-0.1-pae ) and your openSUSE version, sending 6 ( !! ) zypper commands per that guide. Not 3 . 6 commands. If you are not clear as to what those 6 commands are, BEFORE you attempt an update, please advise. If you are totally confused on this, please advise and I will copy and paste the 6 command for you.

    Now after that update, and after rebooting, if that does not work, then if you look at the bottom of the alsa update page, there is a link to another update page for "daily snapshots". You can then go there and try those updates. Alsa-update-snapshot - openSUSE

    Again, as before, please update alsa per your kernel version ( 2.6.27.25-0.1-pae ) and your openSUSE version, sending 6 ( !! ) zypper commands per that guide. Not 3 . 6 commands. If you are not clear as to what those 6 commands are, BEFORE you attempt an update, please advise. If you are totally confused on this, please advise and I will copy and paste the 6 command for you.

    Apologies for any confusion in the guide. I'll do a hack job on it later today, pointing CLEARLY to those links, and I'll remove its confusing examples.

  7. #7
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Sound issue -- Intel Hda

    Sorry for the late reply.
    I did follow some of the hints in the pages given. But this one really works, at least now i have sound.

    Alsa-update - openSUSE

    Did alsaconf in konsole and start kmix. Now i have sound.
    But still i have a few issues with sound, hope to find any help on it:
    1- I am using SMplayer for audio/video, it works fine, but whenever i switch to headphone, then no sound. For this i have to open kmix and raise/down the volume to work. and it works after this and same with when removing headphone. By plugging in, by default it have to switch the volume to headphone or internal speaker. but it doesn't. Not sure why?
    And if i pause it, it just hangs...i mean the sound. There is repeated sound until i stop it or play it.

    2- If i perform a test in yast->hardware->sound.
    No test sound from there. (Some thing interesting).

    3- Still i can't hear sound in browser.

    Thanks for your time.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound issue -- Intel Hda

    Quote Originally Posted by mmarif4u View Post
    1- I am using SMplayer for audio/video, it works fine, but whenever i switch to headphone, then no sound. For this i have to open kmix and raise/down the volume to work. and it works after this and same with when removing headphone. By plugging in, by default it have to switch the volume to headphone or internal speaker. but it doesn't. Not sure why?
    So your headphone works, but it just needs a volume adjustment? Thats a problem? What am I missing?

    Quote Originally Posted by mmarif4u View Post
    And if i pause it, it just hangs...i mean the sound. There is repeated sound until i stop it or play it.
    What do you mean by repeated sound? Reads almost like an interupt problem. Its possible we may need to apply a setting in the /etc/modprobe.d/sound file (such as enable_msi=1 to address - possibly this is bug writing territory).

    Quote Originally Posted by mmarif4u View Post
    2- If i perform a test in yast->hardware->sound.
    No test sound from there. (Some thing interesting).
    Thats a known bug. It does not work for many sound cards. i recommend you do not apply much consideration into that. ie its not a problem with your config.

    Quote Originally Posted by mmarif4u View Post
    3- Still i can't hear sound in browser.
    Thats probably a separate issue. What browser? (I know - its intuitively obvious to you - but not to me). What web sites did you try? (I know - its intuitively obvious to you - but not to me). Did you try the browser IMMEDIATELY after a clean start (having checked first to ensure mixer is not muted). ....

  9. #9
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Sound issue -- Intel Hda

    Quote Originally Posted by oldcpu View Post
    So your headphone works, but it just needs a volume adjustment? Thats a problem? What am I missing?
    Yup, this is what i mean. The same happen when unplug it.

    Quote Originally Posted by oldcpu View Post
    What do you mean by repeated sound? Reads almost like an interupt problem. Its possible we may need to apply a setting in the /etc/modprobe.d/sound file (such as enable_msi=1 to address - possibly this is bug writing territory).
    Its like interrupt sound from the player, until close the player OR press stop OR play button.

    Quote Originally Posted by oldcpu View Post
    Thats a known bug. It does not work for many sound cards. i recommend you do not apply much consideration into that. ie its not a problem with your config.
    Ok. Will be not bothered.

    Quote Originally Posted by oldcpu View Post
    Thats probably a separate issue. What browser? (I know - its intuitively obvious to you - but not to me). What web sites did you try? (I know - its intuitively obvious to you - but not to me). Did you try the browser IMMEDIATELY after a clean start (having checked first to ensure mixer is not muted). ....
    Browser: Firefox3.5.2
    Websites: youtube.com , bollywoodhungama.com
    I tried after the clean start too, close the browser and also do a restart(browser, system). But still no sound.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Sound issue -- Intel Hda

    Quote Originally Posted by mmarif4u View Post
    Its like interrupt sound from the player, until close the player OR press stop OR play button.
    Ok, this is a wild stab in the dark, ... but its worth a try. Please open an editor with root permissions to edit /etc/modprobe.d/sound file. You can do that in
    • gnome with: gnomesu 'gedit /etc/modprobe.d/sound'
    • kde with: kdesu 'kwrite /etc/modprobe.d/sound'
    and change your /etc/modprobe.d/sound file, adding a line at the start so it looks like this:
    Code:
    options snd-hda-intel enable_msi=1
    options snd slots=snd-hda-intel
    # u1Nb.sgM5+Zagk53:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    then restart your PC and test your sound. Does that help?

    If it makes it worse, then remove the line.

    We could also look at updating your alsa configuration, as there are some recent updates for your PC's IDT 92HD71B7X hardware audio codec. I can give you the commands for that (to download rpms from the multimedia repositories) but first, lets see if "enable_msi=1" helps.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •