Results 1 to 3 of 3

Thread: yet another 'no sound in amarok'

  1. #1

    Default yet another 'no sound in amarok'

    yet another no sound in amarok

    amarok and firefox produce no sound. so i read thru multiple 'no sound in xxx' posts.

    i'm running an updated (as of 6 aug 09) suse 11.1
    note that sound in suse10, ubuntu, et al, on the same h/w work just fine.

    what i did:
    tried amarok as installed and updated, on 1st run, it asked for the location of the music collection. i mounted the disk where the collection resides (read only, if it matters). all the files in the selected directory are .wav files.

    two issues:
    1. nothing displayed in the 'entire collection' window under the 'collection' tab. we'll ignore this for the moment, as i can use the 'files' tab to surf to a particular file, click a file, and amarok says its playing.

    2. no sound

    speaker-test works great, but only as root.


    i added the packman repos to s/w mgmt, clicked 'filter repositories', then clicked 'Packman'. i then checked/installed the following:

    amarok, amarok-xine, amarok-packman, libxine1, xine-ui, smplayer, mplayerplug-in, vlc, w32codec-all, libffmpeg0, ffmpeg, libquicktime0, libxvidcore4, xvidcore

    yast reports all of these as having 'pm' in their installed version.

    i ran alsaconfig, several loud pops in the headphones, other than that, no problems.

    i ran alsamixer -c0, turned up and un-muted all but mic. before the packman install, this worked. after the install, it resulted in an error:

    alsamixer at this point will not run:
    function snd_ctl_open failed for default: No such file or directory

    running applications->multimedia->sound mixer results in the loading cursor for about 30 sec (ps -ef shows /usr/bin/kmix -caption KMix -icon kmix), then kmix appears to exit.


    run amarok, click settings, configure, engine, select xine as the sound engine, alsa as the output. a popup error msg says
    unable to initialize any audio drivers
    very often, amarok crashes at this point.

    using auto as the output doesn't help.

    now, speaker-test crashes with
    $ speaker-test -c2 -l5 -twav

    speaker-test 1.0.18

    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
    ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
    ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
    ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
    ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
    ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    plus many other errors.


    --------

    at this point, i think the sound system is completely hosed.

    suggestions?

  2. #2
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,859
    Blog Entries
    20

    Default Re: yet another 'no sound in amarok'

    Check in Yast hardware sound
    There is a enable pulse audio check box, don't use it
    The primary device in there (for me Intel) should be the same in Config Desktop - Multimedia
    see:


    Check the backend tab there is set to xine also.

    Might be worth a reboot too.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,138
    Blog Entries
    40

    Default Re: yet another 'no sound in amarok'

    Quote Originally Posted by wmmSuse View Post
    2. no sound

    speaker-test works great, but only as root.
    If you have not already done so, try adding your regular user to group "audio". There is advice here as to how you do that (see step-6 : how to fix a permissions problem):
    SDB:AudioTroubleshooting - openSUSE - step-6 How to fix a permissions problem

    Note, you should restart your PC after making that change so it has an effect.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •