Results 1 to 6 of 6

Thread: How to load "vesa" driver?

  1. #1
    Camalen NNTP User

    Default How to load "vesa" driver?

    Hello,

    I just downloaded the livecd iso for milestone 5 but I'm being bitten by
    this bug:

    ***
    Bug 529121 - [Milestone 5][live-CD]X server fails to start due to
    missing intel-agp/agpgart/i915/drm kernel modules
    https://bugzilla.novell.com/show_bug.cgi?id=529121
    ***

    Is there any way I can get the driver "vesa" to load instead of "intel" one
    which seems to be missed as kernel module and so it cannot load and I
    cannot get into X session?

    I've tried:

    - sax2 -r m 0=vesa -> no go

    - editing xorg.conf file -> it is not there, there is no /etc/X11/xorg.conf
    file

    Any advice will be highly appreciated :-)

    Greetings,
    --
    Camalen

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: How to load "vesa" driver?

    Quote Originally Posted by Camalen View Post
    I just downloaded the livecd iso for milestone 5 but I'm being bitten by this bug:

    ***
    Bug 529121 - [Milestone 5][live-CD]X server fails to start due to
    missing intel-agp/agpgart/i915/drm kernel modules
    https://bugzilla.novell.com/show_bug.cgi?id=529121
    ***

    Is there any way I can get the driver "vesa" to load instead of "intel" one
    which seems to be missed as kernel module and so it cannot load and I
    cannot get into X session?

    I've tried:
    - sax2 -r m 0=vesa -> no go
    - editing xorg.conf file -> it is not there, there is no /etc/X11/xorg.conf
    file
    At a "higher level" than load the vesa driver, what are you trying to do? Just play with the 11.2 milestone5 live CD ? Are you trying to install from the live CD ?

    ie Does the liveCD boot to a GUI and then fail during the installation ?
    or Does the liveCD fail when booting the GUI ?

    If the latter, with root permissions, then "sax -r -m 0=vesa" is the nominal way of loading the vesa driver. Note that is "zero equals vesa" and not "Oh equals vesa". You could try just "sax2 -m 0=vesa"

    The " -r " option removes the detection database and re-init the hardware database.

    ... If you have more than one graphic device, you could try "sax2 -m 1=vesa" to access the second graphic device. You could try that without and with " -r " (ie also try "sax2 -r -l -m 0=vesa" ... )

    You could also try to force lower levels of graphics for the vesa driver with " sax2 -l -m 0=vesa" (where "-l" forces a lower resolution - that is a lower-case "L" ).

    You could also try forcing the intel driver at a lower resolution with: " sax2 -l -m 0=intel "

    If you type "max sax2" you can read the various sax2 options.

  3. #3
    Camalen NNTP User

    Default Re: How to load "vesa" driver?

    oldcpu wrote:

    > At a "higher level" than load the vesa driver, what are you trying to
    > do? Just play with the 11.2 milestone5 live CD ? Are you trying to
    > install from the live CD ?


    I'm just "playing" with the LiveCD, not trying to installing it. Just want
    to check if all of my hardware is being correctly detected and how it looks
    the milestone 5, so nothing serious :-)

    > ie Does the liveCD boot to a GUI and then fail during the installation
    > ?
    > or Does the liveCD fail when booting the GUI ?


    LiveCD boots fine, but cannot load X session and leaves me into "init 3". As
    per the above bugzilla I mentioned, it seems the "intel" kernel module is
    missing from the LiveCD of Milestone 5 and cannot be loaded at all, so it
    falls into init 3.

    I would like to get into graphical mode using standard vga "vesa" driver, if
    that is possible.

    > If the latter, with root permissions, then "sax -r -m 0=vesa" is the
    > nominal way of loading the vesa driver. Note that is "zero equals vesa"
    > and not "Oh equals vesa". You could try just "sax2 -m 0=vesa"
    >
    > The " -r " option removes the detection database and re-init the
    > hardware database.


    I am testing now with: "sax2 -m 0=vesa". No go, but /var/log/SaX.log shows
    it tries to load vesa module and fails with the message "virtual width
    (3840) is too large for the hardware (max. 2048)... screen(s) found, but
    none have a usable configuration". That can be the clue...

    > ... If you have more than one graphic device, you could try "sax2 -m
    > 1=vesa" to access the second graphic device. You could try that without
    > and with " -r " (ie also try "sax2 -r -l -m 0=vesa" ... )


    I'm afraid I only have one embedded vga card O:-)

    > You could also try to force lower levels of graphics for the vesa
    > driver with " sax2 -l -m 0=vesa" (where "-l" forces a lower resolution
    > - that is a lower-case "L" ).


    That sounds good, let's try! :-)

    (...)

    Well, no luck, I still get the same response as above. It seems vesa driver
    tries to setup a screen size larger than the one it can handle and fails.

    > You could also try forcing the intel driver at a lower resolution with:
    > " sax2 -l -m 0=intel "


    Mmm... "intel" module is completely missing, it's not included in this
    Milestone 5 so it cannot be loaded (some developer forgot to add it while
    compiling or building the milestone into the OBS, dunno :-P).

    > If you type "max sax2" you can read the various sax2 options.


    Yes, I will try by forcing "vesa" driver to load a lower resolution by
    checking the available options. I will post here any advance :-)

    Thanks so much for the suggestions!

    Greetings,

    --
    Camalen

  4. #4
    Camalen NNTP User

    Default Re: How to load "vesa" driver? (solved)

    Camalen wrote:

    > oldcpu wrote:


    >> You could also try forcing the intel driver at a lower resolution with:
    >> " sax2 -l -m 0=intel "

    >
    > Mmm... "intel" module is completely missing, it's not included in this
    > Milestone 5 so it cannot be loaded (some developer forgot to add it while
    > compiling or building the milestone into the OBS, dunno :-P).
    >
    >> If you type "max sax2" you can read the various sax2 options.

    >
    > Yes, I will try by forcing "vesa" driver to load a lower resolution by
    > checking the available options. I will post here any advance :-)
    >
    > Thanks so much for the suggestions!


    Solved!

    A chap from the opensuse Spanish list suggested me to manually create a
    minimal /etc/X11/xorg.conf" file (as this file is not present at all) and
    that did the trick!

    ***
    Section "Monitor"
    Identifier "Monitor[0]"
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "vesa"
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    EndSection
    ***

    Then I've just had to run "startx" and now I'm in!

    Greetings,

    --
    Camalen

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: How to load "vesa" driver? (solved)

    Quote Originally Posted by Camalen View Post
    Solved!

    A chap from the opensuse Spanish list suggested me to manually create a
    minimal /etc/X11/xorg.conf" file (as this file is not present at all) and
    that did the trick!
    Congratulations! Thanks for sharing your solution.

    The possibility of creating a custom /etc/X11/xorg.conf file occured to me, but I felt that my idea as to what to put in the file was inadequate, plus I had never tried it before, so I did not want to waste your time with such a suggestion. Its neat to see the idea work.

    Well done in your determination in scouring around, finding some ideas, and then applying a solution !!

  6. #6

    Default Re: How to load "vesa" driver?

    I encountered similar the other day for those that don't want all that typing
    Code:
    X -configure
    will create a guessed one.

    After this it can be a small step to edit in vesa. iirc it will be at /root/xorg.conf-new(Something like this after running it will tell you). Then you can test with
    Code:
    X -config /root/xorg.conf-new
    Then if all goes OK move into the correct place
    Code:
    mv /root/xorg.conf-new /etc/X11/xorg.conf
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •