Results 1 to 10 of 10

Thread: DHCP configuration for Bell Wimax in home service

  1. #1

    Default DHCP configuration for Bell Wimax in home service

    I recently installed OpenSuse 11.1, to dual boot with Windows Vista. My internet connection is using the Bell WiMax in home service.

    The IP address setup is via DHCP. When I boot to OpenSuse, the DHCP request always times out and I do not obtain an IP address. I have verified that the interface is setup for DHCP, and can see the dhcp timeout logs in /var/log/messages.

    The Vista setup is very straightforward and just uses the "obtain an IP address automatically" radio button. There is no other special setting.

    Bell has claimed that they do not support linux, so I have not been able to get any help from them.

    What is the difference between the windows and linux DHCP request ? Does anyone know of any parm I have to set to get this working with linux ?

    Thanks

  2. #2
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: DHCP configuration for Bell Wimax in home service

    are you trying to connect wirelessly or wired ?

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  3. #3

    Default Re: DHCP configuration for Bell Wimax in home service

    Quote Originally Posted by deltaflyer44 View Post
    are you trying to connect wirelessly or wired ?

    Andy
    It's a wired connection. Are there any specific details I can post ?

    Thanks,
    Tash

  4. #4

    Default Re: DHCP configuration for Bell Wimax in home service

    Just an update. This does not seem to be an issue with openSuse in particular but linux in general. I tried the Ubuntu and archlinux Live CD's and they both exhibit the same problem when trying to configure the eth0 interface for dhcp. They both timeout after advertising for the lease.

    Thanks,
    Tash

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: DHCP configuration for Bell Wimax in home service

    tasha123 wrote:
    > Just an update. This does not seem to be an issue with openSuse in
    > particular but linux in general. I tried the Ubuntu and archlinux Live
    > CD's and they both exhibit the same problem when trying to configure the
    > eth0 interface for dhcp. They both timeout after advertising for the
    > lease.


    There is likely a bug in the driver. As it is the same for all distros
    that use the same kernel version, they will all behave the same.

    What kernel are you using? Post the output of 'uname -r'.

    What are the PCI ID's for your device. You can find that from the
    output of '/sbin/lspci -nnv'. Only post the paragraph that refers to
    the Wimax.

  6. #6

    Default Re: DHCP configuration for Bell Wimax in home service

    What kernel are you using? Post the output of 'uname -r'.
    2.6.27.7-9-pae

    What are the PCI ID's for your device. You can find that from the
    output of '/sbin/lspci -nnv'. Only post the paragraph that refers to
    the Wimax.
    There is no Wimax device on the computer. The DHCP is through the regular eth device. This is the lspci output for that device.

    00:19.0 Ethernet controller [0200]: Intel Corporation 82562V-2 10/100 Network Connection [8086:10c0] (rev 02)
    Subsystem: Dell Device [1028:020d]
    Flags: bus master, fast devsel, latency 0, IRQ 222
    Memory at fdfc0000 (32-bit, non-prefetchable) [size=128K]
    Memory at fdfff000 (32-bit, non-prefetchable) [size=4K]
    I/O ports at ff00 [size=32]
    Capabilities: [c8] Power Management version 2
    Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 Enable+
    Capabilities: [e0] Vendor Specific Information <?>
    Kernel driver in use: e1000e
    Kernel modules: e1000e

    This is what the device looks like in vista:

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . : sympatico.ca
    Description . . . . . . . . . . . : Intel(R) 82562V-2 10/100 Network Connecti
    on
    Physical Address. . . . . . . . . : 00-1D-09-88-B5-B4
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::2100:812:8c4:cb5b%9(Preferred)
    IPv4 Address. . . . . . . . . . . : 76.70.120.80(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : August-07-09 9:26:19 PM
    Lease Expires . . . . . . . . . . : August-08-09 12:26:20 AM
    Default Gateway . . . . . . . . . : 76.70.120.1
    DHCP Server . . . . . . . . . . . : 76.70.120.1
    DHCPv6 IAID . . . . . . . . . . . : 201334025
    DNS Servers . . . . . . . . . . . : 207.164.234.193
    207.164.234.129
    NetBIOS over Tcpip. . . . . . . . : Enabled

    In OpenSuse, I see the following logs:
    Aug 7 19:58:26 linux-0ect dhcpcd[2750]: eth0: timed out
    Aug 7 19:58:26 linux-0ect dhcpcd[2750]: eth0: trying to use old lease in `/var/lib/dhcpcd/dhcpcd-eth0.info'
    Aug 7 19:58:26 linux-0ect dhcpcd[2750]: eth0: broadcasting for a lease
    Aug 7 19:58:46 linux-0ect dhcpcd[2750]: eth0: timed out

    The parms in dhcpcd-eth0.info are:
    # cat /var/lib/dhcpcd/dhcpcd-eth0.info
    INTERFACE='eth0'
    CLASSID='dhcpcd 3.2.3'
    CLIENTID='01:00:1d:09:88:b5:b4'
    DHCPCHADDR='00:1d:09:88:b5:b4'

    In OpenSuse, if I tcpdump eth0, I do see some kind of a response:

    21:23:50.096671 IP 76.67.40.154.6646 > 76.67.40.255.6646: UDP, length 1320

    Yet, it never configures an IP address.

    Thanks,
    Tash

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: DHCP configuration for Bell Wimax in home service

    I have seen postings regarding problems with the e1000e driver. I
    don't think they were fixed by 2.6.27 - the kernel in openSUSE 11.1.

    If you can, please download the Live CD for openSUSE 11.2 Milestone 5.
    The kernel in it is very new. If it is able to connect to the network,
    you will know it is a driver problem. If it also fails, then there is
    a Linux problem with your setup.

  8. #8

    Default Re: DHCP configuration for Bell Wimax in home service

    Thanks lwfinger.

    The 11.2 Build 5 LiveCD was able to bring up the networking. That has the 2.6.31 kernel.

    I have one question about the 11.2 version. I was not able to directly boot to run level 5 from the Live CD. I would get a blank screen after the inital boot sequence in normal and failsafe modes.

    I was able to boot to run level 3 and then use init 5 to launch kde. Is this a known issue ?

    Thanks again for the suggestion,
    Tash

  9. #9
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: DHCP configuration for Bell Wimax in home service

    tasha123 wrote:
    > Thanks lwfinger.
    >
    > The 11.2 Build 5 LiveCD was able to bring up the networking. That has
    > the 2.6.31 kernel.
    >
    > I have one question about the 11.2 version. I was not able to directly
    > boot to run level 5 from the Live CD. I would get a blank screen after
    > the inital boot sequence in normal and failsafe modes.
    >
    > I was able to boot to run level 3 and then use init 5 to launch kde.
    > Is this a known issue ?


    It is not a problem for me. Did you have to configure X before the
    init 5, or just run the init.

    Larry

  10. #10

    Default Re: DHCP configuration for Bell Wimax in home service

    Quote Originally Posted by lwfinger View Post

    It is not a problem for me. Did you have to configure X before the
    init 5, or just run the init.

    Larry
    I didn't have to configure X before running init 5. I have the same problem after I installed 11.2 as well.

    Tash

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •