Results 1 to 4 of 4

Thread: alsamixer and default soundcard

  1. #1

    Default alsamixer and default soundcard

    Hi all!

    I have behringer UCA202 usb card, after plug to usb, it just works , I have only small problem with alsamixer, which still shows by default my integrated HDA Intel, I could switch it by F6 or by alsamixer -c 1 .. no problem, but I expect that default card is now plugged "USB audio", see :
    Code:
    cat /proc/asound/cards
     0 [Intel          ]: HDA-Intel - HDA Intel
                          HDA Intel at 0xfc300000 irq 22
     1 [default        ]: USB-Audio - USB Audio CODEC
                          Burr-Brown from TI USB Audio CODEC  at usb-0000:00:1d.1-2, full s
    so why alsamixer recognize default audio device as HDA intel and not a USB Audio ?
    anyone who has two or more sound cards with the same issue ?

    I am using latest Factory but I also do tests on 11.1 and it's the same

    thanks
    Last edited by mseben; 07-Aug-2009 at 05:29. Reason: forgotten version of used openSUSE

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: alsamixer and default soundcard

    I don't have two audio devices. ... I note the following wiki:
    USB headphones - openSUSE
    which suggests:

    Initial configuration
    To get openSUSE working with USB headphones, it is quite easy.
    • Connect the USB headphones.
    • Select the SuSE menu > Applications tab > System > Administrator Settings (YaST)
    • Select Hardware > Sound

    You should see a list of audio cards. Sometimes, it doesn't list the USB headphones automatically. If not, we can add it manually.
    • Click Add
    • Search for USB audio
    • Select USB Audio, Generic
    • Click Next
    • Leave Quick Automatic Setup selected and click Next

    You should now see your sound cards including the USB headset. Now we need the system to prefer the USB headphones, when connected.
    • Select USB Audio
    • Select Other button > Set as the primary card
    • Click Finish

    At this point, the USB headphones should be active. You will need to have them connected when the computer starts, or you will need to restart the sound services to make them active.

    If the computer is started without the USB headphones, the soundcard will be the active sound device.
    Does that shed any light on this?

    Again, since I do not have such hardware, I can not offer any information from experience.

    Good luck!

  3. #3

    Default Re: alsamixer and default soundcard

    thanks for quick reply ...
    this helps, now is default device 'USB audio"
    anyway this is not solution for me ... when I unplug sound card an type alsamixer I got :
    Code:
    cannot open mixer: No such file or directory,
    because /dev/snd/controlC0 didn't exist ... when I plug usb card back, alsamixer works again,

    I am just wondering why alsamixer can't check default device (using e.g /proc/asound/cards) and simple used it as default device

    anyway thanks ...

  4. #4

    Default Re: alsamixer and default soundcard

    # gpassw -a <user login> audio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •