Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Digikam crashing on start up

  1. #1
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Digikam crashing on start up

    I have just updated to KDE 4.3 and now Digikam 0.10.0 keeps crashing on start up. Version 0.9.4-51 works fine.
    I have also tried the 1.0 beta but that won't work either.

    Application: digiKam (digikam), signal: Aborted
    [Current thread is 1 (Thread 0x7fdb23690750 (LWP 29094))]

    Thread 2 (Thread 0x7fdb0e4e2950 (LWP 29095)):
    [KCrash Handler]
    #5 0x00007fdb1c40a645 in raise () from /lib64/libc.so.6
    #6 0x00007fdb1c40bc33 in abort () from /lib64/libc.so.6
    #7 0x00007fdb1d11df15 in qt_message_output(QtMsgType, char const*) () from /usr/lib64/libQtCore.so.4
    #8 0x00007fdb1d11e05b in qFatal(char const*, ...) () from /usr/lib64/libQtCore.so.4
    #9 0x00007fdb1d22324d in QObjectPrivate::QObjectPrivate(int) () from /usr/lib64/libQtCore.so.4
    #10 0x00007fdb2193ebad in QSqlDriver::QSqlDriver(QObject*) () from /usr/lib64/libQtSql.so.4
    #11 0x00007fdb219378c2 in ?? () from /usr/lib64/libQtSql.so.4
    #12 0x00007fdb21937c29 in QSqlDatabase::QSqlDatabase() () from /usr/lib64/libQtSql.so.4
    #13 0x00007fdb205cfea6 in Digikam:atabaseBackendPriv::databaseForThread() () from /usr/lib64/libdigikamdatabase.so.1
    #14 0x00007fdb205cb33d in Digikam:atabaseBackend:pen (this=0xb74260, parameters=<value optimized out>) at /usr/src/debug/digikam-0.10.0/libs/database/databasebackend.cpp:293
    #15 0x00007fdb205c6920 in Digikam:atabaseAccess::checkReadyForUse (observer=0xb749e0) at /usr/src/debug/digikam-0.10.0/libs/database/databaseaccess.cpp:231
    #16 0x000000000064ba5d in Digikam::ScanController::run (this=0xb749d0) at /usr/src/debug/digikam-0.10.0/digikam/scancontroller.cpp:420
    #17 0x00007fdb1d125e65 in ?? () from /usr/lib64/libQtCore.so.4
    #18 0x00007fdb1ceb2070 in start_thread () from /lib64/libpthread.so.0
    #19 0x00007fdb1c4ab10d in clone () from /lib64/libc.so.6
    #20 0x0000000000000000 in ?? ()


    This is only the first half of the crash info.
    (Some how the full report contains 9 images & I am allowed only 4)

    Thanks for any help.

  2. #2
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Re: Digikam crashing on start up

    Ahhh, I see the image problem

    I'll try the whole crash info.

    Application: digiKam (digikam), signal: Aborted
    [Current thread is 1 (Thread 0x7f303148d750 (LWP 5133))]

    Thread 2 (Thread 0x7f301f11b950 (LWP 5134)):
    [KCrash Handler]
    #5 0x00007f302a207645 in raise () from /lib64/libc.so.6
    #6 0x00007f302a208c33 in abort () from /lib64/libc.so.6
    #7 0x00007f302af1af15 in qt_message_output(QtMsgType, char const*) () from /usr/lib64/libQtCore.so.4
    #8 0x00007f302af1b05b in qFatal(char const*, ...) () from /usr/lib64/libQtCore.so.4
    #9 0x00007f302b02024d in QObjectPrivate::QObjectPrivate(int) () from /usr/lib64/libQtCore.so.4
    #10 0x00007f302f73bbad in QSqlDriver::QSqlDriver(QObject*) () from /usr/lib64/libQtSql.so.4
    #11 0x00007f302f7348c2 in ?? () from /usr/lib64/libQtSql.so.4
    #12 0x00007f302f734c29 in QSqlDatabase::QSqlDatabase() () from /usr/lib64/libQtSql.so.4
    #13 0x00007f302e3ccea6 in Digikam: DatabaseBackendPriv:: databaseForThread() () from /usr/lib64/libdigikamdatabase.so.1
    #14 0x00007f302e3c833d in Digikam: DatabaseBackend: open (this=0xacd080, parameters=<value optimized out>) at /usr/src/debug/digikam-0.10.0/libs/database/databasebackend.cpp:293
    #15 0x00007f302e3c3920 in Digikam: DatabaseAccess::checkReadyForUse (observer=0xaefc10) at /usr/src/debug/digikam-0.10.0/libs/database/databaseaccess.cpp:231
    #16 0x000000000064ba5d in Digikam::ScanController::run (this=0xaefc00) at /usr/src/debug/digikam-0.10.0/digikam/scancontroller.cpp:420
    #17 0x00007f302af22e65 in ?? () from /usr/lib64/libQtCore.so.4
    #18 0x00007f302acaf070 in start_thread () from /lib64/libpthread.so.0
    #19 0x00007f302a2a810d in clone () from /lib64/libc.so.6
    #20 0x0000000000000000 in ?? ()

    Thread 1 (Thread 0x7f303148d750 (LWP 5133)):
    #0 0x00007f302acb2d59 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
    #1 0x00007f302af23e19 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
    #2 0x00007f302af2300c in QThread::wait(unsigned long) () from /usr/lib64/libQtCore.so.4
    #3 0x000000000064b8dc in Digikam::ScanController::shutDown (this=0xaefc00) at /usr/src/debug/digikam-0.10.0/digikam/scancontroller.cpp:264
    #4 0x000000000064f37b in ~ScanController (this=0xaefe9c) at /usr/src/debug/digikam-0.10.0/digikam/scancontroller.cpp:247
    #5 0x000000000064f517 in destroy () at /usr/src/debug/digikam-0.10.0/digikam/scancontroller.cpp:188
    #6 0x00007f302a20a2ed in exit () from /lib64/libc.so.6
    #7 0x00007f302bbe4098 in ?? () from /usr/lib64/libQtGui.so.4
    #8 0x00007f302cf66138 in KApplication::xioErrhandler( _XDisplay*) () from /usr/lib64/libkdeui.so.5
    #9 0x00007f3029013e54 in _XIOError () from /usr/lib64/libX11.so.6
    #10 0x00007f302901bf48 in _XSend () from /usr/lib64/libX11.so.6
    #11 0x00007f302901c014 in _XEventsQueued () from /usr/lib64/libX11.so.6
    #12 0x00007f3029004593 in XEventsQueued () from /usr/lib64/libX11.so.6
    #13 0x00007f302bc1e79b in ?? () from /usr/lib64/libQtGui.so.4
    #14 0x00007f30278990fb in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
    #15 0x00007f302789c8cd in ?? () from /usr/lib64/libglib-2.0.so.0
    #16 0x00007f302789ca8b in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
    #17 0x00007f302b035d3f in QEventDispatcherGlib:rocessEvents( QFlags<QEventLoop:rocessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #18 0x00007f302bc1dfff in ?? () from /usr/lib64/libQtGui.so.4
    #19 0x00007f302b00b1d2 in QEventLoop:rocessEvents(QFlags<QEventLoop:rocessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #20 0x00007f302b00b5a4 in QEventLoop::exec( QFlags<QEventLoop:: ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #21 0x000000000064b606 in Digikam::ScanController: databaseInitialization (this=0xaefc00) at /usr/src/debug/digikam-0.10.0/digikam/scancontroller.cpp:308
    #22 0x00000000005d80e2 in Digikam::AlbumManager::setDatabase (this=0xab32a0, dbPath=<value optimized out>, priority=<value optimized out>)
    at /usr/src/debug/digikam-0.10.0/digikam/albummanager.cpp:506
    #23 0x00000000006717f9 in main (argc=5, argv=0x7fff394e38e8) at /usr/src/debug/digikam-0.10.0/digikam/main.cpp:158

    Sorry about the smilies. Is there a way to turn them off?

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,403

    Default Re: Digikam crashing on start up

    About the smileys: when you put computer text between CODE tags is will be:
    1) be recongnised as such;
    2) be more readable;
    3) not have smileys.
    Just use the # in the toolbar after selecting.

    I do have the same problem with digicam (so you do not feel alone).
    Code:
    Systeemconfiguratie opstartcontrole uitgeschakeld.
    
     [?1034h(no debugging symbols found)
    Using host libthread_db library "/lib/libthread_db.so.1".
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    [Thread debugging using libthread_db enabled]
    [New Thread 0xb5b21950 (LWP 9071)]
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    [KCrash handler]
    #6  0xb5e9c3ec in Exiv2::JpegBase::readMetadata () from /usr/lib/libexiv2.so.0
    #7  0xb2c0647b in KJpegPlugin::readInfo ()
       from /opt/kde3/lib/kde3/kfile_jpeg.so
    #8  0xb79995cf in KFileMetaInfo::init () from /opt/kde3/lib/libkio.so.4
    #9  0xb79996e2 in KFileMetaInfo::KFileMetaInfo ()
       from /opt/kde3/lib/libkio.so.4
    #10 0xb79997a5 in KFileItem::metaInfo () from /opt/kde3/lib/libkio.so.4
    #11 0xb7dd190e in Digikam::ImagePropertiesTab::setCurrentURL ()
       from /opt/kde3/lib/libdigikam.so.0
    #12 0xb7dbbc1a in Digikam::ImagePropertiesSideBarDB::slotChangedTab ()
       from /opt/kde3/lib/libdigikam.so.0
    #13 0xb7dbc072 in Digikam::ImagePropertiesSideBarDB::itemChanged ()
       from /opt/kde3/lib/libdigikam.so.0
    #14 0xb7dbc1a6 in Digikam::ImagePropertiesSideBarDB::itemChanged ()
       from /opt/kde3/lib/libdigikam.so.0
    #15 0xb7c7b978 in Digikam::DigikamView::slotDispatchImageSelected ()
       from /opt/kde3/lib/libdigikam.so.0
    #16 0xb7c7bf82 in Digikam::DigikamView::qt_invoke ()
       from /opt/kde3/lib/libdigikam.so.0
    #17 0xb6df9b4d in QObject::activate_signal ()
       from /usr/lib/qt3/lib/libqt-mt.so.3
    #18 0xb6dfa6ed in QObject::activate_signal ()
       from /usr/lib/qt3/lib/libqt-mt.so.3
    #19 0xb712fea9 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
    #20 0xb6e1cbaf in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
    #21 0xb6d9b33c in QApplication::internalNotify ()
       from /usr/lib/qt3/lib/libqt-mt.so.3
    #22 0xb6d9c126 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
    #23 0xb7416c92 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
    #24 0xb6d90614 in QEventLoop::activateTimers ()
       from /usr/lib/qt3/lib/libqt-mt.so.3
    #25 0xb6d4a573 in QEventLoop::processEvents ()
       from /usr/lib/qt3/lib/libqt-mt.so.3
    #26 0xb6db1ec0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
    #27 0xb6db1d56 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
    #28 0xb6d9aeaf in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
    #29 0x0804ae96 in main ()
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,403

    Default Re: Digikam crashing on start up

    I can add that it happens somewhere when the directories containing the albums are interpreted. I moved my albums to another place and started Digicam. It started without problems. I changed its config to point to the new directory with the albums. After finishing this it started searching through the albums and Boing!

    I have version 0.9.3 0.pm.2, a Packman one I tried because I already had the problem.
    Henk van Velden

  5. #5
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Re: Digikam crashing on start up

    Quote Originally Posted by hcvv View Post
    I can add that it happens somewhere when the directories containing the albums are interpreted. I moved my albums to another place and started Digicam. It started without problems. I changed its config to point to the new directory with the albums. After finishing this it started searching through the albums and Boing!

    I have version 0.9.3 0.pm.2, a Packman one I tried because I already had the problem.
    I have just moved the folder with all my photographs and tried starting it again. This time it started into the "first run wizard" but crashes just after creating the "Pictures" folder. I have tried using another folder but get the same result. Also tried deleting the digikam4.db file... no change.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,403

    Default Re: Digikam crashing on start up

    IMHO this should be reported on https://bugs.kde.org/. The fact that I did not is because I am on KDE 3.5 (and the corresponding lower digikam level) and knew that they won't do much on it. Maybe you can report there with your up-to-date level.
    Henk van Velden

  7. #7
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Re: Digikam crashing on start up

    Ok, I'll look into doing that. Thanks for the help.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,403

    Default Re: Digikam crashing on start up

    Hm, I checked in bugs.kde.org with the keywords SIGSEGV in Digikam. A few are almost like ours, but the answers are not very satisfactory.

    May be I go back to the original 10.3 (0.9.2-51), because the security update (0.9.2-51.2) crashes and the Packman one (0.9.3-0.pm.2) also.

    Living dangerous without the security update
    Henk van Velden

  9. #9

    Default Re: Digikam crashing on start up

    Quote Originally Posted by asarge View Post
    I have just updated to KDE 4.3 and now Digikam 0.10.0 keeps crashing on start up. Version 0.9.4-51 works fine.
    I have also tried the 1.0 beta but that won't work either.
    openSUSE 11.1 x86-64, digikam-0.10.0-18.14 from KDE:KDE4:Factory:Desktop... works fine.

    If isn't a problem of config/data (delete/move ~/.kde4/share/config/digikamrc and ~/.kde4/share/apps/digikam, plus photo dirs) I suppose it is a mixing of packages. Could you copy&paste the output of "LC_ALL=C zypper -v se -s | fgrep '(System Packages)'"? And the one from "zypper lr -d" could also help.

  10. #10
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Re: Digikam crashing on start up

    Quote Originally Posted by RedDwarf View Post
    openSUSE 11.1 x86-64, digikam-0.10.0-18.14 from KDE:KDE4:Factoryesktop... works fine.

    If isn't a problem of config/data (delete/move ~/.kde4/share/config/digikamrc and ~/.kde4/share/apps/digikam, plus photo dirs) I suppose it is a mixing of packages. Could you copy&paste the output of "LC_ALL=C zypper -v se -s | fgrep '(System Packages)'"? And the one from "zypper lr -d" could also help.
    I have tried removing the files/folders but that didn't change anything.
    Here is the output for "zypper lr -d". When trying to post the output from "LC_ALL=C zypper -v se -s | fgrep '(System Packages)'" I get a message saying I have too many characters. Is there any specific part that I can post?
    Code:
    sarge@linux-03ep:~> zypper lr -d
    # | Alias                 | Name                                  | Enabled | Refresh | Priority | Type   | URI                                                                                   | Service
    --+-----------------------+---------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------+--------
    1 | KDE:KDE4:Playground   | KDE:KDE4:Playground                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Playground/openSUSE_11.1_KDE_42/ |
    2 | Qt_4.5                | Qt 4.5                                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt/openSUSE_Factory/                   |
    3 | openSUSE 11.1-0       | openSUSE 11.1-0                       | No      | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                                               |
    4 | openSUSE-11.1-Non-Oss | openSUSE-11.1-Non-Oss                 | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss                           |
    5 | openSUSE:11.1:NonFree | openSUSE:11.1:NonFree                 | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/repositories/openSUSE:/11.1:/NonFree/standard/           |
    6 | repo                  | openSUSE BuildService - KDE:Community | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Community/openSUSE_11.1/               |
    7 | repo-update           | openSUSE-11.1-Update                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/                                             |
    8 | repo_3                | Packman Repository                    | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/                                           |
    9 | repo_6                | Main Repository (OSS)                 | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •