I'M SORRY, PLEASE DISREGARD MY PREVIOUS POST, IT'S NONSENSE!

if your apache2 server is using default settings, which mine isn't, you
SHOULD be doing exactly what you said: change the AllowOverride value in
mod_userdir.conf. doing what i wrote earlier would leave your system open
to all types of attacks, especially if your webserver is accessible over
the internet.

in this case you would set up your website in your home directory, i.e.,
/home/<your-user-name>/public_html, as it's supposed to be. but you'd have
to make sure that the mod_userdir module is enabled, of course.

--
phani.


On Tue, 22 Feb 2011 23:14:47 +0530, phanisvara <listmail@phanisvara.com>
wrote:

> On Tue, 22 Feb 2011 22:36:03 +0530, Ski K2
> <Ski_K2@no-mx.forums.opensuse.org> wrote:
>
>>
>> Hope someone can confirm I have done this the correct way!
>>
>> I edited /etc/apache2/mod_userdir.conf and changed
>>
>> AllowOverride All
>> Options All
>>
>> Now I do not get Internal Serrver Errors when I have a .htaccess file
>> in my user/public_html directories

>
>
> i'm afraid that, depending on your apache2 configuration, this won't
> work. i suspect you're not getting an error because that file,
> mod_userdir.conf, isn't pulled into the standard config file
> (/etc/apache2/httpd.conf) -- this option is commented out. i also don't
> think that this is what mod_userdir.conf is supposed to do.
>
> if you want to set that option, to allow .htaccess to modify
> permissions, server-wide i would set it directly in httpd.conf, where it
> says:
>
>
Code:
> <Directory />
>      Options None
>      AllowOverride None
>      Order deny,allow
>      Deny from all
> </Directory>
>
>
> changing "AllowOverride None" to "AllowOverride All", or whatever
> permissions you want to allow.
>
> otherwise, if you have enabled different virtual hosts, in
> /etc/apache2/vhosts.d/<your-virtual-server>.conf
>



--
phani.