Results 1 to 8 of 8

Thread: Processor only listed at half normal clock speed

  1. #1

    Default Processor only listed at half normal clock speed

    I bought an Acer Aspire X1300 over the weekend to play with various linux distros, and I thought I would start with OpenSUSE. The sucker came pre-loaded with Vista, and BitLocker seemed to screw up partitioning, so I actually bought another hard drive and swapped out, leaving the Vista install drive sitting in the box that the blank HD came in.

    Anyway, after install, I look in the system settings, and it lists my processor as having two cores running at 1.2 Ghz. Now, the processor is an Athlon X2 7450 which should be running at 2.4 Ghz. The board is a Foxconn (don't know which model), running off of an Nvidia 8200 onboard chipset. I'm pretty sure that it's a software/driver issue (I'm still running off of generic drivers and haven't been hooked up to the net yet), but I'm just a bit worried as I had to do some pretty significant tinkering to replace the HDD in that small form-factor case. Is there a chance that I damaged something swapping out drives and that's why my processors are only listed at half speed? FYI I'm running the 32-bit x86 version of 11.1, not amd-64. Could that account for the difference?

    I suppose I can throw the Vista disk back in and confirm whether or not it's a hardware issue that way, but I'd rather not since I have no intention of using it (I couldn't stand throwing it away though, since the machine didn't come with OS media and I already paid the Windows Tax for it). Any ideas?

  2. #2

    Default Re: Processor only listed at half normal clock speed

    You probably have the cpu frequency "adjustable" depending on needs. Nothing to worry about, in most cases such settings can be adjusted in the motherboard.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3

    Default Re: Processor only listed at half normal clock speed

    Go to software management, install cpufreq utility. After that open console and post the output of cpufreq-info in here.

    It should have "ondemand" as the current governor.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  4. #4

    Default Re: Processor only listed at half normal clock speed

    Thanks! As soon as I can get that output I'll post it.

  5. #5
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Processor only listed at half normal clock speed

    BenderBendingRodriguez adjusted his/her AFDB on Wednesday 05 Aug 2009 15:06
    to write:

    >
    > Go to software management, install cpufreq utility. After that open
    > console and post the output of cpufreq-info in here.
    >
    > It should have "ondemand" as the current governor.
    >
    >


    Also if running KDE4.3

    You can stick CpuFreqDisplay plasmoid on the desktop and that will just
    simply show you what freq is at any time, so if you do have "Dynamic" set in
    the power options you will see it switch up and down depending on load.

    My CPUs have about four steppings, 800, 1400, 200, 2600 and they go up and
    down automagically.

    :-)

    HTH
    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  6. #6
    Join Date
    Jun 2008
    Location
    Charleston, SC, USA
    Posts
    192

    Default Re: Processor only listed at half normal clock speed

    Also, the CPU governor doesn't necessarily impact system performance. So even though it clocks your CPU down, that just means you don't need the full power of your CPU with whatever the machine is currently doing. If you start doing something major (like playing an extremely intense game, running multiple virtual machines, etc) it will bump your CPU back up to max.
    My personal philosophy:
    The only way you won't find something is if you stop looking.

  7. #7

    Default Re: Processor only listed at half normal clock speed

    Yeah, I didn't expect that it would keep the clock throttled down all the time -- like you said, for idle or light load. The little guy's only got a 220W PS to begin with, so it's just as well (if nothing else, my wallet will thank me a bit, right?).

    Do you know if this is part of AMD's "Cool'n'Quiet" technology (I noticed on AMD's site they mentioned "wideband frequency control" as part of "Cool'n'Quiet" 2.0), or is it an OS feature enabled on all OpenSUSE installs?

    I'll post the cpufreq-info as soon as I can, but I currently don't actually have internet access for the computer -- if I can't install the package off of the DVD repository then I will post it back here this weekend.

    Oh, and as you can probably guess, it's still on KDE 4.1.3 from the install

  8. #8

    Default Re: Processor only listed at half normal clock speed

    You don't need to post it if you discovered that it's fine and is part of Cool'n'Quiet. Everything must support it Motherboard, CPU and OS. With the OS (here openSUSE) you can set how low will it go etc.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •