Results 1 to 10 of 10

Thread: Strigi not starting on KDE 4.3 in openSUSE 11.1

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Strigi not starting on KDE 4.3 in openSUSE 11.1

    I just upgrade to KDE 4.3 and it is great release, one problem I have
    found with it is that The Strigi Desktop File Indexer does not want to
    start. The error that I get is "Strigi service failed to initialize,
    most likely due to an installation problem.", does anyone here know if
    Strigi logs things like this and were?
    --
    "We must plan for freedom, and not only for security, if for no other
    reason than only freedom can make security more secure." Karl Popper

  2. #2

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    Install java openjdk-devel and soprano-backend-sesame. That's it.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    BenderBendingRodriguez wrote:

    >
    > Install java openjdk-devel and soprano-backend-sesame. That's it.
    >
    >


    Unless logging out and back in is required, which I don't think it
    should, something else has to be wrong because according to zypper I have
    both installed already
    --
    "We must plan for freedom, and not only for security, if for no other
    reason than only freedom can make security more secure." Karl Popper

  4. #4

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    Have you tried creating a new user and check if that happens with the new user also? If that won't happen then it would be a matter of clearing the config files
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  5. #5
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    Hi,

    as suggested by BenderBendingRodriguez the installation of these two packages (and a reboot) and striggi is working. Now it's indexing the files.
    But, how can I do a desktop search with striggi?

    Greetings

    Michael

  6. #6

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    Quote Originally Posted by BenderBendingRodriguez View Post
    Install java openjdk-devel and soprano-backend-sesame. That's it.
    many thanks, that finally made nepomuksearch work for me.
    Why the hell were those not installed by default if nepomuk and strigi need them?

  7. #7

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    To search with that you only need nepomuk turned on. Strigi doesn't have to be ticked. You may start strigi once to index everything or you may leave it till the end of the universe on (it takes about 100MB of memory, mind that

    By the way, when you install most applications in openSUSE (or any linux distro) then in most cases you DO NOT NEED to restart the system, it is not Windows

    Searching is done with krunner, just press Alt + F2 and type something you know you have
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  8. #8
    Join Date
    Jun 2008
    Location
    Cleveland, TN USA
    Posts
    412

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    For me all I had to do was logout and back in, something in a config file I guess, also searching can be done through Dolphin in KDE 4.3, just use the search bar.

    Restarting is for installing a new kernel silly
    "We must plan for freedom, and not only for security, if for no other reason than only freedom can make security more secure." Karl Popper

  9. #9
    Join Date
    Jun 2008
    Location
    Levin, New Zealand
    Posts
    227

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    Cheers, I have added your solution to the bug for this problem


  10. #10
    Join Date
    Aug 2010
    Posts
    11

    Default Re: Strigi not starting on KDE 4.3 in openSUSE 11.1

    Strigi also has a dependency on a backend such as CLucene, so this or another backend also needs to be installed. See the README at /usr/share/doc/packages/strigi. In addition, after I installed CLucene and then installed openjdk-devel and soprano-backend-sesame with all of its dependencies dragged in by sesame, I then went into Personal Settings/Desktop Search to start the Strigi service by clicking the checkbox and then Apply and it still complained that it could not start it and that it was probably installed incorrectly; however, after exiting Personal Settings Nepomuk and Strigi immediately started indexing, contrary to the complaint, and I can now find file contents for those files that have already been indexed and indexing continues unabated. This worked under OpenSuSE 11.2 and KDE 4.3.5 Release 0.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •