Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Root password not accepted by YAST, SAX2.

  1. #1

    Default Root password not accepted by YAST, SAX2.

    After a new installation of 11.2, I found I could not use YAST (or SAX2) as
    the root password would not be accepted. I tried the same password in a
    terminal window and "su" was happy with it. I can also log on as Root with
    the password. Both user sessions on this system are similarly affected.

    I've made other installations of 11.2 and not had this problem before so the
    glitch seems unrelated to 11.2 - just one of those things. How can I fix it?

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Root password not accepted by YAST, SAX2.

    It's a kernel bug. Kernel 2.6.31 is in the Factory repos now. Bug is already being worked on.
    Weird thing is: if I persist in clicking OK, I do get the root access.....
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    goldie NNTP User

    Default Re: Root password not accepted by YAST, SAX2.

    shouldn't this thread have been originated in
    http://forums.opensuse.org/pre-release-beta/

    and, shouldn't it be moved there (so those affected might see it)?

    --
    goldie

  4. #4

    Default Re: Root password not accepted by YAST, SAX2.

    goldie wrote:

    > shouldn't this thread have been originated in
    > http://forums.opensuse.org/pre-release-beta/
    >
    > and, shouldn't it be moved there (so those affected might see it)?
    >


    I didn't put it there because I didn't think it was 11.2-related as I'd
    already made several installs without this problem showing up. I assumed it
    was just the luck of the draw - one of these daft things that happen from
    time to time. It seemed to me that the problem was likely to have shown up
    before with other releases and the cure, assuming there was one, would be
    similarly general.

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

  5. #5

    Default Re: Root password not accepted by YAST, SAX2.

    Knurpht wrote:

    >
    > It's a kernel bug. Kernel 2.6.31 is in the Factory repos now. Bug is
    > already being worked on.
    > Weird thing is: if I persist in clicking OK, I do get the root
    > access.....
    >
    >


    Odd. I was sure this problem showed up from the start, i.e. before I updated
    the kernel. I might try a few more experiments.

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

  6. #6
    goldie NNTP User

    Default Re: Root password not accepted by YAST, SAX2.

    sorry, it was not my intention to say you had done wrong, rather it
    was a *HINT* to a moderator to move it...so other testers have the
    benefit..

    --
    goldie

  7. #7

    Default Re: Root password not accepted by YAST, SAX2.

    goldie wrote:

    > sorry, it was not my intention to say you had done wrong, rather it
    > was a *HINT* to a moderator to move it...so other testers have the
    > benefit..
    >


    No problem. I've done an update on another machine and found the same
    problem, so Knuroht was correct in saying it was a kernel bug - I'd made a
    mistake in recognising when the problem had happened during installation.

    So, yes, I now agree that the thread would be better located in "prerelease-
    beta". Of course, if all the correspondence had occurred on NNTP, all the
    relevant info would probably be in one posting and I could do it myself.
    Sorry, couldn't resist jumping onto the nearest soapbox. ;-)

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Root password not accepted by YAST, SAX2.

    Moved to Pre-Release Beta
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Root password not accepted by YAST, SAX2. [Solved]

    Knurpht wrote:

    >
    > It's a kernel bug. Kernel 2.6.31 is in the Factory repos now. Bug is
    > already being worked on.
    > Weird thing is: if I persist in clicking OK, I do get the root
    > access.....
    >


    Latest update has fixed the problem.

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

  10. #10

    Default Re: Root password not accepted by YAST, SAX2. [Solved]

    caf4926 wrote:

    >
    > Moved to Pre-Release Beta
    >
    >


    Latest kernel update has fixed the problem.

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy
    "I wear the cheese. It does not wear me."

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •