Results 1 to 6 of 6

Thread: Konqueror & bash scripts - no terminal window

  1. #1
    axel_bock NNTP User

    Default Konqueror & bash scripts - no terminal window

    Hello all,

    we are using SLES 10 SP2 and KDE in our company, and I have this annoying little problem with Konqueror: Whenever I start a shell script (bash, python, etc.) with the Konqueror, it will be executed ... but without any indication!

    So basically for the user "nothing" happens. Although the script is executed in the background.

    I would like that a terminal window is opened if I click on the script, so that I have a visual feedback. Is that possible?

    Thanks for any ideas!
    Axel.

  2. #2
    goldie NNTP User

    Default Re: Konqueror & bash scripts - no terminal window

    > Thanks for any ideas!

    see here: http://tinyurl.com/lylhho

    --
    goldie

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: Konqueror & bash scripts - no terminal window

    When you start something from Konqueror, of course the only thing that starts is the script. You could change the srcipt, so it starts Konsole, with that what was the original script as the command to execute. Like:
    Code:
    konsole -e /path/to/script
    You could also create icons on the desktop or in the panel that call konsole with a command (your script) to execute.

    IMHO is basic Unix/Linux/KDE, thus independent from the fact that you use SLES and we openSUSE
    Henk van Velden

  4. #4
    axel_bock NNTP User

    Default Re: Konqueror & bash scripts - no terminal window

    yep, that's what I hoped - that this is basic Linux only ;-) .

    BUT. *I* use those scripts from the command line. *My colleagues* use them from Konqueror. So I would like to reconfigure the Konqueror so that it opens a terminal window on bash scripts.

    Is that possible, maybe?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: Konqueror & bash scripts - no terminal window

    Well, I tried a few things.

    1) I generated a script and gave it a name ending in a (more or less unique) ending, e.g. .bik (meaning bash-in-konsole to me). (Some people call this an extension, but that may let people think that it is like the extention on MS file systems, which it is not).

    2) I went to Konqueror > Configuration > Configure Konqueror > Fileassosiations (the real terms might differ, I have a Dutch translation here and try to translate back). I clicked Add. It asks for a group and I choose text (imo it does not matter which you choose, but it seems appropriate). It asks for a typename, choose what you like, e.g. bashinkons.

    3) The new entry is shown at the right. Add a pattern '*.bik*. Add an application: "konsole". In the 'Embedding" tab choose "open in external .." and uncheck "ask for store on disk".
    Back to the General tab and select the "konsole" you just entered in the lower field and click "Change". In the new window go to the appplication tab and fill in the command "konsole -e". Finish everythhing.

    Now when you click a file ending in .bik, Konqui will open a console with the application running inside. My testscript is test.bik:
    Code:
    #!/bin/bash
    echo "bik-test"
    read A
    Without the read the konsole window will only flash before it finishes.

    So I think I did it. But you have to change all the names of the scripts wich are to be run thus. But there mus be a method to tell Konqui what to do.

    Alternative is what I told you earlier. In the place where *they* click use:
    Code:
    konsole -e /path/to/script
    and you just type
    Code:
    path/to/script
    Feel free to ask when unclear.
    Henk van Velden

  6. #6
    axel_bock NNTP User

    Default Re: Konqueror & bash scripts - no terminal window

    super, thanks a lot! I will try that and if you don't hear from me again I am happy :-) .

    thanks a lot!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •