Results 1 to 3 of 3

Thread: Three monitors, two video cards - partially working

  1. #1
    Join Date
    Apr 2009
    Location
    Washington (the state)
    Posts
    53

    Question Three monitors, two video cards - partially working

    For the past several months, I have been using a dual monitor setup with a single dual-output nvidia video card. I recently aquired a third monitor that matches the second. In hopes of running a triple monitor setup, I got a second video card (also nvidia) and have installed it in my computer as well. The current hardware setup is the original card (GeForce 8800GT located in PCI express 16x slot one) drives my main (center) monitor. The second card (GeForce 8400GS located in PCI express 16x slot two) drives my other two monitors (left and right). I started the configuration with sax2, getting a single monitor setup to allow me to get into kde and access the nvidia-settings utility. From there, I used the nvidia-settings utility to configure my xorg.conf the rest of the way. This has gotten me to my present situation, which is the center monitor working fine, while both left and right monitors have 'blank' x screens (black with white X as cursor indicator). I have done quite a bit of reading around, and have not found much information regarding three monitor setups. Most say "just use the nvidia-settings utility and it's easy." I am hoping that someone has some experience with this type of configuration and can help me get this wrapped up. The setup is working fine in Windows 7, using the nvidia configuration utility there.

    I'm not entirely set on any one type of setup, be it three individual x screens, or a xinerama setup across all three. I was leaning towards the individual x screens though. It seems to be pretty close, I just can't seem to figure out what is missing or wrong. I would appreciate any help anyone can provide.

    Here is the info from lspci, as well as my xorg.conf:
    Code:
    00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a2)
    00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a3)
    00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a3)
    00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1)
    00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2)
    00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1)
    00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a3)
    00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a3)
    00:05.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a3)
    00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2)
    00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
    00:08.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a3)
    00:0a.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a3)
    00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a3)
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    01:08.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
    01:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
    02:00.0 VGA compatible controller: nVidia Corporation GeForce 8400 GS (rev a1)
    03:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (abuild@pmbs)  Sun May  3 17:04:37 UTC 2009
    
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-07-31T06:56:20-0700.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen      0  "Screen0" 1280 0
        Screen      1  "Screen1" LeftOf "Screen0"
        Screen      2  "Screen2" RightOf "Screen0"
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
        Option         "Clone" "off"
        Option         "Xinerama" "off"
    EndSection
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        FontPath        "/usr/share/fonts/misc:unscaled"
        FontPath        "/usr/share/fonts/local"
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/Type1"
        FontPath        "/usr/share/fonts/URW"
        FontPath        "/usr/share/fonts/Speedo"
        FontPath        "/usr/share/fonts/PEX"
        FontPath        "/usr/share/fonts/cyrillic"
        FontPath        "/usr/share/fonts/latin2/misc:unscaled"
        FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/Type1"
        FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath        "/usr/share/fonts/baekmuk:unscaled"
        FontPath        "/usr/share/fonts/japanese:unscaled"
        FontPath        "/usr/share/fonts/kwintv"
        FontPath        "/usr/share/fonts/truetype"
        FontPath        "/usr/share/fonts/uni:unscaled"
        FontPath        "/usr/share/fonts/CID"
        FontPath        "/usr/share/fonts/ucs/misc:unscaled"
        FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/misc:unscaled"
        FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/Type1"
        FontPath        "/usr/share/fonts/misc/sgi:unscaled"
        FontPath        "/usr/share/fonts/xtest"
        FontPath        "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
        Load           "dri"
        Load           "dbe"
        Load           "freetype"
        Load           "extmod"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
    
    # Removed Option "Xinerama" "0"
    # Removed Option "Xinerama" "1"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard[0]"
        Driver         "evdev"
        Option         "Pass" "3"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"
        Option         "XkbModel" "microsoftnek4k"
        Option         "XkbRules" "xfree86"
        Option         "evBits" "+1"
        Option         "keyBits" "~1-255 ~352-511"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "mouse"
        Option         "Buttons" "12"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "Logitech USB Gaming Mouse"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
        Identifier         "Modes[0]"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Gateway HD2201"
        HorizSync       24.0 - 83.0
        VertRefresh     48.0 - 76.0
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "DELL E173FP"
        HorizSync       31.0 - 80.0
        VertRefresh     56.0 - 75.0
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor2"
        VendorName     "Unknown"
        ModelName      "DELL E173FP"
        HorizSync       31.0 - 80.0
        VertRefresh     56.0 - 75.0
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 GT"
        BusID          "PCI:3:0:0"
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8400 GS"
        BusID          "PCI:2:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device2"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8400 GS"
        BusID          "PCI:2:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "1680x1050 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "nvidia-auto-select +0+0"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "CRT-0: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "nvidia-auto-select +0+0"
        Identifier     "Screen2"
        Device         "Device2"
        Monitor        "Monitor2"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "CRT-1: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "on"
    EndSection
    Thanks for taking the time to help me out.

  2. #2
    Join Date
    Apr 2009
    Location
    Washington (the state)
    Posts
    53

    Default Re: Three monitors, two video cards - partially working

    I just remembered that I had previously installed gnome, and signed into it to test the configuration there and it worked fine. This must be a kde problem instead, which means it is posted in the wrong place now. If a moderator could delete it, I would appreciate it. If I am unable to get it working properly with this new info, I will create a new post with the relevant info in the appropriate forum. My apologies for the trouble.

  3. #3
    Join Date
    Apr 2009
    Location
    Washington (the state)
    Posts
    53

    Default Re: Three monitors, two video cards - partially working

    Got this resolved, thought I would update it in case it might help anyone else. Apparently the only way to make this work with kde is to enable xinerama. Pretty sure I tried that unsuccessfully through the nvidia-settings utiltity, but I manually changed it in xorg.conf and now have the display on all three monitors.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •