Results 1 to 4 of 4

Thread: On-Board sound issue (kernel updated)

  1. #1

    Default On-Board sound issue (kernel updated)

    Please I cold use some advice. I have this listing for my sound device from lspci -v

    Audio device: nVidia Corporation MCP65 High Definition Audio (rev a1)
    Subsystem: Giga-byte Technology Device a002
    Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
    Memory at f8000000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: [44] Power Management version 2
    Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Count=1/1 Enable-
    Capabilities: [6c] HyperTransport: MSI Mapping Enable+ Fixed+
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel
    Using kde4.2
    Linux 2.6.27.25-0.1-default x86_64
    AMD Athlon(tm) 7750

    On start up I get the error and falling back to pulse audio, but no sound. If I go to Yast- Hardware- Sound
    As it loads - the sound comes to life

    Any help much appreciated. Thanks

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: On-Board sound issue (kernel updated)

    Quote Originally Posted by bslboden View Post
    On start up I get the error and falling back to pulse audio, but no sound.
    I think thats a bug - with minimal to no impact on sound. ... and I believe a number of users have reported this. There are a more than a fewthreads here, where users have posted solutions that worked for them: I think I've seen other "solutions" as well, but a quick search did not reveal it (I probably had the wrong search parameters).

    Quote Originally Posted by bslboden View Post
    If I go to Yast- Hardware- Sound
    As it loads - the sound comes to life
    Other than the start up sound not playing, what is your criteria for determining there is no sound?

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Try those speaker-tests as both a regular user, and with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    After a restart and before going to YaST, do any of those give sound?

  3. #3

    Default Re: On-Board sound issue (kernel updated)

    Thanks oldcpu.
    It seems you were correct. I actually found that since the update kmix was starting muted after reboot (I didn't have mute on when trying the sound!) But also the channel had been switched from Master to PCM. I switched it back to Master and I'm good.

    Strange but not too serious. I suspect the sound s not all the on-board promises to be but it actually doesn't sound bad.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: On-Board sound issue (kernel updated)

    Quote Originally Posted by bslboden View Post
    I actually found that since the update kmix was starting muted after reboot (I didn't have mute on when trying the sound!) But also the channel had been switched from Master to PCM. I switched it back to Master and I'm good.
    A number of us are seeing the volume muted upon boot. I've also observed that behaviour in 11.2 milestone4. I suspect this will be a source of irritation for open SuSE users for a while, until the reason can be found.

    Glad to read your sound is working without having to go to YaST.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •