Results 1 to 5 of 5

Thread: boot-problem after changing default-start-partion with yast

  1. #1
    hedemaut NNTP User

    Default boot-problem after changing default-start-partion with yast

    I have opensuse 11.1 and 2x windows XP on my laptop.
    Everyhing worked fine until I changed the bootloader setting with yast. Now I can't boot ANY OS from my HD.

    I had 3 entries for
    - openSUSE 11.1
    - Failsafe
    - Windows (when selected, I can choose between the 2 win-xp-partitions)
    in my grub start menu

    The default option was openSUSE 11.1, but I wanted to change it to windows. After the change with yast, I only get
    "Error No operating system"
    Intel(R) Boot Agent Version.....
    and no grub menu at all.

    I tried the rescue option with a open suse dvd and could manually mount my boot-Partition /dev/sda6 to /mnt. Then I restored the /mnt/boot/grub/menu.lst.old and /mnt/boot/grub/device.map.old to restore the original settings.
    yast has changed the entry in menu.lst from "default 0" to "default 2". I didn't find a /etc/grub.conf
    The reboot. But the same problem.

    Output of fdisk -l:
    ##############################################
    Disk /dev/sda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x1b3f1b3e

    Device Boot Start End Blocks Id System
    /dev/sda1 1 7834 62918572 7 HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 * 7834 19457 93366000 f W95 Ext'd (LBA)
    Partition 2 does not end on cylinder boundary.
    /dev/sda5 7834 15145 58725607 7 HPFS/NTFS
    /dev/sda6 15145 15154 68954 83 Linux
    /dev/sda7 15154 19455 34555783+ 8e Linux LVM
    ##############################################

    Is it correct, that partition /dev/sda2 is marked as boot-Partition in fdisk? The linux-boot-partition should be /dev/sda6.

    menu.lst (the old one, but yast only changed default)
    ##################################################
    # Modified by YaST2. Last modification on Fri Jun 26 12:03:04 UTC 2009
    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,5)/message
    ##YaST - activate

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.1 - 2.6.27.7-9
    root (hd0,5)
    kernel /vmlinuz-2.6.27.7-9-pae root=/dev/system/root resume=/dev/system/swap splash=silent showopts vga=0x314
    initrd /initrd-2.6.27.7-9-pae

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.1 - 2.6.27.7-9
    root (hd0,5)
    kernel /vmlinuz-2.6.27.7-9-pae root=/dev/system/root showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x314
    initrd /initrd-2.6.27.7-9-pae

    ###Don't change this comment - YaST2 identifier: Original name: windows###
    title Windows
    rootnoverify (hd0,0)
    chainloader +1
    #############################

    Any ideas, what went wrong and how I could correct it ?
    Kind regards,
    Uta

  2. #2
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: boot-problem after changing default-start-partion with y

    Since you know it's a grub problem, use the opensuse disk and choose the rescue option. Now choose the custom option and reinstall grub.
    Once installed, reboot and go to yast2>system>boot and choose the propose new configuration option. Once it has come up with the new layout, highlight th windows otion and set it as the default. (Strange why though, I only use window when I have to!)

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,728

    Default Re: boot-problem after changing default-start-partion with y

    Quote Originally Posted by hedemaut View Post
    Is it correct, that partition /dev/sda2 is marked as boot-Partition in fdisk? The linux-boot-partition should be /dev/sda6.
    I am with you. It is strange that the Extended partition has the boot flag. IMO in your setup it should be sda1.

    Now as you do not have information on how everything looked like before you changed things, it is a bit difficult to explain what went wrong and when.

    Using what whych says, see that GRUB is on the MBR and check that sda1 is used.
    Henk van Velden

  4. #4
    hedemaut NNTP User

    Default Re: boot-problem after changing default-start-partion with y

    My system is up and running again. Here is what I did:

    Tried repair menu, but problems
    Code:
    error "could not detect any valid root partition"
    probably because my root partition is inside LVM

    I tried like sugested, to rewrite the GRUB into MBR with SUSE DVD and graphical menu (expert tools).
    1. problem was:
    Suggested Menu was without WINDOWS (only entries for linux and failsafe linux), so I selected
    Code:
     reread configuration from disk
    WINDOWS was then in menu and I choose
    Code:
     write bootloader to disk
    and pressed OK
    According to message "The boot loader was installed sucessfully" everything looked fine. But after reboot same error message " Error No Operating system" and no grub...

    Next trial with help of SDB:The Boot Manager Grub - openSUSE:

    Code:
     Started from DVD
    Rescue System
    
    procedure to rewrite grub:
    grub
    grub> root (hd0,5) (sd6 is linux boot partition)
    grub> setup (hd0) 
    grub> quit
    
    then I rebooted
    and WOW- my grub menu !!!!
    Everything fine!!!

    Next Step:
    I changed default-entry in /boot/grub/menu.lst to have windows as default selection (default 0 -> default 2).
    then the same procedure from above for rewriting grub.
    Now I'm happy again, but I don't really trust the graphical interface any more.....

    BTW: fdisk -l shows the same as before.
    /dev/sda2 is marked for "Boot" in fdisk -l.
    But as everything works fine now, I don't care....

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,728

    Default Re: boot-problem after changing default-start-partion with y

    Nice it works. Thanks for the follow up.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •