Results 1 to 3 of 3

Thread: xen kernel 2.6.27.25-0.1 doesn't unstand vga parameter?

  1. #1
    psfan NNTP User

    Default xen kernel 2.6.27.25-0.1 doesn't unstand vga parameter?

    I'm using openSUSE 11.1, I just upgraded kernel from 2.6.27.7-9 to 2.6.27.25-0.1. I found that the new kernel of xen version failed to understand vga parameter which does not happen to the former one.

    Part of my menu.lst for 2.6.27.25-0.1-xen

    title Xen -- openSUSE 11.1 - 2.6.27.25-0.1
    root (hd0,0)
    kernel /boot/xen.gz vga=0x314
    module /boot/vmlinuz-2.6.27.25-0.1-xen root=/dev/sda1 resume=/dev/sda2 splash=silent showopts
    module /boot/initrd-2.6.27.25-0.1-xen

    While booting, the screen stopped and asked me to press <ENTER> key for a choice of vga mode. And I found I can select mode 0314 (800X600X16) by typing 'd'.

    The former version 2.6.27.7-9-xen did not have this problem. Is there a work around solution ?

  2. #2
    Join Date
    Jul 2008
    Location
    SPAIN
    Posts
    132

    Default Re: xen kernel 2.6.27.25-0.1 doesn't unstand vga parameter?

    Hi,

    I think you should add the vga parameter to the line corresponding to the OS kernel running on the administrative domain instead of the xen hypervisor:

    title Xen -- openSUSE 11.1 - 2.6.27.25-0.1
    root (hd0,0)
    kernel /boot/xen.gz
    module /boot/vmlinuz-2.6.27.25-0.1-xen root=/dev/sda1 resume=/dev/sda2 splash=silent showopts vga=0x314
    module /boot/initrd-2.6.27.25-0.1-xen

    That makes sense, since once you are booted in Xen mode, you are working within the scope of the dom0 OS, not the xen hypervisor itself.

    Is that what you meant?

    Regards.

  3. #3

    Default Re: xen kernel 2.6.27.25-0.1 doesn't unstand vga parameter?

    Try

    kernel /boot/xen.gz vga=mode-0x314

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •