Results 1 to 7 of 7

Thread: Compaq CQ40-304TU Drivers for OpenSUSE10.3

  1. #1
    Join Date
    Aug 2009
    Location
    Pointe Noire
    Posts
    59

    Question Compaq CQ40-304TU Drivers for OpenSUSE10.3

    Hi,

    (I have posted this request before in Laptop forum, he suggested me to post it again here so that my internet can work below is the link to that post)

    Compaq CQ40-304TU Drivers for OpenSUSE10.3 - openSUSE Forums

    I lately Installed OpenSUSE 10.3

    My wireless isn't recognized; it's Broadcom.

    My Ethernet card is recognized.. I Configured it on DHCP but when i connect a cable, it doesnt give any IP address, plus when i connect a cable running vista, the lamp start blinking in Ethernet card but when i connect it in linux, it doesn't blink at all.

    Just for the info, i have a dual boot.. Vista and Suse.

    I am not even sure if my other drivers are isntalled.

    System Information

    - Intel Pentium Dual-Core Processor T3400 (2.16GHz. , 667MHz. , 1MB L2)
    - 250GB 5400rpm (Serial ATA)
    - 4 GB Ram
    - Intel Graphics Media Accelerator 4500MHD
    - Broadcom Wireless LAN
    - Realtek Fast Ethernet NIC Driver
    - JMB38X Card Reader
    - ALPS Touchpad
    - IDT High-Definition Audio CODEC

    Can anyone help me out.

  2. #2
    Camalen NNTP User

    Default Re: Compaq CQ40-304TU Drivers for OpenSUSE10.3

    shiraz tharani wrote:

    > I lately Installed OpenSUSE 10.3
    >
    > My wireless isn't recognized; it's Broadcom.


    There are several articles in opensuse wiki that may help you with your
    wireless adapter:

    http://en.opensuse.org/Wireless_network_card
    http://en.opensuse.org/Category:Wireless

    > My Ethernet card is recognized.. I Configured it on DHCP but when i
    > connect a cable, it doesnt give any IP address, plus when i connect a
    > cable running vista, the lamp start blinking in Ethernet card but when i
    > connect it in linux, it doesn't blink at all.


    From konsole/xterm/gnome terminal, being root, run "rcnetwork status;
    ifconfig" and put here the result.

    Greetings,

    --
    Camalen

  3. #3
    Join Date
    Aug 2009
    Location
    Pointe Noire
    Posts
    59

    Default Re: Compaq CQ40-304TU Drivers for OpenSUSE10.3

    Hi,

    Just for the info which i missed to mention earlier..

    I Have KDE.
    Please find the outcome below:

    shiraz@Shiraz-Laptop:~> rcnetwork status
    bash: rcnetwork: command not found
    shiraz@Shiraz-Laptop:~> su
    Password:
    Shiraz-Laptop:/home/shiraz # rcnetwork status
    Checking for the NetworkManager: running
    Checking for the NetworkManagerDispatcher: running
    Checking for the DHCP DBUS Daemon: running
    Shiraz-Laptop:/home/shiraz # ifconfig
    eth0 Link encap:Ethernet HWaddr 00:23:5A:22:3B3
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:4040182007 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:19 Base address:0xc000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:32 errors:0 dropped:0 overruns:0 frame:0
    TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2056 (2.0 Kb) TX bytes:2056 (2.0 Kb)

  4. #4
    Join Date
    Aug 2009
    Location
    Pointe Noire
    Posts
    59

    Default Re: Compaq CQ40-304TU Drivers for OpenSUSE10.3

    Shiraz-Laptop:/home/shiraz # ifconfig
    eth0 Link encap:Ethernet HWaddr 00:23:5A:22:3B:D3
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:4040182007 overruns:0 frame:0

  5. #5
    Camalen NNTP User

    Default Re: Compaq CQ40-304TU Drivers for OpenSUSE10.3

    shiraz tharani wrote:

    > Please find the outcome below:
    >
    > shiraz@Shiraz-Laptop:~> rcnetwork status
    > bash: rcnetwork: command not found
    > shiraz@Shiraz-Laptop:~> su
    > Password:
    > Shiraz-Laptop:/home/shiraz # rcnetwork status
    > Checking for the NetworkManager:
    > running
    > Checking for the NetworkManagerDispatcher:
    > running
    > Checking for the DHCP DBUS Daemon:
    > running


    Are you using "NetworkManager" instead "traditional method (ifup)"?

    If yes, try to setup the network adapter with "traditional method (ifup)"
    and run the above commands again. This can be done in YaST.

    > Shiraz-Laptop:/home/shiraz # ifconfig
    > eth0 Link encap:Ethernet HWaddr 00:23:5A:22:3B3
    > UP BROADCAST MULTICAST MTU:1500 Metric:1
    > RX packets:0 errors:0 dropped:4040182007 overruns:0 frame:0
    > TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:1000
    > RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    > Interrupt:19 Base address:0xc000
    >
    > lo Link encap:Local Loopback
    > inet addr:127.0.0.1 Mask:255.0.0.0
    > inet6 addr: ::1/128 Scope:Host
    > UP LOOPBACK RUNNING MTU:16436 Metric:1
    > RX packets:32 errors:0 dropped:0 overruns:0 frame:0
    > TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
    > collisions:0 txqueuelen:0
    > RX bytes:2056 (2.0 Kb) TX bytes:2056 (2.0 Kb)


    You are not getting an IP address from your dhcp server and this can be due
    to several causes. Let's first discard any configuration error on the suse
    side.

    Greetings,

    --
    Camalen

  6. #6
    Join Date
    Aug 2009
    Location
    Pointe Noire
    Posts
    59

    Talking Re: Compaq CQ40-304TU Drivers for OpenSUSE10.3

    Hi,

    I did what you asked me to do, and internet start working even i switched back to KnetworkManager, it's still working

    But i realized my internet is quite slow as compare to vista, Any idea why?

    Thanks for the help. i will try to make my wireless work.

    Thanks once again.

  7. #7
    Camalen NNTP User

    Default Re: Compaq CQ40-304TU Drivers for OpenSUSE10.3

    shiraz tharani wrote:

    > I did what you asked me to do, and internet start working even i
    > switched back to KnetworkManager, it's still working


    Oops, well, that should be fine then O:-)

    > But i realized my internet is quite slow as compare to vista, Any idea
    > why?


    Yes. Probably because of ipv6 is enabled by default and this is known to
    cause some glitches as most ISP and servers have not migrated to ipv6.

    Try first to disable ipv6 at browser level. If using firefox, here is a
    how-to, it's very easy:

    http://en.opensuse.org/Disable_IPv6_for_Firefox

    > Thanks for the help. i will try to make my wireless work.


    Take a look into the wireless subforum. It is plenty of broadcom wireless
    problems and solutions.

    http://forums.opensuse.org/network-internet/wireless/

    > Thanks once again.


    You're welcome :-)

    Greetings,

    --
    Camalen

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •