Results 1 to 5 of 5

Thread: Forcing AGPv3 4x mode with fglrx in openSUSE 11.1

  1. #1

    Default Forcing AGPv3 4x mode with fglrx in openSUSE 11.1

    Dear forum,

    I'm experiencing an old illness:

    I know for some time now that my combination of motherboard chipset (Intel 875P, MSI board) and graphics accelerator (ATI Radeon 9600 Pro, HIS) is incapable of running in 8x AGP mode.

    Everything is fine as long as I don't start anything using 3D acceleration. The system freezes after some seconds later, regardless of the OS in use.

    I had been using SuSE and Gentoo for years now, with some self-patched agpgart module, to force 4x AGP mode.

    Now, having migrated to openSUSE 11.1, I'm experiencing the same problem... the (auto) 8x AGP mode leads to system lock-ups.

    I've tried the
    Code:
    Option "AGPMode" "4"
    which (by the log) is not supported, and I've tried the
    Code:
    Option "AGPv3Mask" "0x00000002"
    , which seems to be ignored silently.

    Here's the xorg.conf snippet in question:
    Code:
    Section "Device"
      Identifier   "Device[0]"
      Driver       "fglrx"
      VendorName   "ATI"
      BoardName    "ATI RADEON 9600 Series (RV350/RV360 4150)"
      Option       "Capabilities" "0x00000000"
      Option       "AGPv3Mask" "0x00000002"
      Option       "VideoOverlay" "on"
      Option       "OpenGLOverlay" "off"
      Option       "XAANoOffscreenPixmaps" "true"
      Option      "BlockSignalsOnLock" "on"
      Option      "UseFastTLS" "2"
      Option      "UseInternalAGPGART" "no"
      Option      "mtrr" "on"
    EndSection
    And dmesg proudly states:
    Code:
    [fglrx] It's not necessary to adjust system aperture on this ASIC
    [fglrx] AGP detected, AgpState   = 0x1f004a1b (hardware caps of chipset)
    [fglrx] [agp] enabling AGP with mode=0x1f004b1a
    agpgart-intel 0000:00:00.0: AGP 3.0 bridge
    agpgart-intel 0000:00:00.0: putting AGP V3 device into 8x mode
    fglrx_pci 0000:01:00.0: putting AGP V3 device into 8x mode
    [fglrx] AGP enabled,  AgpCommand = 0x1f004312 (selected caps)
    [fglrx] Setup AGP aperture
    [fglrx] GART Table is not in FRAME_BUFFER range
    [fglrx] Firegl kernel thread PID: 20472
    [fglrx] Reserved FB block: Shared offset:0, size:40000
    Now, I'm not very keen having to patch my kernel again, since I have to redo it every time there's a kernel update.

    I've checked the agpgart module for any useful parameters, but haven't found any.

    Has anyone got any hints or clues how to force 4x AGP mode?

    Thanks in advance
    Ben

  2. #2

    Default Re: Forcing AGPv3 4x mode with fglrx in openSUSE 11.1

    might read this for some info, thou i believe it is outdated for newer drivers:

    [HOWTO] Disabling Fast Writes - Rage3D Discussion Area

    as a suggestion, if you are currently using any of the catalyst 9.X drivers, i'd roll back to 8.11 or 8.12. Catalyst 9.7 is close to working on a agp 3850 i have, but the 8.12 driver is more stable. I used the 8.11 driver until the last kernel upgrade and apparently it didn't support the newer kernel and would not install.

  3. #3
    Camalen NNTP User

    Default Re: Forcing AGPv3 4x mode with fglrx in openSUSE 11.1

    benwarbln wrote:

    > I know for some time now that my combination of motherboard chipset
    > (Intel 875P, MSI board) and graphics accelerator (ATI Radeon 9600 Pro,
    > HIS) is incapable of running in 8x AGP mode.
    >
    > Everything is fine as long as I don't start anything using 3D
    > acceleration. The system freezes after some seconds later, regardless of
    > the OS in use.
    >
    > I had been using SuSE and Gentoo for years now, with some self-patched
    > agpgart module, to force 4x AGP mode.
    >
    > Now, having migrated to openSUSE 11.1, I'm experiencing the same
    > problem... the (auto) 8x AGP mode leads to system lock-ups.


    Just a shoot in the dark, but... have you tried to force AGP port to x4 by
    setting this in BIOS? :-?

    (...)

    > Now, I'm not very keen having to patch my kernel again, since I have to
    > redo it every time there's a kernel update.
    >
    > I've checked the agpgart module for any useful parameters, but haven't
    > found any.
    >
    > Has anyone got any hints or clues how to force 4x AGP mode?


    How about using "radeon" driver?

    Greetings,

    --
    Camalen

  4. #4
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Forcing AGPv3 4x mode with fglrx in openSUSE 11.1

    Camaleón adjusted his/her AFDB on Sunday 02 Aug 2009 19:42 to write:

    > benwarbln wrote:
    >
    >> I know for some time now that my combination of motherboard chipset
    >> (Intel 875P, MSI board) and graphics accelerator (ATI Radeon 9600 Pro,
    >> HIS) is incapable of running in 8x AGP mode.
    >>
    >> Everything is fine as long as I don't start anything using 3D
    >> acceleration. The system freezes after some seconds later, regardless of
    >> the OS in use.
    >>
    >> I had been using SuSE and Gentoo for years now, with some self-patched
    >> agpgart module, to force 4x AGP mode.
    >>
    >> Now, having migrated to openSUSE 11.1, I'm experiencing the same
    >> problem... the (auto) 8x AGP mode leads to system lock-ups.

    >
    > Just a shoot in the dark, but... have you tried to force AGP port to x4 by
    > setting this in BIOS? :-?
    >




    Also while in the bios there should be a setting where you can disable
    fastwrites try that as well if it is there.

    HTH

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  5. #5

    Default Re: Forcing AGPv3 4x mode with fglrx in openSUSE 11.1

    Thanks for you replies.

    Unfortunately, my BIOS does not support setting any AGP options, except aperture size (I was seriously disappointed when I found out some years ago...).

    The solution for Windoze was to set 4x mode using Catalyst control center.

    But for all what I've seen/read/tried so far, I can't convince agpgart to run in 4x mode...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •