Results 1 to 7 of 7

Thread: Cheese stopped after gstreamer codec pack

  1. #1
    AVLizard NNTP User

    Default Cheese stopped after gstreamer codec pack

    I have a Dell M1330 and just switched to openSUSE after a couple years with Ubuntu. What a difference in setup. Everything worked from the first boot. However, after I ran codecs-gnome.ymp Since then Cheese just gives me the color bars. I tried gstreamer-properties but none of the options there helped. Thank for the help!

  2. #2
    AVLizard NNTP User

    Default Cheese stopped after gstreamer codec pack

    I have a Dell M1330 and just switched to openSUSE after a couple years with Ubuntu. What a difference in setup. Everything worked from the first boot. However, after I ran codecs-gnome.ymp Since then Cheese just gives me the color bars. I tried gstreamer-properties and this is what it spit:

    (gstreamer-properties:11289): GStreamer-WARNING **: Failed to load plugin '/usr/lib64/gstreamer-0.10/libgstcacasink.so': /usr/lib64/gstreamer-0.10/libgstcacasink.so: undefined symbol: caca_dither_bitmap
    gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
    gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
    gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
    gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
    gstreamer-properties-Message: Skipping unavailable plugin 'v4l2src'
    gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
    gstreamer-properties-Message: Error running pipeline 'Video for Linux (v4l)': Could not get/set settings from/on resource. [v4l_calls.c(418): gst_v4l_set_chan_norm (): /GstPipelineipeline6/GstV4lSrc:v4lsrc2:
    Error setting the channel/norm settings: Invalid argument]
    gstreamer-properties-Message: Error running pipeline 'Custom': Could not get/set settings from/on resource. [v4l_calls.c(418): gst_v4l_set_chan_norm (): /GstPipelineipeline7/GstV4lSrc:v4lsrc3:
    Error setting the channel/norm settings: Invalid argument]


    Thanks for the Help!

  3. #3

    Default Re: Cheese stopped after gstreamer codec pack

    Most likely this is caused by mixing gstreamer packages form the OSS repo and the packman repo. I've had this problem crop up every time I've mixed. The weird thing is that if I use the packman repo I can use gstreamer as a phonon backend to play video, but not the webcam in cheese. With the OSS repo I can use my webcam in cheese, but not gstreamer as a phonon backend to play video. Hopefully this can help you with your problem until somebody more knowledgeable comes along with a proper solution to both your problem and mine.

  4. #4

    Thumbs down Re: Cheese stopped after gstreamer codec pack

    Ok. Before someone thinks that i am the knowledgeable one (@nordlibris);-) let me tell you that i am not but that i have the exact same problem.
    > I installed all my gstreamers with OSS repo first then upgraded to the packman ones
    > Video & audio play fine
    > aMSN has no issues with webcam
    > But Skype has a green lined block and cheese has snow and color patterns. Edit - preferences on cheese has /dev/video0 (which is correct) but resolution field is blank
    > I have used Fedora 11 and gstreamer from rpmfusion repo never gave me a problem with cheese or skype

    Some direction now:: Refer to my post Unable to locate buildservices-drivers in webcam repo ! - openSUSE Forums. Check if "buildservices-drivers" package is there in your webcam repo and try installing it. I may be wrong because no one from the forum has validated that yet; but just wanted to know if you guys can get this resolved with that package.

    Else, is it a bug then?

    My experience with OS11.1 multimedia is gradually reaching frustrating limits !

  5. #5

    Default Re: Cheese stopped after gstreamer codec pack

    Quote Originally Posted by AVLizard View Post
    /usr/lib64/gstreamer-0.10/libgstcacasink.so: undefined symbol: caca_dither_bitmap
    Search that in Google and you will end at GStreamer Error - openSUSE Forums

    ...update caca.

  6. #6

    Default Re: Cheese stopped after gstreamer codec pack

    Try my conclusion at Unable to locate buildservices-drivers in webcam repo ! - openSUSE Forums

    I think it is going to work for you.

  7. #7
    AVLizard NNTP User

    Default Re: Cheese stopped after gstreamer codec pack

    updated libv4l,caca and gstreamer to no avail. ld_preloads didn't seem to help either. its weird that the webcam works great in skype but not cheese. any more ideas? thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •