Results 1 to 7 of 7

Thread: KDE will not start automatically

  1. #1

    Default KDE will not start automatically

    Hi,
    my System:
    motherboard: Asus M3N78-VM
    graphiccard: Asus EAH4650/DI
    CPU : AMD Athlon-64 X2 6000+
    memory : 6 GB
    system: : SuSe 11.1 with KDE 4.2

    my Problem: if I start the system the Loginscreen appears, but after entering the password, there is only a textconsole. I must type: startx -- :1 if I would use KDE. Has everyone the same Problem?

    greetings
    wolfgang

  2. #2
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: KDE will not start automatically

    Does KDE actually start when you type startx?
    Do you get any error in your startup log when you type in the following?
    Code:
    dmesg
    Try doing a graphics setup to use the vesa drivers?

    Code:
    sax2 -r -m 0=vesa
    See if any of that helps. Mine starts up fine but I'm no guru
    "To err is human... to really foul up requires the root password."

  3. #3

    Default Re: KDE will not start automatically

    thanks, but sorry, it doesn't work.
    and with dmesg I've not seen any error.
    with "startx -- :1" all is ok, I've have then the KDE Desktop
    greetings
    Wolfgang

  4. #4
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: KDE will not start automatically

    When you see the grub menu try typing in
    Code:
    5
    It will appear in the options line. That should start runlevel 5 and give you a KDE desktop.
    Do a sax2 setup when you're in and save it. Then restart. Might work that way.
    "To err is human... to really foul up requires the root password."

  5. #5
    Camalen NNTP User

    Default Re: KDE will not start automatically

    wope wrote:

    > thanks, but sorry, it doesn't work.
    > and with dmesg I've not seen any error.
    > with "startx -- :1" all is ok, I've have then the KDE Desktop


    Check "xdm" service is enabled (5n) to start at booting up.

    Open konsole and as root, run:

    ***
    stthpc:~ # chkconfig -l xdm
    xdm 0ff 1ff 2ff 3ff 4ff 5n 6ff
    ***

    Greetings,

    --
    Camalen

  6. #6
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: KDE will not start automatically

    Found this when I went looking for a cause for your problem. It was looking to me like OpenSUSE was running fine and the problem could be with KDE. I went looking in the KDE forums and found this.

    Problem 1 sounds like the one you have so give the reply a try.

    If you are using autologin, you need to disable it. Edit /etc/sysconfig/displaymanager as root, and remove your user from the DISPLAYMANAGER_AUTOLOGIN parameter. Restart kde and all should be well.
    "To err is human... to really foul up requires the root password."

  7. #7
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE will not start automatically

    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •