Results 1 to 5 of 5

Thread: Color scheme problems

  1. #1

    Default Color scheme problems

    I have two problems related to color scheme.

    First, is there any way to prevent web browsers from using the system's default colors? I use a dark scheme, specifically Obsidian Coast in KDE and Industrial in GTK. This doesn't behave well on web pages in Firefox, Arora, and Konqueror. (Opera is fine.) Sometimes a site's stylesheet will specify a text field's text color to be black, but its background is not specified, so it defaults to black-on-dark-gray. I've also seen such a field's background color specified as white while the text color was not, so it ended up being light-gray-on-white. Is there any way to keep browsers from ruining web pages? Also, even if the stylesheet doesn't specify the colors, the dark text fields and buttons still stick out like a sore thumb on a warm or bright page.

    My second problem is this: I have a saved session that brings up my applications every time I log in, but the GTK apps Pidgin and Evolution don't match the GTK color scheme until I quit and start them up again. Is there some way of fixing or working around this problem?

  2. #2
    Camalen NNTP User

    Default Re: Color scheme problems

    YAOMTC wrote:

    > I have two problems related to color scheme.
    >
    > First, is there any way to prevent web browsers from using the system's
    > default colors? I use a dark scheme, specifically Obsidian Coast in KDE
    > and Industrial in GTK. This doesn't behave well on web pages in Firefox,
    > Arora, and Konqueror. Sometimes a site's stylesheet will specify a text
    > field's text color to be black, but its background is not specified, so
    > it defaults to black-on-dark-gray. I've also seen such a field's
    > background color specified as white while the text color was not, so it
    > ended up being light-gray-on-white. Is there any way to keep browsers
    > from ruining web pages? Also, even if the stylesheet doesn't specify the
    > colors, the dark text fields and buttons still stick out like a sore
    > thumb on a warm or bright page.


    Firefox and konqueror both have an option to prevent websites using their
    colors. But I dunno the scope of that setting, maybe only affects to html
    pure code (font face) and have no effect if style is defined with css or by
    means of javascript.

    Firefox 3.5.1 -> edit / preferences / content / colors / [ ] Allow pages to
    choose their own colors, instead of my selections above should be disable.

    Konqueror 3.5.9 -> you can select a custom CSS style to apply all webpages.
    This can be done under konqueror's configuration.

    > My second problem is this: I have a saved session that brings up my
    > applications every time I log in, but the GTK apps Pidgin and Evolution
    > don't match the GTK color scheme until I quit and start them up again.
    > Is there some way of fixing or working around this problem?


    That sounds like an error, as any gtk app should honor your global settings.
    Take a look into the gnome conf editor and look for any evolution or pidgin
    option able to manage this :-?

    Greetings,

    --
    Camalen

  3. #3

    Default Re: Color scheme problems

    I am experiencing the same problem regarding te4xt field background color defaulting in the browser. Have you found an answer anyplace? Or is someone else reading this thread that has an answer?

    Thank you

    Quote Originally Posted by YAOMTC View Post
    I have two problems related to color scheme.

    First, is there any way to prevent web browsers from using the system's default colors? I use a dark scheme, specifically Obsidian Coast in KDE and Industrial in GTK. This doesn't behave well on web pages in Firefox, Arora, and Konqueror. (Opera is fine.) Sometimes a site's stylesheet will specify a text field's text color to be black, but its background is not specified, so it defaults to black-on-dark-gray. I've also seen such a field's background color specified as white while the text color was not, so it ended up being light-gray-on-white. Is there any way to keep browsers from ruining web pages? Also, even if the stylesheet doesn't specify the colors, the dark text fields and buttons still stick out like a sore thumb on a warm or bright page.

  4. #4
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Default Re: Color scheme problems

    Quote Originally Posted by YAOMTC View Post
    I have two problems related to color scheme.

    First, is there any way to prevent web browsers from using the system's default colors? I use a dark scheme, specifically Obsidian Coast in KDE and Industrial in GTK. This doesn't behave well on web pages in Firefox, Arora, and Konqueror. (Opera is fine.) Sometimes a site's stylesheet will specify a text field's text color to be black, but its background is not specified, so it defaults to black-on-dark-gray. I've also seen such a field's background color specified as white while the text color was not, so it ended up being light-gray-on-white. Is there any way to keep browsers from ruining web pages? Also, even if the stylesheet doesn't specify the colors, the dark text fields and buttons still stick out like a sore thumb on a warm or bright page.

    My second problem is this: I have a saved session that brings up my applications every time I log in, but the GTK apps Pidgin and Evolution don't match the GTK color scheme until I quit and start them up again. Is there some way of fixing or working around this problem?
    You can change that in KDE, not sure about gtk. In KDE: StartMenu > Configure Desktop > Appearance > Colors > Options tab, and turn off "Apply colors to non-kde apps".
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  5. #5

    Default Re: Color scheme problems

    This is weird. I had similar issues with GTK apps under KDE. I posted about that, must have been two months ago. I finally solved the problem by removing qtcurve-kde4 and qtcurve-gtk2. But right now this packages are installed - as I install pretty often - and it seems to work. I would say the bug has been fixed.

    Anyway, you have to set your GTK style under System Settings > Appearance > GTK Style and Fonts. It should write the file .gtkrc-2.0-kde4 in your home directory. If the problem persists, try to remove qtcurve-kde4 and qtcurve-gtk2 if they are installed or maybe ... install them if they are missing (!?).

    The versions I have now seem to work however:

    # rpm -qa | grep qtcurve*
    qtcurve-gtk2-32bit-0.69.2-8.1.x86_64
    qtcurve-gtk2-0.69.2-8.1.x86_64
    qtcurve-kde4-0.69.0-5.1.x86_64

    http://forums.opensuse.org/applicati...ml#post2074638

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •