Results 1 to 6 of 6

Thread: Kde43rc on 11.1 - lost input and lost windows decorations

  1. #1
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Exclamation Kde43rc on 11.1 - lost input and lost windows decorations

    Since last update from factory kde43 repo I lost any

    1. input (but mouse)
    2. window decorations (title bar, system menu, close button ...)

    I was able to create a new user and to verify this for this new user also.
    But starting another window manager all works as expected even konsole,kwrite etc.

  2. #2

    Lightbulb Re: Kde43rc on 11.1 - lost input and lost windows decoration

    Your installation of kde 4.3 seems to be incomplete and is missing either kdebase4-workspace or kdebase4-runtime and related packages.
    To complete the installation, open YAST-install software, and then choose the filter - Repositories. Choose your KDE 4.3 repository, and right click on any package on the right, and choose all in the list - update if newer version available.
    Best Wishes

  3. #3
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Re: Kde43rc on 11.1 - lost input and lost windows decoration

    These packages were installed already. Even after a forced reinstall it was not better. So I changed direction: I decided to upgrade to openSUSE 11.2 factory.

    I know zypper isn't perfect in dist-upgrading therefore I deinstalled as many packages as I could. To my astonishement it also deinstalled zypper even if I had only selected graphical pattern to deinstall. (I was not able to control the long list...)

    So I started Ubuntu, then

    1. chroot to openSUSE patition
    2. wget zypper from 11.2 and rpm -i zypper
    3. changed repos to factory
    4. zypper ref
    5. zypper in zypper
    6. zypper -v dup

    Then there was not enough space for device stoudt to generate initrd of 2.6.30 kernel.
    So I restarted ubuntu and on runlevel 3 it was possible to mkinitrd in a chroot.
    And now I am at work with

    7. zypper in -t pattern kde4
    ...

  4. #4
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Re: Kde43rc on 11.1 - lost input and lost windows decoration

    I did a successfull dist-upgrade following above steps. All works again.

    But: Where to put a xrandr script to activate an extern Monitor ?

    in /etc/kde4/kdm
    does not work ...

  5. #5

    Lightbulb Re: Kde43rc on 11.1 - lost input and lost windows decoration

    try saving it here:
    /etc/X11/Xsession.d/45custom_xrandr-settings

    Xorg RandR 1.2 - ThinkWiki

  6. #6
    Join Date
    Nov 2008
    Location
    Hamburg
    Posts
    237

    Default Re: Kde43rc on 11.1 - lost input and lost windows decoration

    no that's for first login, Site:
    "To configure xrandr automatically during the first login, save this script to your computer as /etc/X11/Xsession.d/45custom_xrandr-settings"

    I want to do it before. Normally therefore is the script:
    /etc/kde4/kdm/Xsetup
    (works in Debian based distros)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •