Results 1 to 8 of 8

Thread: Losing $home priveleges after using Yast2

  1. #1

    Default Losing $home priveleges after using Yast2

    Hi evryone.

    I'm having an ongoing issue that I'm losing ownership of my home partition after using Yast2 to install or update software, or sometimes if I use Dolphin in SU mode as root.

    When updating or installing software, and after, when it says "setting up linker cache", that's taking notably a lot longer than it has historically, whether that's related too?

    When this occurs, if I log out, then in again, it's says KDE cannot start due to not having write access to my /home directory.

    When it happens, permissions on /home are root:root, so I've been logging in as root from the command line, then chown -R my directory back to me before then logging in as user then starting X.

    Any idea what's causing this?

    Thanks in advance.

  2. #2

    Default Re: Losing $home priveleges after using Yast2

    In addition, I'm using KDE4.1 and Suse 11.1.

  3. #3
    brassy NNTP User

    Default Re: Losing $home priveleges after using Yast2

    > Any idea what's causing this?

    that most often happens when your ~/.ICEauthority and/or
    ~/.Xauthority files get damaged by logging into KDE not as yourself,
    but as root...a practice which should *never* be done..

    as far as i know it is impossible to damage either of those files by
    using YaST...

    i have never seen it, but it MAY be possible to do by using Dolphin,
    but i doubt it...especially not if you are first signing into KDE as
    yourself, and then launching Dolphin from a terminal (or Alt+F2) using
    this string

    Code:
    kdesu dolphin
    is that what you have been doing?

    --
    brassy

  4. #4

    Default Re: Losing $home priveleges after using Yast2

    Thnks Brassy.

    No, if I ever use Dolphin in SU mode, I usually just launch it from the Kicker Menu 'Dolphin Super User Mode', I've never launched if from the command line, but this has definite;y happened purely by using Yast2, as I've suspected that's what it was, then carried out a test process to prove it to myself. It seems ONLY to happen if I carry out something as root with the GUI, if I run a zypper update or install from the command line, it doesn't happen.

    Regarding the X Authority file, that's interesting, because the first time I noticed this happening, was when I tried to save a document to /home and got refused because of permissions, so I tried to change the permissions as root from the command line whilst logged in X as user, and it wouldn't let me change permissions of the ICEAuthority & XAuthority files.

    Is it possible for these files to stay corrupted after a reboot? Can I delete them and remake them? Any way to edit them and fix errors or anything?

    Thanks in advance.

    Beth

  5. #5

    Default Re: Losing $home priveleges after using Yast2

    Okay, tried this morning as root at the login prompt "rm -f /home/Beth/.ICEAuthority" and also "rm -f /home/Beth/.XAuthority" and then logged into KDE normally as user, everyhitng ok.

    Uninstalled, then reinstalled Amarok from Yast2, then immediately logged out, then when I tried to log back in again, I get the error, "KDE Cannot start, no write access to /home directory, KDM Caanot Start".

    Any idea what criteria is written to the ICE and X Authority files when they're recrerated? Is this a rogue application maybe?

    Is there any way to check when, and by what application the permissions were changed? Logfiles?

    Also, in my /home directory, there is one .XAuthority filed, and then 4 other files .xauthgg71jc .xauthDWzV5A .xauth30AKdo .xauth1IBCop, are they related to .xauthority do you know?

    Thanks in advance.

  6. #6

    Default Re: Losing $home priveleges after using Yast2

    Just to add, I decided to clean out KDE, upgraded to 4.2, and everything is fine now, apart from I'm looking to get KDM themed, which is proving to be a nightmare!

    Thanks for your efforts on the privileges issue.

  7. #7
    goldie NNTP User

    Default Re: Losing $home priveleges after using Yast2

    welcome

    and, i guess if you NEVER log into KDE as root, this particular
    problem with the .ICE* will be over for you..

    --
    goldie
    Give a hacker a fish and you feed him for a day.
    Teach man and you feed him for a lifetime.

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Losing $home priveleges after using Yast2

    KDM theming can only be changed by root. So, open a terminal window and issue the command:
    su -c systemsettings
    Enter root password when asked for

    Now, in the Advanced tab, you find the Login Manager, where you can change the KDM theme.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •