Results 1 to 4 of 4

Thread: DHCP problem with Easy-LTSP

  1. #1

    Unhappy DHCP problem with Easy-LTSP

    I installed Kiwi-LTSP just now. Two days ago I also tried setting up a thin client server on Windows to no avail. I tried two products then. I think they're quite error-prone. And their forums aren't very active, hardly any responses. Anyway, the problem now with Easy-LTSP is that during the Prebuild image it gives me this error:
    No subnet declaration for eth1 (0.0.0.0).
    ** Ignoring requests on eth1. If this is not what
    you want, please write a subnet declaration
    in your dhcpd.conf file for the network segment
    to which interface eth1 is attached. **
    Now I've read many consultations over this problem but they're on other distributions and I haven't found a working solution. I've checked the the dhcpd.conf used by kiwi-ltsp and see that subnet is declared.
    option domain-name "WORKGROUP";
    option domain-name-servers 10.0.0.254;
    option routers 10.0.0.254;
    default-lease-time 14400;
    ddns-update-style none;
    next-server 10.0.0.254;
    subnet 10.0.0.0 netmask 255.255.255.0 {
    range 10.0.0.50 10.0.0.100;
    default-lease-time 14400;
    max-lease-time 172800;
    filename "pxelinux.0";
    }

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: DHCP problem with Easy-LTSP

    I think if you look in /etc/sysconfig/dhcpd you have not specified the Ethernet interface that it's supposed to listen on.

  3. #3

    Default Re: DHCP problem with Easy-LTSP

    It still didn't work even after specifying so.

    I found a solution in probably an archived thread that in order that dhcpd can run I have to set "ifconfig eth0 x.x.x.x netmask 255.255.255.0" in the terminal. Now if there's only a way to permanently fix it so I wouldn't have to do it everytime I've booted up.

    Onto the next problem. Upon PXE-booting, the client doesn't seem to get anything via TFTP.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: DHCP problem with Easy-LTSP

    Go into YaST set eth0 to be configured by ifup and specify the IP address and netmask of eth0.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •