Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Internet was working on Ubuntu, now not on Suse

  1. #1

    Default Internet was working on Ubuntu, now not on Suse

    I had to remove Ubuntu because I didn't have the room for both flavors on my machine. Ubuntu ran firefox just fine.

    Just installed Suse 11.1. Install worked fine - as far as I know. When I tried to connect to the internet thru firefox, I get url=http://www.opensuse.org]openSUSE.org[/url] address not found. After reading some entries in this forum, I tried to ping 208.67.222.222 and was able to ping it just fine (got 24 packets submitted, 24 packets received). I'm running thru a linksys router and a motorola modem.

    After reading another forum entry, I checked my Network Setup Card - it activates at boot time.

    Going into Network Settings and to configure how firefox connects to the internet, I've got it set to the same way that my vista machine connects - No proxy.

    I called my ISP to see if they could help. They don't support Linux, but they did check to see if I could get to my modem - and I could. But, as I said above, I'm able to ping that outside 208.67.222.222 address.

    Any help would be fantastic.
    Thanks...

  2. #2

    Default Re: Internet was working on Ubuntu, now not on Suse

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Sounds like a DNS issue. Please post the output from:

    dig google.com

    Also, just for reference:

    ip addr sh
    ip route sh
    cat /etc/resolv.conf

    Finally tell us what the internal IP of your router is.

    Good luck.





    mocdog wrote:
    > I had to remove Ubuntu because I didn't have the room for both flavors
    > on my machine. Ubuntu ran firefox just fine.
    >
    > Just installed Suse 11.1. Install worked fine - as far as I know.
    > When I tried to connect to the internet thru firefox, I get
    > url=http://www.opensuse.org]openSUSE.org[/url] address not found. After
    > reading some entries in this forum, I tried to ping 208.67.222.222 and
    > was able to ping it just fine (got 24 packets submitted, 24 packets
    > received). I'm running thru a linksys router and a motorola modem.
    >
    > After reading another forum entry, I checked my Network Setup Card - it
    > activates at boot time.
    >
    > Going into Network Settings and to configure how firefox connects to
    > the internet, I've got it set to the same way that my vista machine
    > connects - No proxy.
    >
    > I called my ISP to see if they could help. They don't support Linux,
    > but they did check to see if I could get to my modem - and I could.
    > But, as I said above, I'm able to ping that outside 208.67.222.222
    > address.
    >
    > Any help would be fantastic.
    > Thanks...
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKby4MAAoJEF+XTK08PnB5m+sQAIeCFTTmj/EY6NUi1Euou10y
    VHy2QG+OUcUw6rA7N7LobqqqVvX/Op9viCFutOBekRbACujqEIueihvJ081Z+A+w
    bQhDMKEjAUOa3awk43QPEyJj1o4WJ4f6XsybFJ3bJJHJPGTOdJptOE7uHUjgQ7/h
    poeOOYzFb1mhdsFjq47KysslaQVsh4qR8z0eYWmnwOZT1z0Sa5AEapsL6/KGen+D
    gPWs1ce2E0+6EEGZCANNx/fkzjhX04AHU61qxyS69PypxRBiTEFEBkzujLYefrw9
    w74pWyd3QAfdbtKCv/2IJQjCIBibFQct7dW2R1K9H+zvdqkLpsHGVMvL+UOf2bQu
    /hLbMKJRfOS4tHFX7mGtpekmKLgKTG9svB/FO+YYnhojzUpxo79U3+C+yVxm5MF8
    +mcEHLcTC29HoqGWwKXYmoilX7kI/l1B+SY7Wc8Qu7b7E5cppLiuCEqL4EwXdNof
    1EMQRdOan0ovYQpkrC6vl0eApigTliAvMayCBfuGJWodAhE3F3UJpEno7dLvzTUd
    TWGfXn8HMabfDvzbCpqRRxhBAh/Tt5bmhif5I5bIj4NVPxd6NVb1uqPIfEK1dgBJ
    kNWi0ZEO8d28inGJhsFComF7161IZYfkoS49T/KdDFalKcGdYviRPq8uSRzTCgzR
    DVy3M5uylljFGlvwFH8k
    =ao91
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: Internet was working on Ubuntu, now not on Suse

    It is very similar to the problem I've had (and solved) after an installation of openSUSE today.

    I've described it here btw :
    ping working but addresses not resolved - openSUSE Forums


    A full online update was enough to fix it.

    run

    > host update.opensuse.org

    you will get an IP

    Now go to yast / Software Repositories and replace every occurrence of "update.opensuse.org" with the IP. Then run an online update, it worked for me. This problem might be driver-related.

  4. #4

    Default Re: Internet was working on Ubuntu, now not on Suse

    AB,
    term@linux-nnjb:~> dig google.com



    ; <<>> DiG 9.5.0-P2 <<>> google.com

    ;; global options: printcmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64066

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0



    ;; QUESTION SECTION:

    ;google.com. IN A



    ;; ANSWER SECTION:

    google.com. 256 IN A 74.125.67.100

    google.com. 256 IN A 74.125.127.100

    google.com. 256 IN A 74.125.45.100



    ;; Query time: 22 msec

    ;; SERVER: 192.168.1.254#53(192.168.1.254)

    ;; WHEN: Tue Jul 28 17:10:00 2009

    ;; MSG SIZE rcvd: 76

    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    term@linux-nnjb:~> ip addr sh

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo

    inet 127.0.0.2/8 brd 127.255.255.255 scope host secondary lo

    inet6 ::1/128 scope host

    valid_lft forever preferred_lft forever

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000

    link/ether 00:04:5a:44:35:1a brd ff:ff:ff:ff:ff:ff

    inet 192.168.5.102/24 brd 192.168.5.255 scope global eth0

    inet6 fe80::204:5aff:fe44:351a/64 scope link

    valid_lft forever preferred_lft forever

    3: pan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN

    link/ether 4a:98:8b:0f:b7:6c brd ff:ff:ff:ff:ff:ff

    inet6 fe80::4898:8bff:fe0f:b76c/64 scope link

    valid_lft forever preferred_lft forever
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    term@linux-nnjb:~> ip route sh

    192.168.5.0/24 dev eth0 proto kernel scope link src 192.168.5.102

    169.254.0.0/16 dev eth0 scope link

    127.0.0.0/8 dev lo scope link

    default via 192.168.5.1 dev eth0
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    term@linux-nnjb:~> cat /etc/resolv.conf

    ### /etc/resolv.conf file autogenerated by netconfig!

    #

    # Before you change this file manually, consider to define the

    # static DNS configuration using the following variables in the

    # /etc/sysconfig/network/config file:

    # NETCONFIG_DNS_STATIC_SEARCHLIST

    # NETCONFIG_DNS_STATIC_SERVERS

    # NETCONFIG_DNS_FORWARDER

    # or disable DNS configuration updates via netconfig by setting:

    # NETCONFIG_DNS_POLICY=''

    #

    # See also the netconfig(8) manual page and other documentation.
    #

    # Note: Manual change of this file disables netconfig too, but

    # may get lost when this file contains comments or empty lines

    # only, the netconfig settings are same with settings in this

    # file and in case of a "netconfig update -f" call.

    #

    ### Please remove (at least) this line when you modify the file!

    nameserver 192.168.1.254

    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


    I'm a little unsure on the last request. To access my router, I enter 192.168.1.254. That lists all sorts of info from my router. Or there is one called the IP Address/Name - 192.168.1.3

    Let me know if that is what you're looking for.

  5. #5
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    249

    Default Re: Internet was working on Ubuntu, now not on Suse

    Are you able to reach other urls like e.g. Google If yes this is a problem related to the opensuse servers otherwise it is a dns trouble. So let us know.

  6. #6

    Default Re: Internet was working on Ubuntu, now not on Suse

    brisciotti,
    I cannot get to google.com, yahoo.com or anything like that - however, if I to a "host www.yahoo.com" on Command Line Terminal, it comes back with 69.147.76.15. If I enter that in Firefox, I can get to yahoo's main page. If I click on a hyperlink on Yahoo's main page, I get the "Fire fox can't find the server www.yahoo.com"
    Thanks

  7. #7

    Default Re: Internet was working on Ubuntu, now not on Suse

    Quote Originally Posted by mocdog View Post
    brisciotti,
    I cannot get to google.com, yahoo.com or anything like that - however, if I to a "host www.yahoo.com" on Command Line Terminal, it comes back with 69.147.76.15. If I enter that in Firefox, I can get to yahoo's main page. If I click on a hyperlink on Yahoo's main page, I get the "Fire fox can't find the server www.yahoo.com"
    Thanks
    If you are using KDE, have you tried browsing with konqueror.. Just to check if the issue is not with firefox!!

  8. #8
    Join Date
    Mar 2009
    Location
    Caribbean
    Posts
    242

    Default Re: Internet was working on Ubuntu, now not on Suse

    funny thing is, I have a redhat server having a similar problem. Windows servers can access the internet but it can't.

    I keep giving it either an external DNS or internal DNS server but nothing works. I can ping any destination i want but no dns.

    When I run a nslookup i get nothing. I'm just wondering if I'm setting the config the wrong way. (GNOME: system>administration>Network>DNS [tab])
    Opensuse 11.3 KDE 4.4.4, Windows XP. Vostro 1500 with 2.0Ghz Core2Duo and 8400M GS and DELL wireless 1390 Card
    Office: PCLinuxOS KDE 4.3.5 Whitebox, 2GB RAM, 2.8GHz Pentium 4

  9. #9
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    249

    Default Re: Internet was working on Ubuntu, now not on Suse

    I'm pretty sure you have a dns problem. Ask your isp for it's dns server address then add those addresses to /etc/resolv.conf. If there you fine the address of your router. Delete it or move it at the last line of the file. This has to be done with root privileges. Also disable ipv6 support if present and reboot just to make it simple.

  10. #10
    Join Date
    Jul 2008
    Location
    Cape Town
    Posts
    51

    Default Re: Internet was working on Ubuntu, now not on Suse

    and ubuntu is quick, opensuse is dead slow, how does one fix that?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •