Results 1 to 4 of 4

Thread: samba trouble

  1. #1

    Default samba trouble

    I am trying to share a folder with everybody
    I think I have everything setup like it should be but I can't connect to it from windows XP if I do a smbclient -L 192.168.10.10 I get connection refused. What do I look for next???

  2. #2
    PV NNTP User

    Default Re: samba trouble

    On Wed July 29 2009 05:06 pm, twdavis wrote:

    >
    > I am trying to share a folder with everybody
    > I think I have everything setup like it should be but I can't connect
    > to it from windows XP if I do a smbclient -L 192.168.10.10 I get
    > connection refused. What do I look for next???
    >
    >

    twdavis:
    Go over these HowTos:
    http://opensuse.swerdna.org/suselanprimer.html
    http://opensuse.swerdna.org/susesambaserver.html

    I suspect that a firewall may be blocking this ( on XP or Suse) or that you
    have not created users with:
    Code:
    su
    smbpasswd -a <username>
    Note: "username" must be a valid linux user.

    If this does not sort out your problem, it would help if you posted the
    contents of /etc/samba/smb.conf. You might also try to clarify your problem;
    is the share on XP or OpenSuse. In your post you note that you can NOT
    connect from XP but then give an error from smbclient.
    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  3. #3

    Default MY SMB.CONF

    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2007-06-29
    [global]
    workgroup = harden
    printcap name = cups
    cups options = raw
    null passwords = Yes
    guest account = guest
    comment = samba server
    domain master = No
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    winbind gid = 10000-20000
    winbind uid = 10000-20000

    [homes]
    comment = Home Directories
    valid users = %S
    browseable = No
    read only = No
    inherit acls = Yes

    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700

    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/

    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes

    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    [Public]
    path = /srv/www/
    public =yes
    only guest = yes
    writeable = yes
    hide files = cgi-bin/htdig/perl-lib/
    case sensitive = no
    msdfs proxy = no
    hosts allow = 192.168.10., 127.

  4. #4
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: samba trouble

    Here's a guide for configuring smb.conf for windows comms: Enhance Browsing with a Local Master Browser
    I suggest you change the [global] stanza to this:
    Code:
    [global]
    workgroup = workgroup = harden
    netbios name = network_name_for_this_workstation <== adjust this
    name resolve order = bcast host lmhosts wins
    server string = ""
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    use client driver = yes
    map to guest = Bad User
    local master = yes
    preferred master = yes
    os level = 33
    usershare allow guests = Yes
    usershare max shares = 100
    usershare owner only = False
    Then reboot SuSE
    Then reboot windows
    Then run your code:
    Code:
    smbclient -L 192.168.10.10
    If that doesn't give the correct result, temporarily turn off the firewall as a diagnostic test (to see if the firewall is blocking Samba). Tempoarry turn off is done with this command:
    Code:
    sudo /sbin/rcSuSEfirewall2 stop
    and run smbclient again.

    If it turns out that the firewall is a problem, open it for samba using this guide:
    Opening the Firewall for Samba
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •