Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Flash Player 10 on 11.1

  1. #1

    Default Flash Player 10 on 11.1

    Hey all!
    I've been trying to get flash player to work for a little over a week now. Can you help me?

    Whenever I run flashplayer in bash it just spits out:
    WARNING: environment variable G_FILENAME_ENCODING set and it is not UTF-8
    Segmentation fault

    Not surprisingly, the player doesn't load in Firefox.

    The output of ldd shows that all of the libraries are there ("ldd `which flashplayer` | grep not" shows no output) and YaST doesn't say I am missing any dependencies.

    I'm running 64-bit OpenSuSE 11.1

    Hope you can help!

  2. #2
    Join Date
    Jun 2008
    Location
    Charleston, SC, USA
    Posts
    192

    Default Re: Flash Player 10 on 11.1

    To begin, some questions:
    What version of flash player do you have installed? Did you install it through the repos, or have you downloaded and installed it from Adobe's website yourself?

    I see you are running 64-bit Opensuse. Are you running the 32-bit version of flash? If so, are you running it with a 32-bit version of firefox, or are you trying to use the nspluginwrapper to run it in 64-bit firefox? Or are you running the 64-bit alpha version of flash?
    My personal philosophy:
    The only way you won't find something is if you stop looking.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Flash Player 10 on 11.1

    su terminal

    Code:
    zypper in flash-player
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Flash Player 10 on 11.1

    It's the 32-bit version of flash, running under nspluginwrapper in 64-bit firefox.

    flash-player:10.0.22.87-0.1.1-i586 from repo-update
    nspluginwrapper:1.2.2-2.1.1-x86_64 from repo-update

    @caf4962: zypper replied that I already had the package installed and exited with a "nothing to do."

  5. #5
    Join Date
    Jun 2008
    Location
    Charleston, SC, USA
    Posts
    192

    Default Re: Flash Player 10 on 11.1

    Quote Originally Posted by nthread View Post
    ...Whenever I run flashplayer in bash it just spits out...
    What do you mean by this? Do you mean you launch Firefox from terminal, go to a website with flash and view the output? Or are you doing something different?

    What version of firefox are you running (3.0.11, 3.5 etc...)?

    What repositories do you have enabled? Post the output to:
    Code:
    zypper lr
    My personal philosophy:
    The only way you won't find something is if you stop looking.

  6. #6

    Default Re: Flash Player 10 on 11.1

    It's the actual command flashplayer:

    Code:
    cody@home:~>flashplayer
    WARNING: environment variable G_FILENAME_ENCODING set and it is not UTF-8
    Segmentation fault
    cody@home:~>
    I am running Firefox 3.0.12

    Code:
    #  | Alias                    | Name                                    | Enabled | Refresh
    ---+--------------------------+-----------------------------------------+---------+--------
    1  | KDE:KDE4:Community       | KDE:KDE4:Community                      | Yes     | Yes
    2  | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop                | Yes     | Yes
    3  | KDE:Qt                   | KDE:Qt                                  | Yes     | Yes
    4  | Libdvdcss repository     | Libdvdcss repository                    | Yes     | Yes
    5  | My_Downloaded_RPMs       | My Downloaded RPMs                      | Yes     | Yes
    6  | NVIDIA Repository        | NVIDIA Repository                       | Yes     | Yes
    7  | Packman Repository       | Packman Repository                      | Yes     | Yes
    8  | devel:gcc                | devel:gcc                               | Yes     | Yes
    9  | home:Akoellh             | home:Akoellh                            | Yes     | Yes
    10 | home:cfeck               | home:cfeck                              | Yes     | Yes
    11 | home:deanjo13            | home:deanjo13                           | Yes     | Yes
    12 | home:dgege:g15tools      | home:dgege:g15tools                     | Yes     | Yes
    13 | home:nesnomis:games      | home:nesnomis:games                     | Yes     | Yes
    14 | openSUSE 11.1-0          | openSUSE 11.1-0                         | Yes     | No
    15 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib                | Yes     | Yes
    16 | repo                     | openSUSE BuildService - Wine CVS Builds | Yes     | Yes
    17 | repo-debug               | openSUSE-11.1-Debug                     | No      | Yes
    18 | repo-non-oss             | openSUSE-11.1-Non-Oss                   | Yes     | Yes
    19 | repo-oss                 | openSUSE-11.1-Oss                       | Yes     | Yes
    20 | repo-source              | openSUSE-11.1-Source                    | No      | Yes
    21 | repo-update              | openSUSE-11.1-Update                    | Yes     | Yes
    22 | repo_1                   | VideoLan Repository                     | Yes     | Yes
    23 | security:privacy         | security:privacy                        | Yes     | Yes
    Note that My Downloaded RPM's only contains CrossOver and the proprietary VirtualBox RPM's. Nothing that I can imagine would be related to Firefox, nspluginwrapper, or the Flash Player.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Flash Player 10 on 11.1

    su terminal

    Code:
    zypper in nspluginwrapper
    what happens
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Flash Player 10 on 11.1

    Not much, sadly.

    Code:
    cody@home:~> sudo zypper in nspluginwrapper
    root's password:
    Retrieving repository 'My Downloaded RPMs' metadata [done]
    Retrieving repository 'Packman Repository' metadata [done]
    Building repository 'Packman Repository' cache [done]
    Retrieving repository 'home:Akoellh' metadata [done]
    Building repository 'home:Akoellh' cache [done]
    Retrieving repository 'openSUSE:Factory:Contrib' metadata [done]
    Building repository 'openSUSE:Factory:Contrib' cache [done]
    Loading repository data...
    Reading installed packages...
    'nspluginwrapper' is already installed.
    Resolving package dependencies...
    Nothing to do.

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Flash Player 10 on 11.1

    Please do this.
    Open Yast - Software Management
    Search for: flash
    Take a screenshot and post a link here
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Flash Player 10 on 11.1

    Gladly,
    Here is the link: http://i28.tinypic.com/29c6ob6.jpg

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •