Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Not getting automatic updates notification on OpenSuse 11.1

  1. #1

    Unhappy Not getting automatic updates notification on OpenSuse 11.1

    I installed OpenSuse 11.1 (switched from Fedora 11) last week. I installed my apps and also updgraded them using the yast2--install 'upgrade' tab. However i have not got a single notification to get security patches/bugs/enhancements. I have configured for daily updates & notification through Control center. I have seen OpenSuse screenshots where a 'blue?' button appears on taskbar notifying you of updates (Fedora had something similar too); but i have never seen something like that on my system yet.

    Is something wrong? I am really starting to get worried now since it's a home computer which my entire family uses.

    Would appreciate early response !

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Not getting automatic updates notification on OpenSuse 1

    Open a terminal and type:

    Code:
    zypper lr --details
    post result so we can see your repo status
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Not getting automatic updates notification on OpenSuse 1

    Here is what i got as output:

    | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-----------------------+-----------------------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------

    1 | Google | Google | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |
    2 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
    3 | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    4 | repo | NVIDIA Repository | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1 |
    5 | repo-debug | openSUSE-11.1-Debug | Yes | Yes | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
    6 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | No | 99 | yast2 | Index of /distribution/11.1/repo/non-oss |
    7 | repo-oss | openSUSE-11.1-Oss | Yes | No | 99 | yast2 | Index of /distribution/11.1/repo/oss |
    8 | repo-source | openSUSE-11.1-Source | Yes | Yes | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
    9 | repo-update | openSUSE-11.1-Update | Yes | No | 99 | rpm-md | Index of /update/11.1 |
    10 | repo_1 | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.1/repo/non-oss |
    11 | repo_10 | openSUSE BuildService - Virtualization (QEMU) | Yes | Yes | 99 | rpm-md | Index of /repositories/Virtualization:/Qemu/openSUSE_11.1 |
    12 | repo_11 | openSUSE BuildService - Virtualization (VirtualBox) | Yes | Yes | 99 | rpm-md | Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.1 |
    13 | repo_12 | openSUSE BuildService - X11:Compiz | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/Compiz/openSUSE_11.1 |
    14 | repo_13 | openSUSE BuildService - XFCE | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/xfce/openSUSE_11.1 |
    15 | repo_14 | openSUSE BuildService - Drivers for webcams | Yes | Yes | 99 | rpm-md | Index of /repositories/drivers:/webcam/openSUSE_11.1 |
    16 | repo_15 | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | Index of /repositories/games/openSUSE_11.1 |
    17 | repo_16 | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    18 | repo_17 | openSUSE BuildService - Database | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/database/openSUSE_11.1 |
    19 | repo_18 | openSUSE BuildService - Mail Server | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/mail/openSUSE_11.1 |
    20 | repo_19 | openSUSE BuildService - PHP | Yes | Yes | 99 | rpm-md | Index of /repositories/server:/php/openSUSE_11.1 |
    21 | repo_2 | Main Repository (OSS) | Yes | Yes | 99 | yast2 | Index of /distribution/11.1/repo/oss |
    22 | repo_20 | Main Update Repository | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    23 | repo_21 | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
    24 | repo_22 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
    25 | repo_23 | openSUSE Education | Yes | Yes | 99 | yast2 | Index of /download/repo/1.0/11.1 |
    26 | repo_24 | ATI Repository | Yes | Yes | 99 | rpm-md | http://www2.ati.com/suse/11.1 |
    27 | repo_3 | openSUSE BuildService - Wine CVS Builds | Yes | Yes | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.1 |
    28 | repo_4 | openSUSE BuildService - GNOME:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_11.1 |
    29 | repo_5 | openSUSE BuildService - GNOME:STABLE | Yes | Yes | 99 | rpm-md | Index of /repositories/GNOME:/STABLE/openSUSE_11.1 |
    30 | repo_6 | openSUSE BuildService - KDE:Backports | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.1 |
    31 | repo_7 | openSUSE BuildService - KDE:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.1 |
    32 | repo_8 | openSUSE BuildService - Mono:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/Mono:/Community/openSUSE_11.1 |
    33 | repo_9 | openSUSE BuildService - OpenOffice.org | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 |

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Not getting automatic updates notification on OpenSuse 1

    You have duplicates of Update #3 and #22
    keep #3 and change it's priority to 20
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Not getting automatic updates notification on OpenSuse 1

    #9 is also the same. Should i delete that as well?

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Not getting automatic updates notification on OpenSuse 1

    Quote Originally Posted by ddas4 View Post
    #9 is also the same. Should i delete that as well?
    Yes
    Dude you have way too many repo, but never mind that for now. Don't forget the priority in #3 to (20)
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Not getting automatic updates notification on OpenSuse 1

    Deleted #22 and #9 and changed priority of #3 to 20. What next to get auto updates?

    Also in your opinion which one of the repos should i remove so that i still have all software on my Yast? It takes way too long for Yast, install software, etc. to start up since auto-refresh attempts to get the latest updates every time.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Not getting automatic updates notification on OpenSuse 1

    Do you have the updater running in the panel? I never bother with it. Prefer to use Yast Software Management (or you could use the Yast Online Update)

    Another method is; open a terminal and become su then do

    Code:
    zypper ref
    then

    Code:
    zypper up
    ======================================

    Regarding the repo's. Do you know why you have them all?
    With so many there, it's possible you could loose functionality or break a driver if we take them out.
    I could advise you but understand, it's virtually impossible for me to know the outcome.

    My guess is you had a bit of a repo adding spree;
    I think that because you have both nvidia and ati graphics repo's amongst a plethora of other superfluous repo's.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Not getting automatic updates notification on OpenSuse 1

    Updater is not running in the panel yet. How do i fix it in order to make it pick updates automatically?

    I did go on a repo adding spree. Followed a website (blindly) and added them. Frankly i don't even know which ones i use. I have installed the following:

    Acrobat reader, Back in time UI, HPLIP for printing/scanning, Peazip, Songbird, Java, VLC player, XBMC, xsane, aMSN, Skype, Banshee, Brasero, Flash player, MPlayer, Rhythmbox, Totem, Open office suite, Planner, AntiVir GUI, RPMOrphan.

    I did not touch the standard software can came installed with OpenSUSE 11.1 liveCD.

    But my auto update issue is top priority!

  10. #10

    Default Re: Not getting automatic updates notification on OpenSuse 1

    I have been using Yast for doing manual updates so far; but my issue is that updates are not coming automatically. I have even restarted !

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •