Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Repo Update constantly fails from unrecognized error

  1. #1

    Default Repo Update constantly fails from unrecognized error

    When trying to update my Linux system I get constantly the error:

    PackageKit Error repo-not-available: Download (curl) error for 'http://download.opensuse.org/update/11.1/repodata/primary.xml.gz': Error code: Unrecognized error Error message: transfer closed with 1579972 bytes remaining to read

    Indicated file can be loaded without problems from same computer with same analogue MicroLink 56k modem and dial-in-number provided I am using MS-Windows.

    When connecting via KInternet in OpenSuse download constantly fails after approx. 20% at variable byte count. So download out of Yast, KDE-Updater, and manually from explorer via Save As... impossible.

    These are my system coordinates:

    Betriebssystem
    Betriebssystem: Linux 2.6.27.19-3.2-pae i686
    System: openSUSE 11.1 (i586)
    KDE: 4.2.1 (KDE 4.2.1) "release 106"
    Graphic board
    Hersteller: DRI R300 Project
    Modell: Mesa DRI R300 20060815 AGP 8x x86/MMX/SSE2 TCL
    Treiber: 1.3 Mesa 7.2

    Update problem since end of juin. First clean installation middle of juin with same hardware problems but without the updater failures. So something serious must have happened.
    Checksums odd?

    Selected repositories not configured by hand but pre-configured by package offered in:
    https://shop.linuxnewmedia.de/store/sh01/SH11005/de

    I have start-up problems with Intel sound-board (Message: does not work). KDE-Media-Manager not loaded possibly as consequence? (Cafeine plays music nonetheless but Amarok quits, Audio-CDs not recognized in explorer windows). If deeper hardware reasons, possibly interrupt problem disturbing anyhow the modem?

    I think, problem is quite on the side of my system. So remote debugging possibly very difficult. My personal understanding of Linux is NULL. So your help would possibly drown me. Anyway you should keep track of this problem because it seems to randomly occur here and there on other systems too (-> browse the internet for the error message on top).

    One more hint: Please preconfigure KPPP to use full modem speed as Kinternet does. Isn't funny loading data with 22k if 46k is possible without knowing any remedy. This possibly also effects GnomePPP which seems to be the only dial-in tool for Ubuntu (not your steak, I know...;-))

    Good Day and Good Luck

  2. #2

    Default Re: Repo Update constantly fails from unrecognized error

    Additional information:

    The extended properties of my sound board P4P800 Mainboard indicate a

    AC'97 Codec Frequency (0=automatic detection),
    AC'97 Workaround for unusual hardware,
    some buggy-semaphore, and buggy-irq

    I translated some words from the german.

    I indicate this all for the case that the underlaying problem could also affect the function of modem etc. May also be that the libraries for data transfer simply throw exceptions for what reason ever. I suppose that use of modem is not very common any more. So I belong to a minority... ;-(

  3. #3

    Default Re: Repo Update constantly fails from unrecognized error

    Hi Konrad,

    I had to chime in as I'm having the same problem, (my thread here)
    Update Problem using zypper - openSUSE Forums
    and I noticed you are using dial up, as I am, with Kinternet. I wonder if the problem is just for those with dial up, otherwise this forum would see many more complaints of update repository problem.

    I'm going to try using wvdial and see if this makes a difference. I'll report back if it does.
    Orba

  4. #4
    brassy NNTP User

    Default Re: Repo Update constantly fails from unrecognized error

    ok! you may have cracked this case...i could be that there is
    something in the modem init string that windows is using that is not
    being used in kppp (or whatever you are using to drive the modem)..

    hmmmm...(thankfully) it has been a long time since i had to do this so
    i don't remember any of the details--but, i used to have to figure out
    exactly WHAT initial strings were being sent to my modem to make my
    ISP happy...of course, the ISP's start up disk ASSUMED i was using a
    modem often using in my country/locale AND i was using the Windows of
    the day...

    so, i had to painfully inspect the files on the ISP's CD/floppy disk
    in a text editor, looking for standard modem commands from the hayes
    command set (example page: <http://www.cellular.co.za/hayesat.htm>..

    usually looking through the windows setup files you could find ATDT
    somewhere and near would be all the cods your ISP expected to see to
    set up a stable, persistent connection..

    it is not SO painful to search, you should be able to use grep, kinda
    like this:

    grep -i atdt /[fullpath to the CD/Floppy media]/*

    which should then list all the fils with that atdt (or ADTD) string,
    then just look around inside for the AT commands that came before that
    (ADTD commands a dial, and the init string comes before any dial)

    then, look in the documentation that came with the modem itself to see
    what the manufacturer put in as the default initialization, and make
    sure it meshes with the ISPs needs....if not, learn how to either
    change the manufacturer's default init, OR add/change it on the fly..

    and THEN it was _just_ a matter of finding the CORRECT magic
    incantation for both the modem AND the ISP and shoving that into
    whatever is driving the modem from Linux (and putting that sting into
    its setup, replacing whatever the kppp guy decided was the most likely
    choice for you...)

    good luck....

    --
    brassy

  5. #5

    Default Re: Repo Update constantly fails from unrecognized error

    Hi brassy,

    Thanks so much for the help! I'm new with opensuse and using kinternet and yast. The question I am wondering for the init strings is that yast and zypper have no problems refreshing oss and non-oss repositories for me, so I don't understand how this could be an init string problem with my modem. And, like Konrad said, this problem started in June, for prior to that I had no problems refreshing update repository. I can't find the thread, but this is supposed to be a problem fixed in 11.2.

    If I could figure out how to use ftp to refresh update, I'd try that. Time to do some more research.

    Oh, I tried wvdial and it didn't make a difference. I also turned off the firewall in sysconfig/network/general and that didn't help. I also turned NetworkManager back on in sysconfig/network/general, to no avail (rebooted). I don't like using wvdial anyway in this system as it requires root privileges, but helpful for modem specs and testing.

    Code:
     WvDial: Internet dialer version 1.60
    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Idle Seconds = 300, disabling automatic reconnect.
    --> Sending: ATDT(phone number)
    --> Waiting for carrier.
    ATDT(phone number)
    CONNECT 50666 V44
    --> Carrier detected.  Starting PPP immediately.
    --> Starting pppd at Thu Jul 23 09:56:21 2009
    --> Pid of pppd: 3532
    --> pppd: 2[7f]
    --> Using interface ppp0
    --> pppd: 2[7f]
    --> pppd: 2[7f]
    --> pppd: 2[7f]
    --> local  IP address o.oo.oo.oo (I did this)
    --> pppd: 2[7f]
    --> remote IP address oo.oo.ooo.ooo
    --> pppd: 2[7f]
    --> primary   DNS address 209.244.0.3
    --> pppd: 2[7f]
    --> secondary DNS address 209.244.0.4
    --> pppd: 2[7f]
    --> Script /etc/ppp/ip-up run successful
    --> Default route Ok.
    --> Nameserver (DNS) Ok

  6. #6

    Default Re: Repo Update constantly fails from unrecognized error

    caf4926 helped me see the forest for the trees in my other thread and problem with update repository for me is solved.

    I did as he suggested and used an alternate mirror, and didn't have to use media ftp, but the usual URL method. When I tried using an alternate http mirror before, I wasn't getting the complete address path. I tried the mirror in Indonesia and it refreshed without problems.

    Update Problem using zypper - Page 2 - openSUSE Forums

    Regards,
    Orba

  7. #7

    Default Re: Repo Update constantly fails from unrecognized error

    Son, if someone tells you that there is a broken leg, don't tell him he can solve the problem by walking on hands even if _you_ do.

    If there is a Mirror in Sumatra, Borneo, or even in Taka-Tuka-Land this is off interest. The point of the bug is not the mirror in Kiruna, no, the point is that a simple thing like an update doesn't work any more under the explained conditions, if the official OpenSuse-pathes are chosen being preconfigured with official distributions in more or less common bundles offert in the bookshops. That's the point we must seriously discuss.

    Or more clearly: If someone buys a distribution in the bookshop with large headlines (Migrate from Windows to Linux in an hour) - do you think, such a "migrant" is instantenously able to realize the true problem of the matter and then to find a mirror on Galapagos and to configure it in order to have the packages up to date before he can reinstall the multi-media packages seperately which is almost ever necessary because they are missing on the disks for legal reasons?

    I'll stop it now. Good day

  8. #8

    Default Re: Repo Update constantly fails from unrecognized error

    Hi Konrad,

    I'm not sure who you were addressing, but I do agree with you that this is a bug in the main Update software page, as well as what comes with the distribution, and so I would file a bug report, as one should not have to go searching for a mirror that works. I used the forum to help solve this problem for now, as I needed to check what updates were available. When I put it off too long, with dial up, I find I have a huge download session to deal with.

    Regards, Orba

  9. #9
    brassy NNTP User

    Default Re: Repo Update constantly fails from unrecognized error

    > I'm not sure who you were addressing

    me either, but if he was calling me "son" he must be a pretty old guy,
    who can be thankful for nothing...which is all i expect he will get
    from me in the future.

    --
    brassy

  10. #10

    Default Re: Repo Update constantly fails from unrecognized error

    Hi Brassy,

    And I'm a Mrs., but Konrad didn't know that.

    I do need to fill a bug report for this "Download (curl) error for 'http://download.opensuse.org/update/11.1/repodata/primary.xml.gz': Error code: Unrecognized error". I just haven't made the time to sign up and register there. I checked, and the only similar bug reports have "Error code: Cannot connect", but not "unrecognized" or "unknown error".

    Again, thanks Brassy for the modem init string suggestions, as in the past I have had to fiddle with them, but not so in the recent 6 months, thank goodness.

    Warmest regards,
    Orba (just a name I picked out of my head )

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •