Results 1 to 3 of 3

Thread: wireless will not grab ip address

  1. #1
    Join Date
    Sep 2008
    Posts
    40

    Default wireless will not grab ip address

    Greetings,

    I installed SuSE 11.1 64 bit. Previously, I had SuSE 11.1 32 bit. The wireless adapter will not grab an ip address from dhcpcd but the lan connection will. The wireless adapter worked properly with SuSE 11.1 32 bit. Here is the output after running this command /etc/init.d/network restart:

    Shutting down network interfaces:
    eth0 device: nVidia Corporation CK804 Ethernet Controller (rev a3)
    eth0 done
    eth1 device: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
    No configuration found for eth1
    Nevertheless the interface will be shut down.
    eth1 done
    wlan0 name: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
    wlan0 done
    Shutting down service network . . . . . . . . . done
    Hint: you may set mandatory devices in /etc/sysconfig/network/config
    Setting up network interfaces:
    eth0 device: nVidia Corporation CK804 Ethernet Controller (rev a3)
    eth0 Starting DHCP4 client.
    eth0 IP address: 192.168.1.106/24
    eth0 done
    eth1 device: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
    No configuration found for eth1
    eth1 unused
    wlan0 name: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
    wlan0 warning: WPA configured but may be unsupported
    wlan0 warning: by this device
    wlan0 starting wpa_supplicant
    wlan0 Starting DHCP4 client. . . . . . . .
    wlan0 DHCP4 continues in background
    wlan0 waiting
    Setting up service network . . . . . . . . . . done
    SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    SuSEfirewall2: using default zone 'ext' for interface eth1
    SuSEfirewall2: using default zone 'ext' for interface wmaster0
    SuSEfirewall2: batch committing...
    SuSEfirewall2: Firewall rules successfully set

    If you need anymore information I will try to supply it!

    THKS,
    Uans

  2. #2
    Join Date
    Sep 2008
    Posts
    40

    Default Re: wireless will not grab ip address

    I ran these two commands.

    linux-1iou:/home/devel # iwconfig wlan0
    wlan0 IEEE 802.11bg ESSID:"Xchange"
    Mode:Managed Frequency:2.462 GHz Access Point: 00:1E:E5:69:C9:53
    Bit Rate=6 Mb/s Tx-Power=27 dBm
    Retry min limit:7 RTS thrff Fragment thr=2352 B
    Encryption keyff
    Power Managementff
    Link Quality=68/100 Signal level:-50 dBm Noise level=-67 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    linux-1iou:/home/devel # ifconfig wlan0
    wlan0 Link encap:Ethernet HWaddr 00:21:29:CFD:7C
    inet6 addr: fe80::221:29ff:fecf:dd7c/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:2549 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3593 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:288037 (281.2 Kb) TX bytes:774953 (756.7 Kb)

    Uans

  3. #3
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: wireless will not grab ip address

    I can see something related to ipv6 in your log. Try to disable that in network configuration in Yast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •