Results 1 to 3 of 3

Thread: Cairo-dock starts twice

  1. #1
    Join Date
    Sep 2008
    Location
    Naples, Italy
    Posts
    51

    Default Cairo-dock starts twice

    Hello,
    I recently installed Cairo-dock on KDE 4.1. It works fine, however I can't figure out why at system start the dock starts twice.

    There are two instances of it, one started with OpenGL enabled and one requiring me to use OpenGL or not. I looked in KDE's System>Autostart panel and I found the "cairo-dock -o" command, which should be OK for my GeForce 9700M (I'm also running Compiz with snow effect fine)

    I looked in all ./kde[x]/Autostart folders, even .kde4/share/autostart, but no script was found. I also searched into my whole home directory against files named "cairo" and I found nothing

    How can I let cairo-dock start only once with OpenGL enabled? Thanks

  2. #2
    Join Date
    Jul 2008
    Location
    Loutraki-Bologna
    Posts
    63

    Default Re: Cairo-dock starts twice

    Same problem here....and both are black without OpenGL...
    Anyone???

  3. #3
    blaramore NNTP User

    Default Re: Cairo-dock starts twice

    I too had this problem and it was really driving me nuts. Here was the answer for me. I noticed that if I closed all instances of the dock and reboot, I was fine when it came back up. However if the dock was running and I reboot, I would have two instances. I figured out that in kde (I'm no expert) it saves the session state prior to shutting down. So when the dock was open and I shut down, The previously open version would respawn and a new one would load via autostart. I went in the session manager and added "cairo-dock" in the section that reads "Applications to be excluded from sessions:". This will prevent kde from respawning the cairo-dock that was left open and just run the auto-start one. That worked for me.

    As for where the autostart is coming from it seems that it can come from a number of places.
    /home/user/.config/autostart/ (Mine is here)
    /home/.kde/Autostart/
    There is also a gui version under the Systems-Settings area(This may be the same as the /home/.kde/Autostart one but I'm not sure.)
    Hopefully this will help some.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •