Results 1 to 10 of 10

Thread: Compiz update wants to downgrade to KDE 4.1

  1. #1

    Default Compiz update wants to downgrade to KDE 4.1

    I have a notification that there is an update for compiz. When I try update it I get a whole lot of dependency issues basically wanting to roll back a whole lot of KDE stuff to 4.1. I'm using KDE 4.2. In the screenshot below you can see the Version options where the 42 repo doesn't list the latest version. It's a little confusing, should I only use the 42 repo for KDE updates?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  2. #2

    Default Re: Compiz update wants to downgrade to KDE 4.1

    Just noticed that 3 lines up there is a compiz at the latest version number. So shouldn't compiz-kde4 be at the same version number?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Compiz update wants to downgrade to KDE 4.1

    You probably need to change the priority of your Update repo to match the kde4.2 repos - which will likely be 99

    Post
    Code:
    zypper lr --details
    if you want us to look at it
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Compiz update wants to downgrade to KDE 4.1

    Notice the kde4 you don't want the kde4 one, uninstall and install the correct one from the 42repo.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  5. #5

    Default Re: Compiz update wants to downgrade to KDE 4.1

    zypper lr --details
    Code:
    # | Alias                | Name                  | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service                                                        
    --+----------------------+-----------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------                                                        
    1 | KDE42_Community      | KDE42 Community       | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42 |                                                                
    2 | KDE:42               | KDE:42                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/                    |
    3 | OpenOffice_Stable    | OpenOffice Stable     | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.1/     |
    4 | openSUSE 11.1-0      | openSUSE 11.1-0       | No      | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                                             |
    5 | openSuSE11.1_Factory | openSuSE11.1 Factory  | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla:/Factory/openSUSE_11.1/           |
    6 | repo-non-oss         | openSUSE-11.1-Non-Oss | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                        |
    7 | repo-oss             | openSUSE-11.1-Oss     | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                            |
    8 | repo-update          | openSUSE-11.1-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/                                           |
    9 | repo_1               | Packman Repository    | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/
    @Feathermonkey, so you're saying I need to delete compiz-kde4 and then install compiz from the 42 repo?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  6. #6
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,434

    Default Re: Compiz update wants to downgrade to KDE 4.1

    FYI,

    My system has been in the same state for many days now. I'm just ignoring
    it until at some point it will all jive again. Sometimes you just have to
    wait it out. Seems to happen two or three times a year.


  7. #7
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,434

    Default Re: Compiz update wants to downgrade to KDE 4.1

    Also FWIW I have the same zypper lr but I don't have factory as a repo.
    The error I get is:

    PackageKit Error dep-resolution-failed: patch:compiz-1005.noarch conflicts
    with compiz-kde4.i586


  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Compiz update wants to downgrade to KDE 4.1

    Quote Originally Posted by suse_tpx60s View Post
    zypper lr --details
    Code:
    # | Alias                | Name                  | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service                                                        
    --+----------------------+-----------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------                                                        
    1 | KDE42_Community      | KDE42 Community       | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_42 |                                                                
    2 | KDE:42               | KDE:42                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/42/openSUSE_11.1/                    |
    3 | OpenOffice_Stable    | OpenOffice Stable     | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.1/     |
    4 | openSUSE 11.1-0      | openSUSE 11.1-0       | No      | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                                             |
    5 | openSuSE11.1_Factory | openSuSE11.1 Factory  | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla:/Factory/openSUSE_11.1/           |
    6 | repo-non-oss         | openSUSE-11.1-Non-Oss | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                        |
    7 | repo-oss             | openSUSE-11.1-Oss     | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                            |
    8 | repo-update          | openSUSE-11.1-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.1/                                           |
    9 | repo_1               | Packman Repository    | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/
    @Feathermonkey, so you're saying I need to delete compiz-kde4 and then install compiz from the 42 repo?
    If you go back to that screen:
    http://i198.photobucket.com/albums/a...snapshot16.png

    See the versions section. Select the radio button for the kde42 repo.
    Also, have you deliberately disabled the kde42 community and the mozilla?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Compiz update wants to downgrade to KDE 4.1

    Quote Originally Posted by caf4926 View Post
    See the versions section. Select the radio button for the kde42 repo.
    Also, have you deliberately disabled the kde42 community and the mozilla?
    Yes, I deliberately disabled them as I didn't want to get into a mess with all the repos conflicting on versions until I fully understood how it all works.
    Is it OK for them all to have a 99 priority as shown or should the 42 one have a higher priority than the update one?
    Also, what exactly is an unconditional update? Does it mean it ignores dependency issues or it updates whether there is a newer version of the file or not?
    I am now doing a update of all files if newer from the 42 repo. there were a lot of blue items showing.
    I'll also enable the KDE community and Mozilla repos.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Compiz update wants to downgrade to KDE 4.1

    Your priorities are fine 99 all round except oss, non-oss at 100

    Unconditional= It will update every package if that means a roll back then that's what it will do.
    When you have some conflicts, especially if you have version issues or red and blue updates mixed in a repo. This method will resolve most issues
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •