Results 1 to 6 of 6

Thread: Handbrake problems

  1. #1

    Default Handbrake problems

    I am very new to Linux...I think I am up to about 24 hours of use now. So, that being said, I know just enough to be dangerous considering I have been using Windows since the 80s.

    I was wanting to rip a couple of DVDs in order that I might store them on my HDD, but I can't seem to figure out what I have done wrong. I followed the instructions on downloading the source code and compliling the program, but when I ran it I got the following:

    checking for GHB... configure: error: Package requirements (gtk+-2.0 >= 2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10 gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage webkit-1.0 libnotify) were not met:
    :
    : No package 'webkit-1.0' found
    :No package 'libnotify' found
    :
    : Consider adjusting the PKG_CONFIG_PATH environment variable if you
    : installed software in a non-standard prefix.
    :
    : Alternatively, you may set the environment variables GHB_CFLAGS
    : and GHB_LIBS to avoid the need to call pkg-config.
    : See the pkg-config man page for more details.
    :
    : gmake: *** [gtk/.stamp.configure] Error 1
    -------------------------------------------------------------------------------
    time end: Sun Jul 26 22:08:29 2009
    duration: 24 minutes, 13 seconds (1453.67s)
    result: FAILURE (code 2)


    I don't really understand what this is telling me, nor what I should do from this point in order to make this program work.

    I'm running SUSE 11.1 on an older pentium 4 with 1GB memory.

  2. #2

    Default Re: Handbrake problems

    These messages tell you what development libraries you need in order to compile it. If it tells you the name then search for that package with YaSY/zypper/other **** with -devel attached in its name

    BUT first hava a look if your application isn't in the repo first

    Most popular applications are already in the repo.

    For packages search here:

    http://software.opensuse.org/search

    P.S. And have a read here

    http://en.opensuse.org/Compiling_software
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3
    brassy NNTP User

    Default Re: Handbrake problems

    whoa...despite what you may have heard it is NOT required to compile
    all the software we wanna run....nope!

    use YaST to install k3b (a full feature ripper AND CD/DVD burner)

    to learn about YaST and other ways to 'manage software' see
    http://en.opensuse.org/Concepts as a new guy here you will find the
    enter section useful (so bookmark it), but for now you really need to
    read all of section 4...

    oh, and before you install k3b it is probably best to follow the bread
    crumbs of http://opensuse-community.org/Restricted_Formats to install
    your codecs required for mp3 and others...

    this ain't your grandpappy's operating system!
    --
    brassy

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,357
    Blog Entries
    15

    Default Re: Handbrake problems

    Quote Originally Posted by lance0802
    I am very new to Linux...I think I am up to about 24 hours of use now.
    So, that being said, I know just enough to be dangerous considering I
    have been using Windows since the 80s.

    I was wanting to rip a couple of DVDs in order that I might store them
    on my HDD, but I can't seem to figure out what I have done wrong. I
    followed the instructions on downloading the source code and compliling
    the program, but when I ran it I got the following:

    checking for GHB... configure: error: Package requirements (gtk+-2.0 >=
    2.10 gthread-2.0 gstreamer-0.10 gstreamer-interfaces-0.10
    gstreamer-video-0.10 gstreamer-pbutils-0.10 gio-2.0 hal hal-storage
    webkit-1.0 libnotify) were not met:

    :

    : No package 'webkit-1.0' found

    :No package 'libnotify' found

    :

    : Consider adjusting the PKG_CONFIG_PATH environment variable if you

    : installed software in a non-standard prefix.

    :

    : Alternatively, you may set the environment variables GHB_CFLAGS

    : and GHB_LIBS to avoid the need to call pkg-config.

    : See the pkg-config man page for more details.

    :

    : gmake: *** [gtk/.stamp.configure] Error 1

    -------------------------------------------------------------------------------

    time end: Sun Jul 26 22:08:29 2009
    duration: 24 minutes, 13 seconds (1453.67s)
    result: FAILURE (code 2)


    I don't really understand what this is telling me, nor what I should do
    from this point in order to make this program work.

    I'm running SUSE 11.1 on an older pentium 4 with 1GB memory.
    Hi
    I have packaged up a src rpm awhile back.....
    <http://www.fileden.com/files/2009/4/6/2393623/RPMs/handbrake-0.9.3-svn20090709.1.src.rpm>

    Here are the BuildRequires;
    Code:
    BuildRequires:  gcc yasm gcc-c++ libbz2-devel zlib-devel
    BuildRequires:  intltool autoconf automake libtool glib2-devel
    BuildRequires:  gstreamer-0_10-devel gstreamer-0_10-plugins-base-devel
    BuildRequires:  libnotify-devel gtkhtml2-devel libwebkit-devel
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
    up 10:16, 2 users, load average: 3.44, 1.80, 0.83
    GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14


  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,357
    Blog Entries
    15

    Default Re: Handbrake problems

    Hi
    If anyone is interested I've put a later svn build up;
    <http://www.fileden.com/files/2009/4/6/2393623/RPMs/handbrake-0.9.3-svn20090808.1.src.rpm>

    Changes were;
    - svn revision 2755
    - build for 11.2 with updated libwebkit requirement
    - added latest contrib downloads

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
    up 7 days 17:29, 2 users, load average: 0.10, 0.13, 0.14
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,357
    Blog Entries
    15

    Default Re: Handbrake problems

    Hi
    I've updated to svn 2797 and also placed some 11.1 gtk builds for 32 and
    64bit here;
    <http://www.fileden.com/files/2009/4/6/2393623/RPMs/handbrake-0.9.3-svn20090831.1.src.rpm>
    <http://www.fileden.com/files/2009/4/6/2393623/RPMs/openSUSE_11_1/handbrake-gtk-0.9.3-svn20090831.1.x86_64.rpm>
    <http://www.fileden.com/files/2009/4/6/2393623/RPMs/openSUSE_11_1/handbrake-gtk-0.9.3-svn20090831.1.i586.rpm>

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 22:11, 2 users, load average: 0.37, 0.44, 0.66
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18
    Last edited by malcolmlewis; 31-Aug-2009 at 18:06. Reason: Fix url error

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •