Results 1 to 10 of 10

Thread: MYTH TV IS KILLING ME...

  1. #1

    Default MYTH TV IS KILLING ME...

    Okay,

    I am trying to install and configure mythtv(ugh)

    So I have installed the drivers for my tv card and it seems to be working.
    I have also installed mythtv both frontend and backend, mysql, and configured them. They also seem to be working just fine...

    Now I am working on installing the plugins, so I downloaded the mythplugins tarball and ran ./configure

    This is the part that giving trouble.

    I run ./configure and get this error about missing libraries...

    Code:
    linux-b1s9:/home/gehrig/Desktop/mythplugins-0.21 # ./configure
    which: no sdl-config in (/opt/kde3/bin:/home/gehrig/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    MythMusic requires libmad.
    MythMusic requires vorbis.
    MythMusic requires FLAC.
    MythMusic requires libcdaudio.
    MythMusic requires the LAME mp3 encoder.
    ./configure: line 488: taglib-config: command not found
    MythMusic requires taglib 1.4 or later.
    Disabling MythMusic due to missing dependencies.
    Disabling MythGallery due to missing libtiff.
    Disabling MythZoneMinder. Requires mysql/mysql.h header
    Disabling MythBrowser due to missing KDE development packages.
    ERROR: mythconfig.mak not found at /usr/local/include/mythtv/mythconfig.mak
    Did you make AND install MythTV first?
    Are you using the correct prefix (/usr/local)?
    Bailing out!!
    the problem is these libraries are installed for example libtiff... sudo zypper install libtiff yields
    Code:
    Loading repository data...
    Reading installed packages...
    'libtiff3' providing 'libtiff' is already installed.
    Resolving package dependencies...
    Nothing to do.
    all of the libraries are like this (except the KDE dev ones as I don't know which ones to install) aslo there is no directory /usr/local/include/mythtv/

    I'm really confused is there a way to get mythplugins to recognize the libraries installed? Is there a pre compiled RPM for SUSE so I don't have to deal with this.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,672
    Blog Entries
    15

    Default Re: MYTH TV IS KILLING ME...

    Quote Originally Posted by jgehrig
    Okay,

    I am trying to install and configure mythtv(ugh)

    So I have installed the drivers for my tv card and it seems to be
    working.
    I have also installed mythtv both frontend and backend, mysql, and
    configured them. They also seem to be working just fine...

    Now I am working on installing the plugins, so I downloaded the
    mythplugins tarball and ran ./configure

    This is the part that giving trouble.

    I run ./configure and get this error about missing libraries...


    Code:
    --------------------

    linux-b1s9:/home/gehrig/Desktop/mythplugins-0.21 # ./configure
    which: no sdl-config in
    (/opt/kde3/bin:/home/gehrig/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    MythMusic requires libmad. MythMusic requires vorbis.
    MythMusic requires FLAC.
    MythMusic requires libcdaudio.
    MythMusic requires the LAME mp3 encoder.
    ./configure: line 488: taglib-config: command not found
    MythMusic requires taglib 1.4 or later.
    Disabling MythMusic due to missing dependencies.
    Disabling MythGallery due to missing libtiff.
    Disabling MythZoneMinder. Requires mysql/mysql.h header
    Disabling MythBrowser due to missing KDE development packages.
    ERROR: mythconfig.mak not found
    at /usr/local/include/mythtv/mythconfig.mak Did you make AND install
    MythTV first? Are you using the correct prefix (/usr/local)?
    Bailing out!!

    --------------------


    the problem is these libraries are installed for example libtiff...
    sudo zypper install libtiff yields

    Code:
    --------------------

    Loading repository data...
    Reading installed packages...
    'libtiff3' providing 'libtiff' is already installed.
    Resolving package dependencies...
    Nothing to do.

    --------------------


    all of the libraries are like this (except the KDE dev ones as I don't
    know which ones to install) aslo there is no directory
    /usr/local/include/mythtv/

    I'm really confused is there a way to get mythplugins to recognize the
    libraries installed? Is there a pre compiled RPM for SUSE so I don't
    have to deal with this.
    Hi
    Add the packman repository Normally when compiling you need the
    <somename>-devel versions installed.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
    up 3 days 6:40, 2 users, load average: 0.19, 0.25, 0.23
    GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14


  3. #3

    Default Re: MYTH TV IS KILLING ME...

    Thanks for the tip, I should have thought of that.

    Now I am still getting these errors:
    Code:
    which: no sdl-config in (/opt/kde3/bin:/home/gehrig/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    Disabling MythZoneMinder. Requires mysql/mysql.h header
    Disabling MythBrowser due to missing KDE development packages.
    ERROR: mythconfig.mak not found at /usr/local/include/mythtv/mythconfig.mak
    Did you make AND install MythTV first?
    Are you using the correct prefix (/usr/local)?
    Bailing out!!
    Also what are the KDE development libraries that i need?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,672
    Blog Entries
    15

    Default Re: MYTH TV IS KILLING ME...

    Quote Originally Posted by jgehrig
    Thanks for the tip, I should have thought of that.

    Now I am still getting these errors:

    Code:
    --------------------
    which: no sdl-config in
    (/opt/kde3/bin:/home/gehrig/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    Disabling MythZoneMinder. Requires mysql/mysql.h header Disabling
    MythBrowser due to missing KDE development packages. ERROR:
    mythconfig.mak not found at /usr/local/include/mythtv/mythconfig.mak
    Did you make AND install MythTV first? Are you using the correct prefix
    (/usr/local)? Bailing out!!

    --------------------


    Also what are the KDE development libraries that i need?
    Hi
    If you use YaST software management and filter on 'patterns' there
    should be an option to select the KDE Development.

    mysql.h = mysql-devel
    sdl-config = SDL-devel

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
    up 3 days 7:39, 2 users, load average: 0.79, 1.17, 0.63
    GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14


  5. #5

    Default Re: MYTH TV IS KILLING ME...

    I figured it out...

    I found that mythconfig.mak is provided by libmyth-devel(I think)
    suse however uses the directory /usr/include/mythtv
    so i created a symlink at /usr/local/include/mythtv/mythconfig.mak pointing to /usr/include/mythtv/mythconfig.mak


    This seemed to work.

    I am however still stuck on mythbrowser I have installed qt3-devel and all it's dependencies but mythbrowser is still compaining about missing kde devel libraries... Confusing

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,672
    Blog Entries
    15

    Default Re: MYTH TV IS KILLING ME...

    Quote Originally Posted by jgehrig
    I figured it out...

    I found that mythconfig.mak is provided by libmyth-devel(I think)
    suse however uses the directory /usr/include/mythtv
    so i created a symlink at /usr/local/include/mythtv/mythconfig.mak
    pointing to /usr/include/mythtv/mythconfig.mak


    This seemed to work.

    I am however still stuck on mythbrowser I have installed qt3-devel and
    all it's dependencies but mythbrowser is still compaining about missing
    kde devel libraries... Confusing
    Hi
    What about kdelibs3-devel?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
    up 0:33, 2 users, load average: 8.93, 7.35, 4.70
    GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14


  7. #7

    Default Re: MYTH TV IS KILLING ME...

    ok ./configue worked

    But now another problem arises

    My computer doesn't seem so happy

    when I try to make, I get this...

    This is only the part Konsole will let me copy as it is truncated because it is too long.

    cl1p.net

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,672
    Blog Entries
    15

    Default Re: MYTH TV IS KILLING ME...

    Quote Originally Posted by jgehrig
    ok ./configue worked

    But now another problem arises

    My computer doesn't seem so happy

    when I try to make, I get this...

    This is only the part Konsole will let me copy as it is truncated
    because it is too long.

    'cl1p.net' (http://cl1p.net/jgehrigmythtv)
    Hi
    I would say if there are lots of errors like that it probably requires
    patching for gcc 4.3. Why not grab the plugins from packman, else grab
    the src rpm and build it from that?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
    up 1:17, 2 users, load average: 0.15, 0.82, 1.57
    GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14


  9. #9

    Default Re: MYTH TV IS KILLING ME...

    I couldn't find the mythplugins package on packman...
    Is there something I am missing? Maybe a diffferent name in the suse repos for the RPM?

    I couldn't even find an RPM for Fedora or any other RPM based distro.

    Looks like I might have to give up if I can't figure out how to compile it.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,672
    Blog Entries
    15

    Default Re: MYTH TV IS KILLING ME...

    Quote Originally Posted by jgehrig
    I couldn't find the mythplugins package on packman...
    Is there something I am missing? Maybe a diffferent name in the suse
    repos for the RPM?

    I couldn't even find an RPM for Fedora or any other RPM based distro.

    Looks like I might have to give up if I can't figure out how to compile
    it.
    Hi

    http://packman.links2linux.org/package/mythplugins
    http://packman.links2linux.org/package/mythtv

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
    up 12:10, 2 users, load average: 1.39, 0.72, 0.35
    GPU GeForce 8600 GTS Silent - Driver Version: 185.18.14


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •