Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

  1. #1
    Join Date
    Nov 2008
    Location
    Belem, Para, Amazonia, Brazil
    Posts
    85

    Unhappy Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    Hey guys,

    I have here OpenSUSE 11.1 64 bits running with KDE 4.1.3 updated.
    I am having these lockups with keyboard and mouse. I have this issue
    no matter if Compiz is enabled or not, but the locks are different if
    it is enabled.

    When I had Compiz disabled, the keyboard used to lock randomly but I
    could close windows, save documents, and logout of session with the
    mouse (although I could not close Firefox with more the one table opened).


    After had update Compiz, I decided to give a try (before I could never
    get windows decoration), and now it is running good with Emerald
    decorations. But, some times the keyboard and mouse stop working.
    No caps look respond, the cursor can move, but the click does not
    work. The screen works ok, I can see things continue to work, as aMSN,
    for instance, I can see when my friends get on line. I can also continue
    listening to music. I can either shut down the laptop if I press the power
    button, but only if I do not have applications running with unsaved data.
    Theses lockups had happened some times when scrolling in Firefox,
    others when I was watching movie in SMplayer, but most of
    them happened randomly.

    I am afraid this happens because the Intel driver. It is probably one more
    bug of the thousands that the Intel driver has! My laptop's graphics adapter
    is a Intel GM 965, unfortunately!

    I had tried to add the 'Option "AccelMethod" "XAA"' and
    'Option "XAANoOffscreenPixmaps" "true"' from the Compiz Trobleshooting
    (Compiz Troubleshooting - openSUSE),
    but the lockups did not stopped to happen!

    So, any one has this issue? Any workaround?
    Any help is welcome!

    Bye.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    I have the Intel 965 and TBH it's flawless. Darn thing works better than my box's nvidia.
    I only use native compiz with kwin, (I say ONLY - But it's fantastic).
    No extras in anyway towards X11
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Nov 2008
    Location
    Belem, Para, Amazonia, Brazil
    Posts
    85

    Default Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    Quote Originally Posted by caf4926 View Post
    I have the Intel 965 and TBH it's flawless. Darn thing works better than my box's nvidia.
    I only use native compiz with kwin, (I say ONLY - But it's fantastic).
    No extras in anyway towards X11
    I am happy for you! This is really wonderful. Maybe you could post your
    xorg.conf here, so I could take look and try find if there is any thing wrong
    with mine. What do you think?

    While this, I would tell you that my video adapter has the most buggy driver
    in the World!!! My laptop does not suspend neither to RAM or disk
    because this driver! I still have problems with games, scrolling on Firefox,
    and watching movies. But none of these problems are more annoying then
    random locks that make me stop working or "having a lot of fun".

    I would be more worried if these bugs were present only in my system,
    but a small search in Google can make me not fell alone! For example,
    here follow just some bugs of the thousands that you can found with
    Intel 965 GM:

    https://bugs.launchpad.net/ubuntu/+s...el/+bug/390023

    https://lists.linux-foundation.org/p...ry/013305.html

    https://bugzilla.redhat.com/show_bug.cgi?id=469472

    #513063 - xserver-xorg-video-intel: Screen lockup on Dell Studio with AUO LVDS panel - Debian Bug report logs

    So, there are a lot of bugs in drivers for Intel graphics adapter to be fixed
    up. But here, let us try focus on the locks I have been experiencing. So,
    if someone has Intel GM 965 working fine in his/her system, this is great.
    But, please, do not waste time posting here that every thing is fine!!!
    This is what was supposed to be. Let us just discuss about the "not
    normal behaviors" of our hated Intel cards!!!

    Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    As you requested. I can see this driver issue has quite upset. Hope this helps

    Code:
    cat /etc/X11/xorg.conf
    # /.../                                                     
    # SaX generated X11 config file                             
    # Created on: 2009-05-10T20:35:19+0100.                     
    #                                                           
    # Version: 8.1                                              
    # Contact: Marcus Schaefer <sax@suse.de>, 2005              
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #                                                                             
    # Automatically generated by [ISaX] (8.1)                                     
    # PLEASE DO NOT EDIT THIS FILE!                                               
    #                                                                             
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"        
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"          
      FontPath     "/usr/share/fonts/URW"            
      FontPath     "/usr/share/fonts/Speedo"         
      FontPath     "/usr/share/fonts/PEX"            
      FontPath     "/usr/share/fonts/cyrillic"       
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"          
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled" 
      FontPath     "/usr/share/fonts/baekmuk:unscaled"      
      FontPath     "/usr/share/fonts/japanese:unscaled"     
      FontPath     "/usr/share/fonts/kwintv"                
      FontPath     "/usr/share/fonts/truetype"              
      FontPath     "/usr/share/fonts/uni:unscaled"          
      FontPath     "/usr/share/fonts/CID"                   
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"     
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"    
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"   
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"  
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled" 
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"          
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"     
      FontPath     "/usr/share/fonts/xtest"                 
      FontPath     "/opt/kde3/share/fonts"                  
      InputDevices "/dev/gpmdata"                           
      InputDevices "/dev/input/mice"                        
    EndSection                                              
    
    Section "ServerFlags"
      Option       "AIGLX" "on"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"        
    EndSection                              
    
    Section "Module"
      Load         "dri"
      Load         "dbe"
      Load         "freetype"
      Load         "extmod"  
      Load         "glx"     
    EndSection               
    
    Section "InputDevice"
      Driver       "kbd" 
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "gb"     
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"     
    EndSection                              
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "EmulateWheel" "on"       
      Option       "EmulateWheelButton" "2"  
      Option       "InputFashion" "Mouse"    
      Option       "Name" "IBM;TPPS/2 TrackPoint"
      Option       "Protocol" "explorerps/2"     
      Option       "Vendor" "Sysp"               
      Option       "ZAxisMapping" "4 5"          
    EndSection                                   
    
    
    Section "Monitor"
      DisplaySize  331 207
      HorizSync    30-62  
      Identifier   "Monitor[0]"
      ModelName    "LENOVO LCD MONITOR"
      Option       "DPMS"              
      Option       "PreferredMode" "1280x800"
      VendorName   "LEN"                     
      VertRefresh  43-60                     
      UseModes     "Modes[0]"                
    EndSection                               
    
    
    Section "Modes"
      Identifier   "Modes[0]"
      Modeline      "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
      Modeline      "1280x800" 69.75 1280 1328 1360 1440 800 803 809 823 +HSync -Vsync
    EndSection                                                                        
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15     
        Modes      "1280x800" 
        Virtual    3840 1200  
      EndSubSection           
      SubSection "Display"    
        Depth      16         
        Modes      "1280x800" 
        Virtual    3840 1200  
      EndSubSection           
      SubSection "Display"    
        Depth      24         
        Modes      "1280x800" 
        Virtual    3840 1200  
      EndSubSection           
      SubSection "Display"    
        Depth      8          
        Modes      "1280x800" 
        Virtual    3840 1200  
      EndSubSection           
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection                 
    
    
    Section "Device"
      BoardName    "965 GM"
      Driver       "intel"
      Identifier   "Device[0]"
      Option       "monitor-LVDS" "Monitor[0]"
      VendorName   "Intel"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
      Option       "Composite" "on"
    EndSection
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Nov 2008
    Location
    Belem, Para, Amazonia, Brazil
    Posts
    85

    Default Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    Hi,

    Thanks for the reply. My xorg.conf was not too different from yours. But I decided to change some sections. The sections "Modes", "Screen" and "Device" are exactly like yours now. Before they were

    Code:
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        Virtual    3840 1200
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
        Virtual    3840 1200
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "965 GM"
      Driver       "intel"
      Identifier   "Device[0]"
      Option       "XAANoOffscreenPixmaps" "true"
      Screen       0
      VendorName   "Intel"
    EndSection
    Well, I do not hope this work since there are not too many differences between how the file was before and how it is now. I have tried suspend to RAM, but unfortunately it did not work. Any way, while no one seems to have the answer I hope having luck of editing xorg.conf make these lockups stop, but I do not believe that too much!

    According to your signature, your system is 32 bit, while I am working on a 64 bit system. I think this can make a bit difference, can't it?

    Thanks.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    I am working on a 64 bit system. I think this can make a bit difference, can't it?
    I don't know. Seems unlikely but......
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Nov 2008
    Location
    Belem, Para, Amazonia, Brazil
    Posts
    85

    Thumbs down Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    Hi,

    Well, editing the xorg.conf does not work. The lockups still happen!

    Any other suggestions?

    Bye.

  8. #8
    Join Date
    Nov 2008
    Location
    Belem, Para, Amazonia, Brazil
    Posts
    85

    Exclamation Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    Hi,

    I have realized today that the lockups I have been experiencing happen
    at the same moments the laptop screen auto locks. These screen locks
    happens even if there are mouse or keyboard activities. I could disable
    these screen locks in the past looking at some posts. But today, trying
    get my problem solved, I got they back.

    So, every time that these screen locks are to happen, there is a
    message in the right top of the screen saying the screen is being
    locked by the power manager. If I am using the keyboard just in this
    moment, the last typed word repeats around three times. But, if I
    am using the mouse, both keyboard and mouse freezes!

    This seems to be a issue just with the Intel GM 965 graphics adapter.
    I use I desktop at work with the following graphics integrated card:

    Code:
    00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)
    and it works wonderful. Every thing works with this card, from suspend to
    playing Assault Cube.

    So, any ideas?

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    Disable all screen power management
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Nov 2008
    Location
    Belem, Para, Amazonia, Brazil
    Posts
    85

    Default Re: Keyboard and mouse locks in KDE 4.1.3, 11.1_64!

    Quote Originally Posted by caf4926 View Post
    Disable all screen power management
    That is the point, I have already disabled it before, and because of it I could not realize that the system lockups was related to these screen auto locks! I mean, before I enabled again the screen managements, the system lockups had been happening. So, disabling them again it is not a solution.

    I think it is important to say that, although the screen managements was disabled, I always have had these randomly repeated words while typing up.

    Thanks again.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •