Results 1 to 6 of 6

Thread: Test of 2.6.30.2-1.1 kernel problem

  1. #1

    Default Test of 2.6.30.2-1.1 kernel problem

    my purpose was to test the new kernel for milestone 4 using the normal applications on an existing workstation to get an idea of potential problems of upgrading it from 11.1 to 11.2. This proved to be a bust trying to install the new kernel on a 11.1 machine.

    when i got to the point of reinstalling the ati proprietary drive i got a error "kernel-source" not found, thou in fact it was along with the linux-headers rpm.

    i am aware that the new kernel is built with a different version of gcc but am unsure if that is entirely the issue.

    any suggestions?

  2. #2
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: Test of 2.6.30.2-1.1 kernel problem

    You need the kernel-syms package.

    Cheers!

  3. #3
    Join Date
    Jun 2008
    Location
    Sarasota, Florida usa
    Posts
    807

    Default Re: Test of 2.6.30.2-1.1 kernel problem

    Quote Originally Posted by j_xavier View Post
    my purpose was to test the new kernel for milestone 4 using the normal applications on an existing workstation to get an idea of potential problems of upgrading it from 11.1 to 11.2. This proved to be a bust trying to install the new kernel on a 11.1 machine.

    when i got to the point of reinstalling the ati proprietary drive i got a error "kernel-source" not found, thou in fact it was along with the linux-headers rpm.

    i am aware that the new kernel is built with a different version of gcc but am unsure if that is entirely the issue.


    any suggestions?
    I get this error

    which: no XFree86 in (/home/dale/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)

    Error: ./default_policy.sh does not support version
    default:v2:i686:lib::none:2.6.30.2-1-pae; make sure that the version is being
    correctly set by --iscurrentdistro



    I am using the radeon driver which works about as good as the proprietary driver did with openSUSE 11.1
    Last edited by dale14846; 26-Jul-2009 at 20:36. Reason: editing

  4. #4

    Default Re: Test of 2.6.30.2-1.1 kernel problem

    Thanks for the info etech97, the kernel-syms (and all the devel packages it pulls with it) got rid of the "kernel-source not found" error. Unfortunately the module build tanked with a lot of other error messages that pretty much points to having the new gcc packages for it to build correctly.

    The radeonhd driver does well on this machine too, dale14846, and for the database workout i plan to do, it will suffice.

    thanks to you both for the help.

  5. #5
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: Test of 2.6.30.2-1.1 kernel problem

    I did a zypper update last night, and it appeared to have pulled the new gcc that you are looking for

    Cheers!

  6. #6
    Join Date
    Jun 2008
    Location
    Syros, Greece
    Posts
    214

    Default Re: Test of 2.6.30.2-1.1 kernel problem

    I don't think that ATI's proprietary driver works with 2.6.30 kernel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •