Results 1 to 7 of 7

Thread: install older MySQL version than mysql5

  1. #1
    oswalditsys NNTP User

    Question install older MySQL version than mysql5

    Hello,

    could someone tell me how to install Mysql 3.23.58 or Mysql 4 on an opensuse 11.1?

    I need an older version than v5 for a program which I can't get with support for the newest sql version :-(


    Tanks in advance!
    Michael

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: install older MySQL version than mysql5

    Get a binary distribution from mysql.com and install it somewhere which doesn't clash with mysql5, maybe /usr/local/mysql or something like that. You'll have to read it up at mysql.com.

    If there is no way to prevent the clash, you can always build it from source from mysql.com.

  3. #3
    oswalditsys NNTP User

    Default Re: install older MySQL version than mysql5

    tanks for your answer,
    ok, but the problem is i can't find any sources from the version 3.23.58!

    any idea?

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: install older MySQL version than mysql5

    Looks like MySQL AB don't distribute it any more. You may have to extract the source from an old distribution, e.g. the source RPM for this:

    mysql-3.23.58-1.i386 RPM

    I'm sure there will be other problems, finding compatible libraries, gcc versions, etc.

  5. #5
    oswalditsys NNTP User

    Default Re: install older MySQL version than mysql5

    thanks for your link!

    well, i think there will come more problems than i thought before... so i'd better should leave my fingers from this action

    i'm thinking about installing a very small and old distribution as an virtual machine and run the mysql 3.23 there... a bit complicated but this may work better

    thanks a lot for your posts!

  6. #6
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: install older MySQL version than mysql5

    If my memory serves me, there was a version 4.nn which was backwards compatible with earlier versions but, because of the security changes, they dropped backward compatibility with 5.

  7. #7
    JosephKK NNTP User

    Default Re: install older MySQL version than mysql5

    On Sun, 26 Jul 2009 12:46:02 GMT, ken yap
    <ken_yap@no-mx.forums.opensuse.org> wrote:

    >
    >Looks like MySQL AB don't distribute it any more. You may have to
    >extract the source from an old distribution, e.g. the source RPM for
    >this:
    >
    >'mysql-3.23.58-1.i386 RPM' (http://tinyurl.com/muc8ch)
    >
    >I'm sure there will be other problems, finding compatible libraries,
    >gcc versions, etc.


    The deconstruction of MySQL continues per Oracle wishes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •