Results 1 to 10 of 10

Thread: Cannot connect to adhoc network

  1. #1

    Default Cannot connect to adhoc network

    Hi All.. we are having a cable modem here... so what we do is one person connect to his laptop and creates a wireless adhoc network with ics enabled.. everyone else connects to that network... his operating system is windows xp... I have a dual boot system... I am able to connect in windows but failed to connect in opensuse..

    I tried to conenct using knetwork manager and by the traditional method... the network is getting detected but the connection is not getting established... tried with and without encryption....

    I have done the following checks.. please have a look at the results...

    1) lspci | less

    09:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
    0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

    2) lspci -n
    09:00.0 0200: 14e4:1698 (rev 10)
    0c:00.0 0280: 14e4:4315 (rev 01)

    3) dmesg | less
    usb 1-1: New USB device found, idVendor=0a5c, idProduct=4500
    usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    usb 1-1: Product: BCM2046B1
    usb 1-1: Manufacturer: Broadcom

    4) /usr/sbin/iwconfig

    lo no wireless extensions.

    eth1 IEEE 802.11 Access Point: Not-Associated

    eth0 no wireless extensions.

    5)sudo /usr/sbin/iwlist scan

    lo Interface doesn't support scanning.

    eth1 Scan completed :
    Cell 01 - Address: 02:21:5D:00:1B:0B
    ESSID:"sumesh"
    Mode:Ad-Hoc
    Frequency:2.412 GHz (Channel 1)
    Quality:5/5 Signal level:-40 dBm Noise level:-91 dBm
    Encryption keyff
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Cell 02 - Address: C6:BB:FC:85:47:6B
    ESSID:"SUNIL"
    Mode:Ad-Hoc
    Frequency:2.462 GHz (Channel 11)
    Quality:5/5 Signal level:-46 dBm Noise level:-92 dBm
    Encryption keyff
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s

    eth0 Interface doesn't support scanning.


    6)/sbin/ifconfig
    eth0 Link encap:Ethernet HWaddr 00:21:70:7E:91:9D
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:17

    eth1 Link encap:Ethernet HWaddr 00:22:5F:1D:A4:E7
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:17 Base address:0xc000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:550 errors:0 dropped:0 overruns:0 frame:0
    TX packets:550 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:41108 (40.1 Kb) TX bytes:41108 (40.1 Kb)

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Cannot connect to adhoc network

    sarin cv wrote:
    > Hi All.. we are having a cable modem here... so what we do is one person
    > connect to his laptop and creates a wireless adhoc network with ics
    > enabled.. everyone else connects to that network... his operating system
    > is windows xp... I have a dual boot system... I am able to connect in
    > windows but failed to connect in opensuse..
    >
    > I tried to conenct using knetwork manager and by the traditional
    > method... the network is getting detected but the connection is not
    > getting established... tried with and without encryption....


    I don't think that NetworkManager handles Ad-Hoc networks.

    My first suggestion is for you to take a collection and buy a wireless
    Access Point. That way you could use a Managed network, and you would
    not be dependent on the master XP machine running.

    If that is not possible, you will need to use the traditional ifup
    method. You should first copy /etc/sysconfig/network/ifcfg-template to
    /etc/sysconfig/network/ifcfg-eth1, then edit the latter to set _ALL_
    your preferences. In particular, you need to set the WIRELESS_MODE
    variable to "ad-hoc". If you did that before and it didn't work, then
    whichever driver you are using may not support ad-hoc mode.

  3. #3

    Default Re: Cannot connect to adhoc network

    wireless mode is already set to ad-hoc

    BOOTPROTO='dhcp4'
    BROADCAST=''
    ETHTOOL_OPTIONS=''
    INTERFACETYPE='wlan'
    IPADDR=''
    MTU=''
    NAME='BCM4312 802.11b/g'
    NETMASK=''
    NETWORK=''
    REMOTE_IPADDR=''
    STARTMODE='manual'
    USERCONTROL='no'
    WIRELESS_AP=''
    WIRELESS_AUTH_MODE='no-encryption'
    WIRELESS_BITRATE='auto'
    WIRELESS_CA_CERT=''
    WIRELESS_CHANNEL=''
    WIRELESS_CLIENT_CERT=''
    WIRELESS_CLIENT_KEY=''
    WIRELESS_CLIENT_KEY_PASSWORD=''
    WIRELESS_DEFAULT_KEY='0'
    WIRELESS_EAP_AUTH=''
    WIRELESS_EAP_MODE=''
    WIRELESS_ESSID='sumesh'
    WIRELESS_FREQUENCY=''
    WIRELESS_KEY=''
    WIRELESS_KEY_0=''
    WIRELESS_KEY_1=''
    WIRELESS_KEY_2=''
    WIRELESS_KEY_3=''
    WIRELESS_KEY_LENGTH='128'
    WIRELESS_MODE='Ad-hoc'
    WIRELESS_NICK=''
    WIRELESS_NWID=''
    WIRELESS_PEAP_VERSION=''
    WIRELESS_POWER='yes'
    WIRELESS_WPA_ANONID=''
    WIRELESS_WPA_IDENTITY=''
    WIRELESS_WPA_PASSWORD=''
    WIRELESS_WPA_PSK=''

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Cannot connect to adhoc network

    The template uses "ad-hoc", not "Ad-hoc". I don't know if it is case
    sensitive. If not, then it is a driver problem. Unfortunately, your
    card requires that you use an unsupported driver, thus we cannot help.


  5. #5

    Default Re: Cannot connect to adhoc network

    I am having Broadcom Corporation BCM4312 802.11 which most of the people use and connect wthout any issues...then why only me having problems...

    one doubt... The drivers available in linux for bcm4xxx card are opensource drivers or released by broadcom???

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Cannot connect to adhoc network

    sarin cv wrote:
    > I am having Broadcom Corporation BCM4312 802.11 which most of the people
    > use and connect wthout any issues...then why only me having problems...
    >
    > one doubt... The drivers available in linux for bcm4xxx card are
    > opensource drivers or released by broadcom???


    If your BCM4312 has PCI ID of 14e4:4312, then you can use the
    open-source driver b43. If it has ID 14e4:4315, then you must use the
    Broadcom wl driver, which is closed source. If the latter, we cannot
    help you with any problems in setting up an ad-hoc network as we
    cannot view the source.

  7. #7

    Default Re: Cannot connect to adhoc network

    unfortunately, I am having 14e4:4315... in the meanwhile I tried to make it work using ndiswrapper also...later I removed it from booting... but the problem now is, when i scan for networks, it says device does not support scanning...

  8. #8

    Default Re: Cannot connect to adhoc network

    I have installed broadcom-wl drivers from packman repo... still wireless is not working... The drivers listed in their website are dated may 1st... will it work for the latest linux kernels? can I get the updated version from somewhere else? I tried to compile that driver for my currenct kernel once and had failed... does anyone got a solution???

  9. #9
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Cannot connect to adhoc network

    sarin cv wrote:
    > I have installed broadcom-wl drivers from packman repo... still wireless
    > is not working... The drivers listed in their website are dated may
    > 1st... will it work for the latest linux kernels? can I get the updated
    > version from somewhere else? I tried to compile that driver for my
    > currenct kernel once and had failed... does anyone got a solution???


    Does the Broadcom driver load? Look at the output of lsmod to tell? Do
    you see any error messages in the listing that might pertain to wl?

    If you see any mention of ssb in the lsmod list, then you need to
    blacklist it. Modify (as root) /etc/modprobe.d/blacklist. The commands
    below will do the job:

    Code:
    su
    cp  /etc/modprobe.d/blacklist  /etc/modprobe.d/blacklist_save
    echo  "blacklist ssb"  >>  /etc/modprobe.d/blacklist
    /sbin/modprobe  -rv  wl
    /sbin/modprobe  -rv  ssb
    /sbin/modprobe  -v  wl
    exit
    BE VERY CAREFUL! During the execution of these commands, you will be
    logged in as root. Mistyping one of the entries could destroy your
    system. In particular, make sure you have the >> correct in the echo
    line. Please post the output from these commands.

    If you get the driver from Broadcom's web pile, you will definitely
    need to compile it. As that failed earlier, and you do not mention any
    corrective action, that will likely fail again.

  10. #10

    Default Re: Cannot connect to adhoc network

    sorry for the delay... i will check these things and post results asap

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •