Results 1 to 9 of 9

Thread: openSuse 11.2 Milestone 4 with Intel 945

  1. #1

    Default openSuse 11.2 Milestone 4 with Intel 945

    Hello!

    I have just installed openSuse 11.2 M4 with KDE on my laptop with intel 945GM, and I can't turn on composite extensions. Everything worked good on M3, but on M4 with the new intel driver (2.8.0) video doesn't work as it should. Maybe I have to give some parameters to the kernel on boot, or to change xorg.conf?
    Did someone try this release with intel chipset?

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: openSuse 11.2 Milestone 4 with Intel 945

    What is
    Code:
    lspci -v
    showing for the 945 section?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: openSuse 11.2 Milestone 4 with Intel 945

    Code:
    0:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
            Subsystem: Lenovo Device 2061                                                                                  
            Flags: bus master, fast devsel, latency 0                                                                      
            Capabilities: [e0] Vendor Specific Information <?>                                                             
            Kernel driver in use: agpgart-intel                                                                            
    
    00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])                                                                                                                                                           
            Subsystem: Lenovo Device 2062                                                                                                                        
            Flags: bus master, fast devsel, latency 0, IRQ 16                                                                                                    
            Memory at d0200000 (32-bit, non-prefetchable) [size=512K]                                                                                            
            I/O ports at 1800 [size=8]                                                                                                                           
            Memory at c0000000 (32-bit, prefetchable) [size=256M]                                                                                                
            Memory at d0300000 (32-bit, non-prefetchable) [size=256K]                                                                                            
            Expansion ROM at <unassigned> [disabled]                                                                                                             
            Capabilities: [90] MSI: Mask- 64bit- Count=1/1 Enable-                                                                                               
            Capabilities: [d0] Power Management version 2                                                                                                        
    
    00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
            Subsystem: Lenovo Device 2062                                                                                         
            Flags: bus master, fast devsel, latency 0                                                                             
            Memory at d0280000 (32-bit, non-prefetchable) [size=512K]                                                             
            Capabilities: [d0] Power Management version 2
    Maybe I have to turn on KMS? Or explicitly turn on the UXA option in xorg.conf?

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: openSuse 11.2 Milestone 4 with Intel 945

    There have been some issues with 945 chipsets

    You can see my 965 info here:

    Code:
    00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
            Subsystem: Lenovo T61                                                                 
            Flags: bus master, fast devsel, latency 0                                             
            Capabilities: [e0] Vendor Specific Information <?>                                    
            Kernel driver in use: agpgart-intel                                                   
            Kernel modules: intel-agp                                                             
    
    00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])                                                                                       
            Subsystem: Lenovo T61                                                                                     
            Flags: bus master, fast devsel, latency 0, IRQ 16                                                         
            Memory at f8100000 (64-bit, non-prefetchable) [size=1M]                                                   
            Memory at e0000000 (64-bit, prefetchable) [size=256M]                                                     
            I/O ports at 1800 [size=8]                                                                                
            Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Count=1/1 Enable-                           
            Capabilities: [d0] Power Management version 3                                                             
            Kernel modules: intelfb
    There have been some updates in mesa but how that translates in M4 I'm not sure.
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: openSuse 11.2 Milestone 4 with Intel 945

    Ok, thanks.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: openSuse 11.2 Milestone 4 with Intel 945

    I have just been trying M4 in Virtual Box and to boot I had to level 3 it, use the vesa switch as root and then startx
    Ick!
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: openSuse 11.2 Milestone 4 with Intel 945

    I'm sorry, but I don't understand what you mean...
    What is vesa switch?

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: openSuse 11.2 Milestone 4 with Intel 945

    Quote Originally Posted by YevgenyEfter View Post
    I'm sorry, but I don't understand what you mean...
    What is vesa switch?
    Like this:
    Installation Problem Suse 11 - openSUSE Forums

    to login as root, just type: root

    no password needed
    then enter the sax2 command

    wait..........then if necessary type: startx
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: openSuse 11.2 Milestone 4 with Intel 945

    Looks like my issue is related to yours. After update M3->M4 overall graphic performance dropper significally on my i965GM-powered laptop. Switching tabs in Firefox may take 2-4 seconds, scrolling is very sluggish. Other apps also suffers a lot. Something is wrong in new intel driver, I think.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •