Results 1 to 5 of 5

Thread: Update broken - Wrong Digest

  1. #1

    Default Update broken - Wrong Digest

    Hello

    Since yesterday (at least that's when I noticed) either updating or adding repository is not working. When I run online update, it gives warning "Wrong Digest" and also gives following warning.

    There was an error in the repository initialization.
    'openSUSE-11.1-Updates': [|] Failed to cache repo (4).
    History:
    - 'repo2solv.sh' '-o' '/var/cache/zypp/solv/openSUSE-11.1-Updates/solv' '/var/cache/zypp/raw/openSUSE-11.1-Updates'

    gzip: primary.xml.gz: not in gzip format

    gzip: susedata.xml.gz: not in gzip format

    gzip: updateinfo.xml.gz: not in gzip format
    repo_updateinfoxml: no element found at line 1:0

    Thanks in advance.

    Woojin

  2. #2
    brassy NNTP User

    Default Re: Update broken - Wrong Digest

    i guess: pick a mirror close to you from
    http://mirrors.opensuse.org/list/all.html

    or wait for the one which is temporarily NOT working to come back on
    line..

    --
    brassy

  3. #3

    Default Re: Update broken - Wrong Digest

    Hello.

    I tried other mirrors and got same issue.

    I removed all repositories in yast2 and did "rpmdb --rebuilddb".
    Then I added the 11.1 oss repo by issuing following command.
    "zypper addrepo Index of /distribution/11.1/repo/oss oss"

    Then when I try to refresh by "zypper ref"
    I get the following wrong digest error
    "Digest verification failed for dvd-11.1-71.1.i586.pat.gz. Expected 1e69c0fe3c858c38e01668372207c21cd8a7daa5, found 4a59fcad0e70adfe7eeb4e2b968b7bad3280755d. Continue? [yes/NO]:"

    I then tried the mirror site by
    "zypper addrepo Index of /opensuse/distribution/11.1/repo/oss/ oss" and "zypper ref" produced same error
    "Digest verification failed for dvd-11.1-71.1.i586.pat.gz. Expected 1e69c0fe3c858c38e01668372207c21cd8a7daa5, found cc335c3dc995bcee7e3eb66a9608be7d46321f9e. Continue? [yes/NO]:"

    Thanks in advance.

    Woojin

  4. #4

    Default Re: Update broken - Wrong Digest

    I found the problem.
    I had enabled the systemwide proxy using squid and dansguardian. That must have caused some sort of conflict. Disabling the system proxy fixed the issue.

    Thanks

    Woojin

  5. #5
    brassy NNTP User

    Default Re: Update broken - Wrong Digest

    > I found the problem.
    > I had enabled the systemwide proxy using squid and dansguardian. That
    > must have caused some sort of conflict. Disabling the system proxy
    > fixed the issue.


    i wonder how you discovered that solution?

    --
    brassy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •